Software update Cherry 1.6

Hi all,

We’re happy to announce that the Fairphone OS software update version 1.6 (named Cherry) is ready. Within the next two days, you should receive a notification on your phone to accept this update once you are connected to a Wi-Fi network. The software update will be available from your Fairphone Updater app, which will automatically check for the update every 24 hours. When updating, please make sure your phone is charged over 80% or plugged into an outlet.

For more information about this software update, look here.

Please ask questions and add comments in this thread!

Cheers,

Rick
Fairphone Support Team

5 Likes

Hi all,

The newsletters are out! All FP1 and FP1U owners should be receiving an e-mail in the next hour (mind the Spam folder). We look forward to rolling this software update out!

From another post, by @Remco:
https://forum.fairphone.com/t/outlook-for-next-software-update-august-2014/?source_topic_id=258

Unfortunately my FP update still shows 1.3 as current version even though I cleared the data from the updater app. Does this have anything to do with the 1.3 being installed form the image instead of OTA?

Same here… cleared data of the updater app as described, but still. My FP was off for a couple of days, so it should have displayed the new version also without cleaning. But nevertheless: no update available.

Patience :slight_smile: We wanted to let people have some time to read the newsletter and anticipate the update before it is sent over Wi-Fi. @Remco above was talking about his experience with a developer version from the XDA developers’ forum.

We’ll put the file package on our support site too so you can manually install if you prefer. Good to hear your excitement! Cheers-

2 Likes

Hi,

I called it a preview, but is was indeed a developer version from XDA forum, which was granted so that the development team could get early feedback. Sorry for the confusion :smile:

The developer version needs to be installed through recovery mode of the phone, so waiting for a streamlined OTA update is probably better from this moment on I guess as it will follow very soon.

2 Likes

Thanks @joe :smiley:

Now the update is being displayed, but “install new version” is not starting anything. There’s just flashing something in the Manu bar and the screen remains unchanged. Do we still have to wait until the data is actually available OTA?

The update should now be available over-the-air (Wi-Fi). It sounds silly but can you tap “Install new version” a few times? Keep tapping… does it work? Sometimes the easy fix is restarting your phone, too.

@Stephan, can you confirm if you have FP1 or FP1U?

Hi there!

I tried to install 1.6 Cherry for the second time. After the restard I am still prompted to install the Update?!

The Updater still shows 1.5 and not 1.6 even though I did not get any error notice.

Best regards

phila

2 Likes

Hi guys,

I needed to install the update twice (maybe because of the Xposed/Xpiracy framework I use) but succeeded eventually.

I have a addition to the guide @ https://fairphone.zendesk.com/hc/en-us/articles/201295267-How-to-re-install-the-App-Store .
When you add the google apps widget to for instance Nova Launcher, you won’t be able to reinstall it after the upgrade to Cherry 1.5.

You need to be in the default launcher to be able to use the widget, to do this:

  1. Go to settings, apps, your custom laucher
  2. Reset default values
  3. Press home button
  4. Select Fairphone OS
    (4.5. Put “install google apps”-widget back)
  5. Install Google apps again.

Hope this helps some of you.

Cheers!

Tapped two times. Now it’s installing.

Cheers!

Update:

1.6 now installed - after downloading from database ant NOT via updater prompt.

Best regards

phila

After rebooting the phone all worked. I’m back with 1.6/1.4 :slight_smile:

@anon90052001 I have a first Edition FP, if this is what you wanted to know…

1 Like

Okay - Update worked. AOSP keyboard crashed permanently until Google Apps were installed.

Now I’m trying to find a way to partitionize my phone - Can someone please help me out?

Cheers!

EDIT: Ok, found it myself: https://fairphone.zendesk.com/hc/en-us/articles/200887199-How-do-I-upgrade-to-the-unified-storage-partition-for-first-edition-Fairphone-owners-

Hi,

That’s correct, the AOSP keyboard will work again after the App store in reinstalled.

To create a unified partition, please read our support article on the support article: https://fairphone.zendesk.com/hc/en-us/articles/200887199-How-do-I-upgrade-to-the-unified-storage-partition-for-first-edition-Fairphone-owners-

Cheers

edit: good you found it already :slight_smile:

Hi all,

We recommend you install the new update through the Fairphone Updater app. If you are having problems getting the download to start, make sure you have at least 250 MB of free internal storage, and tap the Install button many times in a row. You can also try the steps described in here: https://fairphone.zendesk.com/hc/en-us/articles/201860198-I-see-no-software-update-sent-to-my-Fairphone-What-can-I-do-

If it for some reason still doesn’t work, you can install the update manually. Read here how to do this: https://fairphone.zendesk.com/hc/en-us/articles/202478028-Manually-install-Fairphone-OS-software-update-version-Cherry-1-6

Rick

Hi there fellow FP-users.

I had some trouble installing the new Fairphone update. I thought I might share my story, for people who encounter the same problem.

After opening the “Fairphone Updater”-application, it did tell me there was a new update. However, I tapped the button “Download Update” a dozen times and nothing happend. Eventually - after restarting my phone twice and mashing the button some more- , it actually started downloading. After downloading it said “Reboot to install” (or something similar).

At this point, I thought everything was fine. During the reboot this appeared on my screen.
That didn’t look so well. However, after taking out my battery and rebooting and re-trying the update, the problem still existed.

I did find a workaround. When the “No command”-screen shows up (to which I linked earlier) press the “Power” button on top once. You’ll get a screen with options. Press volume down until you have highlighted “Update from SD”. Confirm with volume up/ (Be careful: you can not use “Volume up” to navigate through the menu.).

After this, scroll down (again, with volume down) to “/Updater”. Confirm with “Volume up”. When you’re in this menu, you should see a .ZIP-file named something like “fairphone-update-1.4.zip”. Highlight this and, once again, confirm with “Volume up”.

When this is done, you should return to the ‘main menu’. Here you must select te first option from the menu (“reboot now”) and confirm with “volume up”. Now, your phone should restart and the update will be completed.

I don’t really know why this happend, but I’m glad I did find a workaround. If anyone encounters a similar problem, please let me know.

If anyone can explain why this did happen, I would be very grateful as well.

Kind regards,

Robin

EDIT: I’m currently unable to press anything in the new Fairphone Updater-app. So I can’t upgrade to the unified storage partition.

EDIT 2: After force quitting the Fairphone Updater-app and clearling all data, I was able to upgrade to the unified storage partition. Luckily, it all ends well :slight_smile: .

1 Like

Hi @Robin,

What method did you use to back up your device? We’ll pass on your feedback to our developers.