Software update Cherry 1.6

I got a notification that I could install the new FP-update. So I opened the FP Updater. It took a while before I could press on the ‘install’ button. After a while my phone went off, then there was the screen of the green Androidman telling me ‘installing system update’. Then it went black. After that my phone went back on. I got a notification that if I wanted to reinstall the App Store I needed to put the widget at the beginning screen. So I did. But the Google App installer stayed grey. I looked for info on the support pages. Followed the steps mentioned (so now I also lost all my widgets and couldn’t get them back on…). Even after all those steps it still stayed grey. Then suddenly I got again a notification that there is a software update available. So I went looking on the Fairphone OS app: it mentioned still version 1.1. So I did the whole installation proces again. And still have same result. Now again there is a notification that there is a software update available… So again I started the process. After getting the Androidman ‘installing system update’ is got a screen with something like ‘updating’ and then how many parts were still left. Phone started back up. Now I actually was able to reinstall with the Google Apps installer widget. Did do that. And then I went looking in the app of Fairphone OS: still is version 1.1??? So 2 questions: do I need to keep trying? And how do I get my widgets back? If I go to the 6 dots and then choose widgets and try to drag them to the starting screen they just open up the app and the widgets dissapears again. I also can’t find a widget back of some apps like Instagram?! Please help :slight_smile:

What I also do not understand: I’ve got my phone 1 week ago. Is it normal that there is version 1.1 on it??

Hi Lidwien,

With the partition update the phone now works with MTP (media transfer protocol).
This protocol is not standard supported by Linux, but there is a way to resolve this.
As just discussed on the phone I would like to direct you to the following website for more information on how to resolve this:

Here they explain how you co make your internal storage to be recognized again.


Lots of tapping to get the update to download. Somewhere between tapping quickly and slowly seemed to work. Had to try and download it twice.

All installed and works fine now though.

@Sietse Do you know what the idVendor and the idProduct numbers are for the Fairphone?

Deleting when using FPs own FileManager: Press (not just tap) the item you want to delete, and a waste paper basket should appear at the bottom of the screen. If you’re not allowed to delete some folders or files I guess you’ll have to install an app that make use of root privileges, e.g. X-plore.

In a way it makes sense that you can’t access the internal storage if that’s where the system files are placed. However, if repartitioning means that all 16 GB of phone storage are read as “Internal” and thus inivisible on a Linux computer (and probably on Windows as well), transferring files will be a clumsy affair, always using an external SD card as an intermediary. For me it will be a real problem, since my linux computer can’t see my external SD!

I’ll see if I can get the mtp alternative working on my slackware-based linux distro (found a slackbuild script for creating a mtpfs package).

Thanks Fairphone team,

not only the phone tries to be fair. Your update policy completly is…
It’s the 3rd update within half a year - i think there’s no other manufacturer supporting a product like this. In general you could be happy about geting at least one update…

All in all… happy to belong to the fairphone family =)


1 Like

Oh dear oh dear…

After two hours of wiping, reflashing 1.6 once again (and managing to install google apps this time) and setting up the phone I’m back where I started… There’s apps which won’t install/update due to inadequate free space (which is bollocks). I whish I had never done the partition change…

Examples of affected apps for me:

  • Öffi (Play store - won’t update)
  • CosyDVR (F-Droid)

Can anyone who did the upgrade try and confirm whether or not these apps work for them? Cheers!

After a lot of reading I found the solution.
Luckely I’m using Fedora. If I login with a XFCE-session I can’t see the internal storage.
If I login with a Gnome-session then my computer sees the internal storage.
Perhaps you can run a Gnome-session as well on your Linux-adapt and perhaps you’re lucky to.
At the USB computer connection;
Choose ‘MTP’ if you want to connect the internal storage
Choose ‘USB storage’ if you want to connect an external sd-card in your phone.

I’ve got the same problem. I’ve got a first edition FP and tried to update the phone several times. Basically the 1.6 version makes my FP unusable so I have to turn it off (trying to install an older version 1.3 in recovery mode failed for some reason but I’m too p… for another thousand attempts).
The following URL points to a little clip I’ve taken with my Pre3: .
Although the video quality isn’t that great you can see that it’s not attached to a cable. When enabling the phone it seems like the screen recognizes gazillions of touches even though my fingers aren’t nearby.
Since the previous version of the OS worked like a charm (at least for me) this must be a software bug.

Okay, now I found a fix for the insufficient storage space problem…

I installed Link2SD, went into settings and told it to install all new applications into the internal storage. Afterwards I could install an app which previously wouldn’t work. Out of curiosity I proceeded to remove Link2SD again - and, voila, installing/updating all the other apps still works. Must’ve been just some system setting which was corrected by Link2SD.
No idea what went wrong here in the first place when reformatting the internal memory, but now it finally works again as it should.

@ Herm56:
this is exactly what I experienced, both after the update from 1.1 to 1.4 and now again to 1.6
The solution was in both cases to delete the updates from both PlayStore & PlayServices, reboot the phone, and update them again.

No, I haven’t the gnome-session alternative available. Aftere installing mtpfs I can set up a MTP connection that gives me access to both the “Phone Storage” partition and the external SD card. With a USB storage connection I can only access “Phone Storage”. “Internal Storage” (the 1GB partition) is not accessible either way.
gMTP might be a possible solution, but I haven’t been able to find a version that runs on my slightly outdated distro.

Would a Live dvd of Fedora be an idea? Or created a Live usb.
Because then you don’t to alter your own Linux-adapt.
Choose when you login a Gnome-session.
Just a suggestion.

Yes, that’s a possible workaround albeit a bit clumsy. Another solution is replacing my current distro with Fedora - had a look at F20 some time ago and liked it. If no new version of my distro arrives the next few months I’ll probably take that step.

Hi @Lidwien this should do the trick for you:

Vendor is 0bb4 en product is 2008

And to be more precise: " Bus 002 Device 010: ID 0bb4:2008 HTC (High Tech Computer Corp.) "

Hope this helps you further.

1 Like

I could not get the 1.6 update to work after pressing about 50 times (at least) so I had to perform the manual update which worked smoothly. However since the update I always get the error ‘Unfortunately Bluetooth has stopped’ if I reboot with bluetooth on, if I reboot with bluetooth off then turn it on I will get the error. Curiously when it happens bluetooth seems to continue to work but once I see the error and turn BT off I usually cannot turn it back on again without a reboot.

I don’t want to brag but maybe ease those who still hesitate to update because all those unfortunate troubles collected in this thread…

My update went perfectly smooth as always and everything seems to still work fine!

(I haven’t updated to unified storage yet, though, as I re-partitioned my Fairphone months ago and am happy with my 7GB/7GB-partitions.)


I should add, I went with the unified storage partition install, it’s highly recommended. A bit of a pain to have to resetup the phone from scratch but the install was smooth and oh the space…

1 Like

thanks Rob! I deleted the updates, but this didn’t change the problem with GServices yet. I discover more and more Apps that won’t work now, for example:

and even Google Play Services itself. But this message I see more often, hope that anyone has a suggestion what to do.

I went looking for a button to update both, but couldn’t find it, so I went to look for manual updates. One suggestion I found is to manually force Google Play Store to update (see: But this doesn’t work with me.
Then I went looking for the latest version of GPStore on internet (which showed up to be 4.9.13, while on my phone it is 4.3.11), and downloaded and installed it manually. It downloaded ok, but the new version didn’t come up when opening GPStore, so probably is not compatible with the Android-version on our FP. And I still had messages about missing GServices when trying to update Apps. Tried to download a new App, which gave another message:

So I deleted the update again, hoping it updates itself sometime.

But now I’m stuck. Failing Apps, none can update, and new Apps can’t be downloaded. Seems a failing connection with a server. Suggestions welcome. Bug repairs too…