Google Play can't be re-installed after update, even after clearing data!

Hello everybody!

Before I describe my problem, I would like to confirm that I have already read this post and similar ones:

I got my Fairphone last Friday and I’m really happy with it!
However, I tried to update it and after that discovered that my Google Play Store App must have disappeared completely. I did what is described in the link above, I went to Apps/Fairphone OS and pushed the button “Clear data”. After that I tried to re-install the Google Apps installer, having read that the according icon from the widgets section should not be displayed in grey anymore. It didn’t work. I repeated this whole process 4 times, always restarting my phone again but nothing changed.
I have absolutely no idea how I can re-install my Google Play Store app again and I do now want to tidy up my apps again and again without any useful result.

I would be glad about every single hint that could help me! I apologize if I should have overlooked something obvious, rendering this whole posting superflous…

Hopeful greetings, Jessica

There are some people who had the same problem, apparently.

Hope the links do help. I ended up reflashing and restoring from backup. Afterwards, it did work. I suspect there are glitches in the Android matrix…

No need to apologise in advance. :slight_smile:

Thanks for replying so quickly!
Well, I don’t consider myself a complete moron, but I must admit that I don’t fully understand what the guys are talking about in some posts, I also don’t have any error messages, except the one that tells me, I should re-install Google Play. I don’t seem to get my update to work…
Ok, I saved my data onto my SD card… Can I really dare to restore the previous default settings from the very beginning? My data on the SD card will remain unaffected, right? Sorry, I’m a complete Fairphone Newbie!
It’s a bit frustrating to have such problems as playslists becoming empty and updates not working properly after only a few days of using my Fairphone… However, it’s worth the fact that I support a company like this that really tries to make an effort to change something in a positive way… :slight_smile:

Ok guys, I don’t have the faintest idea what happened, but after having tried to install the update for what felt like the zillionth time (without changing anything else at all) and restarting the phone again and again, it finally worked!!! :slight_smile: :slight_smile: :slight_smile: Now it seems to have the latest update, my Play Store is alive again and even the playlists I save seem to keep existing after a restart, hooray! :smiley:
Maybe the spirits of the android universe were in my favour…
Thanks for your answer anyway, dear Humorkritik!


Glad you got this working. This topic is now closed. New replies are no longer allowed.