Software update Cherry 1.6

I just tried to make a video from the display bug, but i could only send pictures here…

Hi Rick,

Thanks for your concern. Yes I upgraded from 1.3 with the Fairphone Uploader. And I have a first batch Fairphone. I made a small video to show you the flickering. The only “clear” screen is the start-screen with the Fairphone-Logo. How can I send you the video? The Upload-button doesn’t allow mp4.



I ran update and repartitioning yesterday and after restoring a backup with Ritanium nackup I ran into a problem with some apps (like cccleaner) aborting installation in the play store due to insufficient memory…

So I cleaned up gapps, reflashed 1.6 and now I want to reinstall gapps. The widget however fails to download the file with error 1004. Is the server down? Does anyone have a direct link to the zip file? I already tried flashing an older gapps file from 1.3 but that failed so I’m stuck at the moment.



This could be yes, but I can’t tell for sure. Besides clearing the data like you already did, make sure you are connected to a working WiFi network and try to reboot your phone. If by now you still didn’t receive the update, I recommend you to install the 1.6 update manually:


I am on a working wifi network and managed to reinstall the 1.6 update. Now I need to install gapps, which fails. Tried rebooting too. I’d even try downloading via my mobile data connection but it won’t let me, only works via wifi.


Thanks for sharing this info! Good it worked.

Originally the computer recognised two cards.

  • the phone storage (internal storage)
  • the extra sd-card of 16g I had put in the sd-cardslot.

Now after updating and partioning my computer only the extra sd-card.
As my back-up is on my computer I can’t restore my back-up.

Hi Isabelle,

Pictures are fine also, but if you could upload a video somewhere (Wetransfer for example) and send the link in a support request via we can have a more thorough look. Please mention my name in the support request, so my colleagues can send it to me if they see the request first.


Yes, it only works on wifi. About the Google Apps Installer widget, once you placed it on your homescreen is the text blue or greyed out? If it’s blue, try a different wifi network. If it is grey, please have a look here:

Hi Lidwien,

is it possible to
a) copy your back-up from your computer to your external SD card, and
b) restore from there?

How did you make your backup? For me, when using FPs own backup/restore app, the backup files are stored on the external SD card.

Installed the update and GPlay on my FP1 (had to take the alternative route, but that worked). Now logging in to my Gmail-account I get messages that “Google Play-services … is not supported by my device”:

After clicking OK I seem to be able to open and view my mailbox anyway, but the message will be annoying if it keeps coming up.

Bug? or did I miss some instruction?
Update seems ok until now, CONGRATS! But taking some time to test today.
Greetz, Herm

Hey Rick, i also updated from Version 1.3. to 1.6. I recieved the update yesterday over WIFI… I think, Isabelle discribed the same problems like me…

I’m trying to update a 2nd batch FP from 1.5 to 1.6, but it doesn’t work. I tried it 3 times already, twice from the main screen of the updater and once from the OS database. The software downloads and I get the Android installation screen for a couple of minutes, FP then restarts and I’m still with version 1.5.

VERRY happy with the unified storage partition!

1 Like


Are you sure you used the Google Apps Installer widget? And not the Play widget? Try again by dragging the Google Apps Installer widget to your homescreen.

Hi everybody,

I tried the update on my FP1U. Download is ok but if it wants to install I got the notice “Superuser für Fairphone updater verweigert” - in english it should be something like “Superuser for Fairphone updater denied”. Configuration for superuser should be to get a confimation screen. Whats going wrong?


At least update work for me with a first edition FP. Thanks for it

  • Update via updater works not expected, cause i couldn’t choose storage partition option. Normal installation just started… I was going on with manually installation.
  • Restore with backup app is not simple as it was descriped. Cause non free apps couldn’t be restored. Just have to download them again with customization

a) Yes. Now the original backup is placed on the external SD card
b) I can only copy, which I did. Now I have doubled the files.Like the file Alarms - empty and the file Alarms(0) contains the right information.

Do you know who to delete files by using the FileManager?

And still the computer doesn’t recognise the internal storage :frowning:

if you switch off wlan, the computer will recognize the internal storage, I think.

No, sadly switching off wlan, doesn’t help.