Switching from 1.6 with storage upgrade to stock android

I don’t seem to be able to switch from Fairphone OS 1.6 with storage upgrade to stock android. Has anyone else managed this? When I go to the updater app it shows stock android but it won’t start the update. If I try downloading the stock android zip and updating via recovery mode, the setup aborts after about 30 sec.

I’ve moved this to the Fairphone Help! category to make this easier for others in the community to find and help you out.

I think you could be interested in reading this post of mine.

In addition to what you can read there, I wonder if you have tried clicking on the Stock button a few more times.
I remember the first time I had to do so in order to go to the next screen where the download option is.

Thanks for your reply, van. I’ve had a read through your post and it
looks like it might help a bit.

When I hit the Stock button, it doesn’t do anything - even if I hit it a
few times. I’ve thought of two possible issues with what I’m trying to do:

  • Perhaps there isn’t a stock android rom which is compatible with the new
    storage arrangement?
  • Maybe I can’t apply and update from zip (through the recovery menu)
    because the stock rom is older? If I wipe the memory, before updating, this
    might work - but if the stock rom won’t install on a new memory arrangement
    I would brick the phone.

Try tapping on Stock, maybe a few times, then on Fairphone OS, if it goes to the next screen return back and try again Stock.

Try to hit anything more than once, it seems you have to hit it a few times before it wakes up.

@van - I’ve tried tapping on Stock and Fairphone OS within the OS library numerous times and nothing changes. I can select the summary more info button above but this doesn’t make any difference.

I have used the Fairphone Updater app several times in these first few days of testing and have noticed that on occasions to access the Stock subpage I needed some persistence.

Maybe the culprit is in the fact that you are on FP1 plus updates (or so I infer) while I am on a week old FP1U.

When you tried from recovery, did you choose the right package for your device/system?
Or maybe have you tried with some other package?

I think you might be right about the difference between trying FP1 and FP1U updates being the issue.

I used the FP1 Stock download from here: https://fairphone.zendesk.com/hc/en-us/articles/201576753-Fairphone-Stock-Android, so definitely the right one. Maybe the FP1U stock update would work since I’ve done the storage upgrade. My concern is that the fairphone hardware is slightly different and that might mean the ROM is incompatible.

The difference between the “FP1” and the “FP1U” software images has nothing to do with the hardware, but only with the different partition schemes. For an FP1 with the new partition layout, only the FP1U images will work (and will work perfectly fine, I can confirm this myself).

I personally think that should be clarified in the official helpdesk articles. The way it is now is confusing. Maybe replacing “FP1U” with “FP1U / FP1 with storage upgrade” would suffice?

1 Like

I did go from 1.6 to stock and wrote about it here. I have an FP1.

Thanks for your comments. I will try your suggestions when I have the time.