Software update Cherry 1.6

Hey guys. I heard of a issue when downloading the new update: download in the Fairphone OS Upater starts but abrupts shortly afterwards. Any suggestens for this problem except downloading it and install it manually (in safe mode)?

have a look at
good luck

Just installed Cherry, and reinstalled the Google app store. Now I doubt if I checked “remember choice forever” for the super user access. Can I verify this somehow? Ans correct this if it turns out to be incorrect?

Hi Frans,

We have a support article on the site about this:


Hi, i also got poblems with my graphics/screen showing almost the wrong resolution and ghost trails of previous views. Setting the phone in standby for a while sometimes clears the old away but i cant get the screen back in its full glory.

I had some issues when installing the 1.6 update and the uniformed partition update. My screen is not what it used to be. Its darker, the graphics is just like a closeup of an old TV - so there must be something wrong with the resolution, it got ghosted/spooky memories from old views. Setting the phone in standby sometimes clears out the ghosts. The screen also does not register touch correctly. I cant have more than one keyboard now - before i could switch while i write. I have not tested any GPS or Bluetooth, MMS or SMS yet but WiFi seemed to work fine. I have not reinstalled any apps yet either.

After installing the uniform update is it possible to install the 1.6 again to possible get rid of the problems? What is Chenipi-1.5 in the FP updater app?

I noticed after doing some configuration that the touch functionality was more damaged than i first thought. When entering the settings and all its checkboxes they get checked on and off randomly just lika a ghost whas hacking my phone - my phone is haunted! I need an exorcist!

Just noticed that all screenshots are looking OK…strange!

Reinstalled 1.6 - still bad graphics.
Booted in recoverymode made and made Step 6:
"Now, select “Wipe cache partition”, and wait till you see “Wipe cache complete”."
The screen looks good :slight_smile:
installing Google Play Store
The screen looks bad :frowning:
Wipe cache partition again
The screen looks good :slight_smile:
make the phone go to sleep and then wake it up
The screen looks bad :frowning:
I am out of options again
Installed JellyBean through the updater
The screen looks good :slight_smile:
make the phone go to sleep and then wake it up
The screen looks bad :frowning:
Made a factory reset after installing a google play apk that did not work
The screen looks good :slight_smile:
Keeping the good screen by setting the screen not to go to sleep for 30 min
Everything looks good sofar - dowloading and installing 1.6 again so i get the google play store back.
Lesson: dont let the screen go to sleep and jellybean seems to use less power as my battery lasted longer or maybe its the lack of installed apps - dont know.

I have the same problems too… I sent a video with this graphic problems to the customer care, and i am waiting now… If i will hear something, I’ll post as fast as i can…

had the same problem. I charged my phone while I tried to do the update and that seemed to be the reason for the problem.

And now, the problem still exists??? Only because that??

This didn’t work. The screen “Remember choice forever” didn’t appear. Now the Fairphone OS and the Fairphone updater are both gone from the list, and also gone from the trashbin. Superuser screen now says “there are no apps with root access” (my translation).
Do you have any further suggestions?

It’s a good thing that there are no apps with root access.
This means that the next time an app need root access, you will be asked again if you want to enable root access for that particural app.

With for example an update I grant Fairphone just for this time root access. In this way I know that I will be asked each time what I want.

Hey all,

are you using the FP1 orginail cover?
I discovered sometimes if I unplug the phone from the charger that it is unusable due to inresponsiveness or wrong responses of the touchscreen.
Rebooting the phone helped (if I got there) but what does the trick for me is just remove the protective case and put the phone back in.
I suspecct there is some static electricity which causes this.
But it helps for me :slight_smile:


@Samuel_Wyss and @Nordlig: just wanted to give you a quick update on the screen issues that appeared for you after the update: we passed on all the information and videos you all took to our developers - who are looking into a solution. Thanks for bearing with us here.

This seems to be an issue not many people are having, but if you do, please make sure to submit a support ticket through our website. That way we get to know the scope of the issue, if you have any details about the issue/videos - please include them- it really helps us find the fix.

@mgkoeln & @Rob_van_der_Does: I was getting annoyed of all specialised ITtalk here, so I stopped trying for a while. But the problem is still there, so here I am again.
I found out that I do have a widget Google Now, but only in the widget-section. As far as I know I used the Fairphone Launcher, and pressing the Google Now launcher it asks to be activated, so I suppose it’s not. But as it’s not in the list of Apps, I can’t delete it. Besides that according to GPStore it’s not installed, as it shows the option to Install.
Anyway, I need to do something to be able to use and update Apps, while some don’t work properly. And the ‘tip avoid issues…’ is closed for reactions.
GPStore and GPServices don’t show a ‘delete updates’ button anymore, so probably they need to be updated. But I can’t find out how, as I don’t see any button to update, Both of them don’t show in my Google Play store, so that’s no source. Should I delete GPServices and GPStore, is it safe, and how to proceed? ‘Stop’ and ‘deactivate’ give warnings about ‘unexpected behaviour of Apps’ so I was afraid of continuing. I would be grateful for any suggestion, or support link.

@Herm56: If you didn’t install the Google Now Launcher it definitely isn’t the cause of your problems. :wink:

I found this advice on some German message boards: In Android’s app settings menu go to “Google Play Store”, force stop the app and then delete the app data. Do the same with “Google Services Framework” and then re-boot. You’ll probably have to re-enter your Googlemail-adress when opening the Play Store again and then everything might work.

That is great. I have submitted a support ticket and are waiting a responce. I made some screendumps with the phone but to my surprise they were all great and showed a perfect screen instead of the dark spooky view I am presented with. I will try a diffrent camera and send the file with with the returning mail from support, unless you have another suggestion where I can send such moviefiles and images.

Thank you for your effort. I hope, you 'll find a solution as fast as you can… Greetings Samy

Thanks for this information! As my phone is still unusable, would it help, if I sent it back to you, so you can have a look on what is going on?

@mgkoeln thanks for your suggestion. Tried it, but to no effect. ‘No connection’ keeps coming up. Although it started to occur after the last Fairphone update, it seems to be a problem of Google Play store, as lots of people around the world on all kinds of devices reported the same for more then a year. Quite a few solutions are offered. Tried some of them from instructions on internet and YouTube too, like date and time selections, install a root manager and edit the ‘hosts’-file, but still no success. Search continues…

I couldn’t get the update started either.
After reading this I tapped the button like 10 times very quickly, then it finally started the download. :slight_smile: