GPS does not work

I have managed to update the EPO (it eventually worked via the built-in download process).

However, the phone still fails to locate any satellites. Am I to conclude that my phone’s GPS simply does not work? And if so, what steps can I take to rectify this? I don’t use my phone for much in the way of apps etc., but GPS is one of the things I do (want to) use it for.

Please advise.

But when you are outside without phone (no A-GPS) and data (no downloads) connection the GPS is still very very slow. It takes too long to find the satellites - also in firmware version 1.6. I am disappointed, sorry.

After I updated the epo file manually and trying to get satellites OUTSIDE it took like 2-3 minutes to get a “lock”. I managed to do that two times… no gsm or data connection.

1 Like

Robin’s workaround seems to have worked for me. Although I am not sure that I won’t need to do this every time the EPO files need updating (is that once a month)?

Is there a way to address this problem in the next update? Or is there something just wrong with my handset?

Hi there,

Although I’m not an expert: I think the EPO files are mostly usefull for the first fix. Or when you go to another country (far away) and than try and catch a GPS signal again. EPO files contain information about sattelite locations etc.

Kind regards

I’ve given up on the GPS now, on a recent trip to Glasgow the gps navigation was terrible, constantly jumping to roads near where I was driving, I eventually had to pull over and switch to my old Galaxy S2, At the weekend in Paris it was worse, in Glasgow I had a 3G connection, in Paris I had no 3g and no wifi and the GPS would not get a fix. Back home now I just tried turning off wifi and data connection and I see the same problem, 10 minutes so far and no fix, meanwhile I did the same on my S2 and it got a fix in 15 seconds.

This is really disappointing I rely on the GPS either for driving navigation or for finding my way around a strange city using offline google maps.

1 Like

Hi @Reid_Sommerville (and others)

I’m going to address this issue to the support team. If you want to you can also file a support ticket yourself, and see if they can help you out. Really sad that GPS is working so poorly for you guy.

Kind regards

Thanks, Robin, any videos or information I can supply I’ll be more than happy to, I should say I already performed all the EPO and A-GPS suggestions and had one day old EPO files.

Have you tried my suggestion as well? :slight_smile:

Hi yes I’ve tried that in the past when travelling more that 500 miles and it gives me faster fixes for a while, but then maybe the next day will take ages again. It doesn’t make a difference to the inaccuracy when driving though.

Once thing I notice is that when I use GPS Status and toolbox, sometimes it says ‘GPS Disabled’ even though the GPS is enabled and I see the symbol flashing in the top left.

I also experience issues when using GPS:
1- receiver seems to be very insensitive; when driving sometimes there are no fixes for quite a long time.
2- I seem to be driving in the fields along the highway quite often. And then all of a sudden I hop back on the road :smile:

Both issues have been present on all firmware revisions, also on the actual 1.6

is your phone charging while navigating?
i have troubles when connecting the Phone to the charger it will get no Fix for a long time… Unplugged it works better…

I indeed have always charger plugged in. Will try without next time.
If that would indeed improve things, this is a serious bug. Let’s hope this to be software and not hardware related.

I’m answering to this topic using this two version:
for English speaking people and for native German speaking (as I am)
Ich antworte in diesem Topic in 2 Versionen: für englischsprachige Menschen und für Menschen (wie ich) die Deutsch zur Muttersprache habe.

[English Version]
I received my FP last Sunday and especially the GPS setup took me some time to set everything up with free software (not using googleplaystore). There are a lot of how to do and proposals in different places on the net and I think the way I managed it could be helpful for others, simply because I succeeded at last :

  1. Installation fasterGPS.apk (from F-Droid) and setting it up with my dates (continent & country)
  2. Activate your GPS on the FP (if you haven’t so far) [update 14-09-28)
  3. Manuel installation using the advice described here:
    -> Download EPO files: EPO.DAT & EPO.MD5
  4. Installation of a Root capable Explorer, because to my knowledge the integrated FP Data Manager doesn’t have root access (I recommend SimpleExplorer from F-Droid) [update 14-09-28]
  5. Copy EPO.DAT & EPO.ND5 to the folder /data/misc
  6. Type on your phone *#*#3646633#*#* and ! don’t press the receiver - wait till you are in ‘EngineerMode !
  7. Swipe to the right until you reach the “Location” menu
  8. Select “Location Based Service
  9. Select “YGPS” and go on to the “Information” tab
  10. Press the buttons “hot”, “full” and “AGPS restart” in exactly that order
  11. Make sure you do this when you are outside and have a clear view to the air!
  12. Go back to the “satellites” sub menu and wait till you get a fix
  13. When you have a fix you can Close YGPS with the homebutton
  14. Using the freeware Satstat (download from F-Droid) and be happy everthing is working.

Kind regards
Rob Doc

[Deutsche Version]
Ich habe mein FP letzten Sonntag erhalten und insbesondere der GPS setup nahm ziemlich viel Zeit in Anspruch, vor allem, da ich freie software nutzen möchte (ohne den googleplsystore zu verwenden). Es gibt jede Menge Hinweise an verschiedenen Plätzen im Internet und ich dachte meine Vorgehensweise kann für andere hilfreich sein, da sie letztendlich erfolgreich war :

  1. Installation fasterGPS.apk (von F-Droid) und meine Angaben eingetragen (Kontinent & Land)
  2. GPS auf FP einschalten (falls noch nicht getan) [update 14-09-28]
  3. Manuelle Installation unter Verwendung dieser Hinweise: link s.o.
    Hinweise sind auf Englisch, daher hier kurzgefasst wie ich weiter vorgegangen bin
    -> Download EPO files: EPO.DAT & EPO.MD5
  4. Installation eines Root-fähigen Explorers, da der integrierte FP Data Manager meines Wissens keine Dateien in der Root anzeigt – auch wenn man versteckte Daten anzeigen aktiviert ( (Empfehlung: SimpleExplorer aus F-Droid Shop) [update 14-09-28]
  5. Kopieren der EPO.DAT & EPO.ND5 in den Ordner /data/misc
  6. Am Phone Zeichenfolge *#*#3646633#*#* eintippen und ! nicht den Hörer abnehmen, sondern kurz warten, bis man im ‘EngineerMode ist !
  7. Nach rechts wischen bis man sic him Menü “Location” befindet
  8. Auswählen “Location Based Service”
  9. Auswählen “YGPS” und zum Reiter “Information”
  10. Die Knöpfe “hot”, “full” und “AGPS restart” in genau dieser Reihenfolge drücken
  11. Sicherstellen, dass sich unter freiem Himmel aufhält (Garten reicht, muss kein Berg sei)
  12. Zurück klicken auf as Untermenü “satellites” und abwarten, bis man einen “Fix” bekommt
  13. wenn der “Fix” da ist (d.h. die Position bestimmt ist) YGPS mit dem Homeknopf (unten Mitte FP) beenden.
  14. Programm Satstat (download über F-Droid) starten und sich freuen.

Herzliche Grüße
Rob Doc

[Edited by Moderator: Updated the formatting for the engineer mode number so it displays correctly]


Thanks, RobDoc, that was a most helpful and detailed information. I’ll consider trying this, at least if things get worse.
For my own part I have noticed that GPS is not FP’s strength - it’s the only thing that worked better on my old HTC. But I have never had those really serious difficulties described in this thread. I may have to wait a minute or (aat worst) two for a fix but then it’s pretty stable. e.g. while driving and using Google Map’s navigator function.
Trying to download new EPO data files can be a nuisance and occasionally I’ve downloaded them manually.

After trying a lot downloading the files via PC and installing manually was for me the best (and only ;-)) way. I won’t use googleplaystore or the fix offered - I only want apps on the phone I hopefully understand what they do (and what not).

Triggered by this post I did a trip without the charger connected in the car. And indeed: GPS-behaviour is much better then. No more fix-loss observed and I’ve not been driving in the fields this time :smile:
Now the question is: what causes this? The current going through the USB-cable? Because it is on the top of the phone, so close to the receiver?
Any work-around for this, as a long trip without charging is a no-go?

I can report that my FP1 now does have working GPS, however it takes on average about 105 seconds (getting on for two minutes) to lock on to the correct location. I’ll try it later without the mobile networks contributing.

As has been said by others, the FP’s GPS is disappointing compared with previous phones (my HTC also locked on in about 15 seconds).

Would be great if this could somehow get fixed in the next update. Is there any way I can contribute to bug reporting or that sort of thing?


This has been reported to the support team. You can always open a support ticket yourself, but due to the multiple reports, I don’t really see that would be necessary. Unless you have specific problems that haven’t been reported here.

I wonder if it can have to do with the charger and thus related to the problem described here: Touchscreen Goes Crazy While Charging

Personally, I have not experienced that charging affects my gps - I use a bog standard 3rd party car charger - from Belkin, if I remember correctly.

It’s an interesting thought that the placement of the usb jack - on top - could add to this. I’ve always seen that as a design mistake, and it’s really annoying when you have the phone mounted on your car dashboard. Moving it to the bottom would be a great improvement.