Incredibly slow and inaccurate GPS

Just out of curiosity: if the MediaTek servers calculate the checksums wrongly, why on earth don’t they fix this? I would assume this would affect all MediaTek devices then - and they claim that’s about 30% of the Android market?

1 Like

My EPO update experiences:

  1. Right from the beginning, I turned off the automatic update function. I almost always disable all automatic updates on all computer-related stuff, partly to avoid unwanted data traffic, partly to be in control of my gadgets.
  2. Under previous FP OS versions, right up to and including 1.6, updating the EPO files manually has been more or less impossible (after twenty-something attempts it has sometimes worked). The FP1-EPO app solved this problem.
  3. After upgrading to 1.8, the built-in manual update function works perfectly, no doubt because of the switch from FTP to HTTP as described by @keesj here. So the FP1-EPO app is therefore not necessary.
  4. I have not noticed that enabling (updated) EPO files delays getting a first fix. On the contrary: I normally get a fix within 15-20 seconds, while it takes longer if I disable EPO.

This tip is a great tip. Now I understand why the gps is so slow in the car, but works fine outside. In the car I always connect the power. I tried it in the car without the usb power cable, and yes, a quick fix.
I always thought the metal roof of the car messed things up, but alas…
Now I just need to get a ferrit ring.
thanks a lot for the tip.

An alternative (easier) solution that might help:
With the Xposed framework and the GravityBox Module you can choose a 360 degree screen rotation, meaning that you can turn your phone upside down so that the power cable is attached at the ‘bottom’. Thus the interference may be reduced.
More about GravityBox here


Hello lovely people, I also have a pretty slow and often somewhat inaccurate GPS signal. I bought the latest Fairphone in Germany in January 2015. I only know EPO as a blood doping agent and I am generally clueless about anything involving computers, cell phones and remote controls. Is there any chance you can explain step by step what I need to do to get a better signal? My running app won‘t even work properly. Sigh.

Thank you so much, smart people! <3

this forum is only about the Fairphone, so either you have mistyped or you are in the wrong forum.

if you indeed have a fairphone you could install following apps to help your phone get a GPS fix faster:

  • FP1-EPO-Autoupdate to automaticly get those mysterious EPO files. (I don’t know what they are exactly either).

  • FasterGPS: after installing this app you need to run it and enterthe country you’re in.

  • if you do have Google Services on your phone you can allow Google to locate you with Wifi & mobile connections (System Settings > Location access), if you don’t you can install µg Unified Nlp to get a similiar but free service.

If you have an iPhone and GPS doesn’t work well there you’re pretty much screwed. :wink:

1 Like

Thank you Paul. So I just download one of the Apps in the Play Store? Which one do you prefer? I don‘t have all the google systems running (not a fan of google - unfortunately the app store is by google, mäh).

well if you have the play store you (unfortunately) have all of googles services on your phone.
so the third app isn’t necessary for you. I’d install both the other apps and then restart the phone.
when you test your gps be sure to be outside.

Yes now it works normally !!
The solution was simply to unplug the in-car charger.

The difference in signal strength can be easily seen using “GPS test” app : signal bars are divided by 2 when charging and some satellites disappear !

I tried with a randomly chosen ferrite bead on the charging cable but it is the same.
Using an USB port of my battery-powered laptop gives the same result.

Can some of you do the same test with “GPS test” app and tell me if they see the same attenuation in signal strength when charger is connected ?


Me too.
It is reproducible - as soon as I connect a charging cable in my car, the GPS signal weakens; as soon as I unplug the cable, GPS sattelites begin to appear again, no matter which end of the charger I disconnect. Seems the power intake creates a noise for GPS antenna?

1 Like

It seems to me like plugging in earphones also slows down the process of getting a GPS fix. Can someone reproduce this?

I can not say that I really see signals attenuation when earphones are connected on mine.
It looks “modifed” but the global strength remains more or less the same.
But when charging this is an other story !

1 Like

When charging the GPS signal weakens and OsmAnd can’t follow where I go.
I used a low price car charger.
This weekend I used the low price car charger again, but I didn’t use the cable of the car charger to connect to the phone.
Instead I used a separate cable in combination with the usb-point on the carcharger. And suddenly the GPS-signal stays strong and OsmAnd is showing me exactly where I am.
So perhaps this solution is also possible and working with others.


I get the same good behaviour : using a “data cable” ( 4 wires inside) instead of a “charging cable” ( only 2 wires) GPS is much better.
I guess this is because the phone limits it current consumption as it “thinks” that there is computer at the other end of the line.

Maybe a software fix would be that as soon as GPS is enabled, charging current should be limited (as it seems that charging circuitry at full load inside the phone disturbs the GPS receiver).


Hello all you guys
dont waste your time trying out all these fixing suggestions. They are all nonsense. Fact is, that using Gps for Navigation with the fairphone does not work and will never work because of the absolute unusable Chipset.
I tried an external gps reseiver, connected via bluetooth and got the same result. The fairphone, with the Built-in chipset and the unupdateable software is not able to calculate reliable position data.

@kdh: Please don’t draw conclusions about the Fairphone in general just because of your personal frustrating experience with your Fairphone and denying others their own experiences.

I for one didn’t think GPS worked on the Fairphone at all when I first got it but when I tried the first fix I could find on the forum (here) it suddenly worked.
It wasn’t perfect yet but then I tried more and more of the fixes provided on the forum (EDIT: I just gathered them here) and now I usually have a TTFF of 2 seconds and an error of less than 4 meters.
Often I even keep staring at my screen while walking around and collecting data for free location databases and my position isn’t wrong even once.

And it doesn’t just work while walking, as soon as I have a fix (wich of course takes longer if I’m not out in the open) GPS works perfectly in cars and trams as well. Only when I’m traveling by train through the Alps (lots of long tunnels) and changing country sometimes I can’t get refixed again until I leave the train. But then again if you are in a train, you don’t really need navigation, so …

EDIT: And also please avoid posting the same things multiple times on the forum. I deleted your duplicate post here.


thank you for your reply and sorry for my negative posts. I was really frustrated after my last trip yesterday. maybe gravitybox will help. I didn’t try it yet. If I find any solution, i will post it.

1 Like

OK, reason to revive an old thread:

I was among the lucky ones that got a GPS fix fairly quick (15-20 seconds) while on FP OS 1.6 and 1.8. However, after updating to 1.8.5 TTFF increased dramatically (1-2 minutes). Not every time, now and then I got a quick first fix, but often.

So I downloaded the latest epo.dat/epohal.dat files. No difference. I downloaded the correct regional gps.conf file using the “Faster GPS” app. No difference. I turned off EPO. No difference. I enabled EPO and turned off A-GPS. No difference. Then I found keesj’s post here:
where the last paragraph taught me something important:

After turning off EPO assistance and deleting /data/misc/EPO.DAT and /data/misc/EPOHAL.DAT I get a fix in 15 sec max. :smile:

As explained in keesj’s post, the A-GPS data have limited validity (4 hours) so turning off EPO can create trouble if you don’t have a data connection. But since I mainly use GPS together with Google Maps’ navigator function (which needs a connection anyway) this is not a problem for me.

Oh, and you’ll need a file manager with root privileges (e.g. Xplorer) in order to find and delete those files. Can’t be done from the default manager.

P.S. Are there any tech savvies that could explain the difference between the EPO.DAT file (that is installed by the FP1-EPO Autoupdate app) and the EPOHAL.DAT file (that is installed via Settings>Location Access>GPS Satellites>EPO Settings>Download)?


Thanks @kgha for this investigation and for updating the GPS Guide.
I hope you don’t mind I made your text you added there into it’s own chapter (A-GPS vs EPO). I have been meaning to add this chapter for a while now but didn’t have enough information on the pros and cons of the two methods until now. :thumbsup:

1 Like