Directory is read banned

I use the SmartWho File Manager to acces my files as root.
I tried to fix my gps following the steps in this thread: GPS does not work
As i could not download the EPO file i tried to download it as mentioned in the thread and copy it to the folder data/misc

When i opened the folder with SmartWho found the message ther: "Directory is read banned"
It contained no folders (also not /misc) and i could not create a folder.

What can i do?
Hope sbdy can help


Even if FP is rooted this doesn’t mean that all file managers can handle file management within system folders. The default manager can’t, nor can OI FileManager, I’m not sure about SmartWho.
You can search for file managers with root access in PlayStore or F-Droid. Some people here use CM File Manager, others have mentioned ES File Explorer, I use X-plore

I’m not sure what exactly is your GPS trick (on ‘improving GPS via new files’ I’m really sceptical), but if you want to replace a system file, even with a root-capable file manager it’s normal you can’t write in the system.

Because by default the system is read-only.

To change this you must use a terminal app, and

  • issue temporary commands in order to change that (turn the system files read/write),
  • then make your move (if you are really confident, and have a backup),
  • then above all don’t forget to switch the system back to read-only (with an inverse command in the terminal).

I’ve done this before, to attempt adding localized keyboard files (which didn’t work), but I don’t remember the exact command syntax, and don’t feel mature anough anyway to give you a ‘magic command’…
You’ll find pages about this when searching “android system read-only”.

My personal feeling: the GPS in FP is… what it is (rather poor indeed), and modifying system files has very little chances to improve this.

BTW, if you still trust this, on F-Droid you have I think a couple of apps that promiss to do things like this, without the need of a term. Search ‘GPS’…

By default, yes, but not after you’ve allowed root access in the file manager. I’ve copied the EPO files myself using X-plore. However, for this specific task I recommend this app:

Has worked for me instantly every time (when the standard update option fails). You don’t have to set it to automatic updates (I don’t like them), you can just run the app manually now and then.


Thanx Kgha.

got it to work with fp1-epo-autoupdate and some additional tweaks mentioned by RobDoc in this thread GPS does not work