GPS does not work

I’ve had an issue with my FP1 GPS since I received in back in Jan. The GPS has never really worked. The phone seems to manage to triangulate roughly off WiFi and/or mobile masts, but this is never accurate enough to be helpful - and especially not when I’m out of signal range, where it of course can’t locate me at all.

I have read a few posts about this before, but was unable to get past ‘Update EPO files failed’.

I was hoping the Cherry update might fix this, but it has not. I’ve tried updating the EPO data again post-Cherry-update, but no change.

I used my previous phone (a small HTC) for GPS coordinates (via the app ‘GPS Status’) when hiking in remote locations (you can reference the coordinates on an OS map - never be lost again!), and for field surveying too (locating field corners etc.). It is disappointing that the FP1 has never managed to operate GPS convincingly. Please help me to fix it! (In every other way it is a great phone).

With thanks,



I have exactly the same problem. I have done the EPO files downloading, I have factory-reset the phone, I have installed the MT GPS Android app, I have even sent the phone back for repair. They kept it for a week, sent it back claiming that was fixed. It wasn’t. I have given up on that one and content myself with using the features of the phone that do work. I am hoping that the 2015 FP2 will be fully functioning and justify its 325€ price tag.!..

I have a similar problem. GPS never really worked. I was also hoping that the Cherry update would fix it, but today I tested it and nothing changed.

I am using OsmAnd~ for maps, and sometimes it can detect up to 10 satellites, but I never got my position calculated. I installed FasterGPS, and it didn’t help. SatStat also showed up to 10 satellites, but also no fix.

I am almost sure the GPS hardware is defective. Can I send it back for repair?

Hi all,

I had some troubles using the GPS the firs time. I did find a workaround, maybe this helps. (I’m quoting myself from another post, original thread)

This is how I managed to get my GPS working.

  • Plug in your phone into a charger
  • Go to Settings > Developer Options (scroll down) > And check “Stay Awake (Screen will never sleep while charging)”. When your screen goes black automatically, while on battery, the GPS will stop searching for satellites.
  • Go back to “Settings”, scroll down to “Location acces”, click it. Now check “Acces to my location” and enable “GPS Satellites”. Now press the word “GPS Satellites” (not the on-off button, but the actual word). Check “GPS EPO assistance” and check “A-GPS”. Click “EPO Settings” check “Auto Download” and afterwards press “Download” at the bottom. Go back.
  • Now open “GPS Status & Toolbox” and make sure your phone is plugged into the charger. Now, let the app try and lock on to the satellites. If it did, the next time you use your GPS for any app, it will go a lot faster.

Kind regards,


Hi Robin. Thanks for this. In fact I have followed your workaround before (months ago), however the stumbling block was always that attempts to download the EPO data have always returned ‘Update EPO files failed’.

With the settings you have suggested above (albeit without the EPO files) I have left my phone on, outside, with GPS on and running “GPS Status” and it has so far failed to find any satellites. :frowning:

Basically got the same problem as nick

Trying to download the EPO file is a real PITA and googling indicates that this is not FP-specific.
You can download it manually:
and put it in the folder /data/misc
You’ll need a file manager that allows for root access, eg X-plore, for this.


And we have to do that each month?

Bah not gonna bother on the gps until it’s fixed.

I downloaded the EPO files manually, and tried my GPS again for the first time after the Cherry 1.6 update. It took 15-20 minutes to get my first fix, but eventually it worked. Second time, restarted the app, got my location in about 6 seconds… So no real problems here.

Oh yeah, being close to a windows or even being outdoors really helps!

1 Like

I would seriously suggest people to go outside when testing their GPS, don’t stay inside, not even near a window. It can make a huge difference to have a clear 360 degree view of the sky.

1 Like

I placed my phone on the window sill, pointing outwards, and it worked. But I agree, going outside is the best option to use your GPS, why would you want to use it indoors anyways? :wink:

Exactly. I know where my house is :wink:

In fact, I’m never lost. I always know exactly where I am. It’s just that sometimes, I don’t know where everything else is.


OK I’m willing to try once. Only that I don’t find the data/misc folder do you have to create them?

No, you’ll have to use a root browser (something like this) to go there. If it’s not really clear, I could try and make a little tutorial :slight_smile:

Oh so you have to put the file through your computer first then use the root browser on the phone to copy it there?

OK I installed that application only I cannot find te misc folder under the data one. I created it and put the file there. I’m currently trying that gps app for now. I’m not outside though but the phone is directed towards te window.

Doesn’t seem to work. :confused:

I eventually found out by chance[1] that tapping the name (not the on/off slider) of the second entry of the GPS settings menu leads you to the assisted GPS settings. AGPS was disabled all these months and I didn’t even know my phone had it!! I really should start reading manuals… or maybe the usability people should take a look at this menu.

So I enabled it yesterday and downloaded the EPO data. After a few seconds outside it was working like a charm! :sunny:

[1] By chance means… Since the last update I have an issue where the phone detects random taps on the screen… mostly when the background is dark, which is the case with the settings panel. While most of the time it just drives me insane, I was really thankful one of those random taps hit the 2nd menu entry and showed me the AGPS settings screen. :v:

1 Like

OK, I give up. There’s no way to synchronize however I try to do it. Found the folder after all but it changes nothing, it keeps getting stuck on “looking for gps location”… :confused:

But doesnt this mean that EPO and AGPS are useless/not working if your fix needs 20 minutes , isnt it the maximal time a fix without APGS/EPO can need?