FP3 touchscreen experiences ghost inputs


I’m experiencing some ghost inputs to my Fairphone’s touchscreen that make the phone basically unusable. They weren’t present when I originally got the phone, but seem to have developed over time. Basically the screen will suddenly start ignoring inputs, and then begin acting as though I’m touching all over in quick succession, even when my hand is nowhere near the screen. I tried disassembling the phone, cleaning the contacts and re-assembling it, however that’s not changed the situation at all (and I definitely made sure the screws near the contact are seated firmly).

Is there anything I can try to do to resolve this?



Hello djrscally,

and welcome! I have the exact same issue that you describe, it happened five or six times now, I guess. I felt this was more of a software issue, a reboot did resolve the issue instantly.

Best, Philipp

Yeah when I reboot it clears for a short period, and likewise locking and unlocking the phone clears it for an (even shorter) period, but it’s always back within an hour and usually in under a minute.


Sounds like a case for Fairphone support … https://support.fairphone.com/hc/en-us.


Happened to me, too. This is a software issue, if you do a full factory reset, the problem is gone, but it will reappear once you have installed back all your apps etc.

It’s most likely related to some background apps making the phone/keyboard hang for a short time, still registering inputs, but executing them a bit incorrectly. Might also be related to Gboard, I haven’t tried other keyboard apps yet.

I have the same problem. I bought my FF3 in januari but it only started a few weeks ago. It happened like 3-10 times a day, making is really irritating to use the phone. I did a full factory reset 1 week ago, since then it happened only once, on the same day I resetted.

Today someone posted this with the same problem:

I have exact the same problem on my Fairphone 3: Random ghost touches and wipes. To make it visible I have enabled the visual touch feedback in the developer options. It is very weired.

Hope anyone will find an solution! Please post it here, if you have one!

Welcome to the community forum.

To everyone affected by this:
Make sure to report the problem to Fairphone support so they are aware and get an idea of the scale of the problemhttps://support.fairphone.com/hc/en-us.

Don’t just rely on a possibility that somebody in the community here might come up with something.
If you’ve got trouble with your phone, it’s still within warranty, and Fairphone will have to check this out.


So I did and I refered to this topic. Hope there will be a fix soon.

please check my answer below:



Your link doesn’t work…
The page you were looking for doesn’t exist
You may have mistyped the address or the page may have moved”

I seem to have a comparable problem. I used my new FP3 for just about a month now and the touchscreen does some weird stuff making it unusable, At random the touchscreen gets ‘hypersensative’ and wil make anywhere from 3-10 touches, even when I just touch the screen once. This means that I can’t use the phone at all. It randomly happens and stays like that for a long time. Then it suddenly works normally again for a few hours untill it happens again. I tried reboots, taking the battery out, dissasembly, charging etc. nothing seems to work. I cant even start it in safe mode becouse I cant ‘hold’ the turn off key.

If ou had this problem and solved it, please let me know!

As it is written in the troubleshooting guide of Fairphone, in this case, perhaps you can try:

  • Open your phone dial pad
  • Enter *#*#66#*#* in the same way you are entering a phone number to make a phone call. Once the last character is introduced, the Service Menu appears showing you three sub-menus.
  • Select Service tests > Test Single > Touch screen .
  • Use your finger to draw freely on the screen and check if you can do it in each part of the screen.
  • If you can see blank areas in your drawing, your display is partly insensitive to touch.

I don’t know if it can be useful.
And of course, as @AnotherElk said:


The self diagnostic reports no problems with the touchscreen, which isn’t a surprise. Having spoken to support, im now returning the phone to them for analysis and repair/replacement.

1 Like

Hi, had the same issues, the touchscreen self diagnostic was fine too, and I also just returned the phone for repair/replacement. Hope they can identify the cause.

Thank you for your reply Alex. I already tried this and all the other options mentioned on the website. But try typing that code when every touch on the screen gets you anywhere form 3 to 10 inputs. I can hardly ‘type and backspace’ my way throught my SIM-card code. If I do manage to unlock the SIM-card and get to the emergency call screen I would try to type ##66## but it wil turn into ******#####6666666666666666 etc. at wich point I just stop as that might have taken me 15 minutes of typing and backspacing. I Hope the support team will reply soon, the phone is utterly useless like this.

bug appear on e.os too.

it seems that it start lagging then freezing like if the touch&hold delay accessibility option was seted to long then start to bug and touch everywhere.

Maybe it not touch randomly, maybe unfrieezing it touch every where we touch during the freez ?

is someone of fairphone team loking the forum ?

Ok. I was just thinking, perhaps you could cast the screen of your phone onto a PC, and with this type the code and test your screen. Seems a bit complicated but I think it’s feasible :slight_smile: It may also not work, but I’m doing all sorts of strange suggestions :sweat_smile:
The thing is, you need the g***le app, and I personally never did it, but I found a few tutorials.


Not officially. There may be a few Fairphone employees coming here and then, but if you want to contact them directly contact the support team.

If it’s only about typing, then a USB-OTG adapter and a keyboard should do.

1 Like

I contacted fairphone directly thanks.
But wait here, Something appends for me.
Fennec-browser was installed i removed it then reinstalled it.
The problem seems to disapeared. Is someone who experiment this issue have fennec installed ?