After android 13 upgrade FP4 freezes

Hello. I downloaded and installed the Android 13 upgrade to my Fairphone 4 yesterday, and since then the phone has frozen several times. After repeatedly pressing the power button, I have managed to restart the phone, but at one point I thought I was going to have to remove the battery. Is this a common problem, and does anyone know if it’s being addressed?


Do you have an SD card installed? If yes, portable or internal mode?
Instead of taking out the battery you can long press (>15s) the power button.

1 Like

Thanks for replying, Volker. Yes, I do have an sd card, which I use as an internal drive. Could that be the cause of the freezing?

Yes, see sdcardguide .

Reading that, I understand that my sd card operates as external storage, since it shows up as a separate location in the file manager. Could it still be causing the freezing?

In this case I don’t think it’s the SD card - although you still might consider to take it out for some time to check if it helps.
Or you have a look at
But on a first glance I didn’t find a lot of similar reports.

I had the same issue yesterday where the phone froze and the screen stayed off. Has to force a reboot. I do not use an SD card!

Happened four or Five time to me in the last week.
Froze completely, no response to input, and after 10 or ai seconds would reboot from itself.
It happened while I was using it and even when unused in my pocket, since I noticed that the phone was asking me the PIN for the SIM upon taking it out of my pocket.
I don’t use a SD card.

This is so annoying. First the brightness problem, it was fixed by the update, now random freezing and reboots.

1 Like

Yes. It has continued happening on my phone after removing the sd card.

1 Like

Have you checked the apn settings?
It’s a wild guess, but sometimes after an update the Internet settings for mobile data (apn) get mixed up or reset. My wife’s FP3 had the freezing problem after the Android 13 upgrade and correcting the apn solved it for her.

I experienced similar symptoms twice yesterday. Everything froce up with a glitched screen, but I was able to turn the screen on- and off, to switch between a black- and the glitched screen state. A (very) long press of the power button triggered a force-reboot, but nothing else worked. (Note that there’s no sd card in my FP4 at the moment.)
I posted a picture/video of the behaviour in the random reboot thread, since I thought it might be related. Haven’t experienced the behaviour since.

Do you have 5G enabled? That’s been identified as a likely common culprit in the reboot thread I mentioned above.

1 Like

It looks like the behaviour described in the other thread is similar or at least related. I’ve turned off 5g for the time being to see if that helps, but this must be only a temporary solution.

1 Like

Turning off 5g didn’t help, BUT I noticed that this often happened when the screen rotated. So I turned off auto-rotate, and that seems to have stopped the freezing. Maybe it’s just coincidence.


I believe there has actually been an auto rotate related issue on the FP3 before, so its not utterly absurd for something like that to happen on the FP4 as well.


I’m having exactly the same restart problems with my FP4 in my pocket, in course recording mode.

Same here. 5G is off, no SD card. Have to force reboot 3/4 times per day. I reached out to support.

Auto rotate enabled?

Because of ...

I had the update a few days ago and my phone works without crashes.
I don’t know wether there is any way to repeat the installation without resetting the device to factory settings.

Same here…
Any solutions?

As explained above, turning off auto-rotate seems to have worked for me.