English

Using LineageOS on the FP2

livingwogoogle
lineageos
Tags: #<Tag:0x00007fb118845d98> #<Tag:0x00007fb118845c30>

#1

Thanks to @chrmhoffmann and @z3ntu we can all use Lineage OS (G%§$e free Android N!) on the FP2!

Let’s gather our experiences in this thread.

Get the image and see an updated list of known issues here:


I came from Open OS 17.04, wiped data and installed the file via TWRP. Installation worked smooth without any problems.
Then I installed Titanium Backup and restored many of my apps & data. I had to move my TB data from the external SD card to internal memory as TB can’t access external storage.

So here are my experiences so far:

  • Root is available in Developer Settings! :thumbsup:
  • XPosed Framework is not available :thumbsdown:
  • Most functions I needed XPosed Modules like Gravity Box or XPrivacy for before are now available by default! :thumbsup:
  • There is no notification icon for a second empty SIM slot! :thumbsup:
  • haven’t yet found any major functions or important apps that don’t work. :thumbsup:

LineageOS 14.1 with OTA updates for FP2
Porting LineageOS to FP2
Android 6.0 Marshmallow / 7 Nougat for FP2?
Fairphone 3 - Interview of Bas from FrAndroid
Poll: Lineage OS or FPOOS Android 6?
Lineage Experiences
LineageOS 14.1 with OTA updates for FP2
LineageOS 14.1 with OTA updates for FP2
National Roaming
Porting LineageOS to FP2
LineageOS 14.1 with OTA updates for FP2
Proposal for category "Lineage OS"
LineageOS 14.1 with OTA updates for FP2
Porting LineageOS to FP2
LineageOS 14.1 with OTA updates for FP2
#2

What about permission control a la Xprivacy?

PS.: Great that you are testing it! :thumbsup: :slight_smile:


#3

Lineage Privacy Guard works great, much better than Android 6’s Permission Control.


#4

Be aware that UnifiedNLP (including the one microG embeds) doesn’t work in Nougat without integrating them on the system:


#5

So Lineage OS comes with G Location Services? :open_mouth:


#6

Hmm? Nope, LineageOS should come clean of Gobble things


#7

Got it up and running in no time. Looks really good so far. Impressed by this @chrmhoffmann.

Do you have any idea if the build-in update funtion for Lineage will work?


#8

Nice work @chrmhoffmann,

I have noticed a few more issues while playing with your build:

  • Dual-SIM kind of works, but SIM2 does not get any signal
  • Enabling and then disabling flight mode results in no signal on both SIMs (requires reboot)
  • WiFi MAC address is not correct
  • No LED indicator while charging the device

I have no idea what the problem with device encrypton is, but the TWRP port had similiar issues. Maybe these commits by @z3ntu for TWRP can help you?

Besides that, everything works great so far! If device encryption and the SIM2 issues are fixed, I’ll switch to this as my daily driver.

Edit: When using the music app to play some music I have noticed that at the start of every song there is a short spike in volume (maybe in first ~300ms). After that the volume is reduced to the expected level.

Edit 2: I should also mention that the device boots extremly fast (compated to Fairphone Open OS), which is great!

Edit 3: After I changed the cell phone setting to 3G, the option for 4G/LTE is no longer displayed. So I’m stuck on 3G now.


#9

I have it now roughly two days running, and so far I am quite impressed. I just decided that I’m gonna keep it on the device to test during the next week. It’s one of the best things to happen for the longevity of FP2, thanks so far @chrmhoffmann.

I hope that also the official FP guys realize how important a running lineage port is in terms of the longevity - a friend of mine is having a quite actual lineage port running on an really old device, no need for him to buy a new phone.


#10

No fortunately, you need to install them via open gapps.


#11

I have no issues with enabling and disabling Air plane mode.
All conncections are restores after rere-enabling

I did not find how I can disable ‘vibrate on touch’. I thought I turned it off in Settings > Sound > Other Sounds > Vibrate on Touch.
But this doesn’t stop the vibrating…


#12

@chrmhoffmann As everybody else here I also want to thank you for your great work on this, which unfortunately made some work of @z3ntu some kind of useless.

After playing around a bit I experienced two issues in addition to the ones of @jnsp :

  • When disabling from flight mode with one SIM I have to re-unlock my SIM card.
  • The rom doesn’t find any SIM contacts when I try to import them.

#13

@chrmhoffmann thanks a lot ! I tested it also and I have to report this strange issue : I did a backup of everything with adb before testing. When I restored my data with this ROM, only the pictures and music files came again into the phone. Apps and contacts didn’t.

I will try to do it with TWRP some time this week ! And like @sebastku, the ROM didn’t find any SIM contacts when I tried to import them.


#14

some -> all :disappointed_relieved:


#15

I also tested the LineageOS. Looks very mature for me. Its definitive out of the alpha stage. Its usable and i didn’t found any big bugs.

By the way, i use it in combination with new Modem Files from
Fairphone GMS 17.04.8 (4436.1.FP2-0-00)

An there is no battery-drain and not proximity-related bugs.


#16

I have noticed that the WiFi is not very stable in crowded areas. I’m using the WiFi network provided by my university, it works well in the dormitory (usually 2 or 3 devices per AP), but in the food court with hundreds of users in the same room (and maybe dozens per AP) the phone loses WiFi connectivity after ~15 to 30 seconds and sometimes refuses to reconnect.

This worked well with Fairphone Open OS.


#17

We have just hit the best aspect about FLOSS: :smiley: You can now work on ironing out the bugs still found in the LineageOS port!

Also, your efforts have definitely improved your understanding of those things, so not all of the work was useless.


#18

Wrong, @z3ntu. You did an awesome job, I’m sure you learned a lot and officially ported TWRP to the FP2 in the meantime. Your work wasn’t useless at all! :slight_smile:

@NicoM and I didn’t even get CM to boot and I don’t feel our efforts were useless, neither.

Edit:

Exactly, :wink:


#19

Quite impressed at what you guys accomplished! I really want to test this build but I can’t miss the dual sim functionality right now. Going to test it after my on call duty period.

Mad props to the guys who worked on this!


#20

Actually yes but I am still not near other people ^^

:heart: :wink: