Using LineageOS on the FP2

By the way, i use it in combination with new Modem Files from
Fairphone GMS 17.04.8 (4436.1.FP2-0-00)

Can you please tell us how to do that? I have problems with connectivity both mobile network and WLAN.

Thank you to all of you who have worked and still work on this project, as well as to all of the people testing the OS and reporting bug!
I look forward to this Summer, when I will have more time to make a backup and test LineageOS, Ubuntu and Sailfish on top of FPopensOS Marshmallow!


Just Download the whole package:

Extract in a folder on your PC

Boot the Phone in the Fastboot mode (Vol- & PowerOn)

Run this commands:

fastboot flash rpm rpm.mbn
fastboot flash sbl1 sbl1.mbn
fastboot flash tz tz.mbn
fastboot flash modem NON-HLOS.bin
fastboot flash splash splash.img
fastboot reboot


Maybe it is a stupid question but it is possible to run threema with lineageOS on the FP2? So did anyone test this so far? Thanks for your answers. :wink:

1 Like

What about the dual sim. Does this work in your combination?

If yes, can we get those modem files in the flashable zip?

1 Like

DualSIM works for me. i don’t know how to integrate modem files in the

I have compiled a flashable zip that installs the latest modem files. You can download it here.

SHA256: 4f2a6b4acebff7af401fb56fce0ed450155e5958da51f563f0c3ba2418974db8

The zip is based on the official ota zip for Fairphone Open OS 17.04.0, I have simply removed emmc_appsboot, system.img and boot.img, updated the modem files from 17.04.08 manual zip and added some comments to the updater-script.

It is theoretically possible to include this in the Lineage OS zip, but this would require us to manipulate the Lineage OS build process. Providing a seperate zip to update the modem firmware is easier IMHO.


There are no stupid questions. Without google I can confirm Threema is running as usual.


Since yesterday my FP2 is running on Lineage OS too. [without google]

I can confirm the FM Radio is not working.
I also have problems with the flightmode. My phone does not get any signal after disabling flightmode. After rebooting the phone I couldn’t get any signal on my sim cards either. I tried in TWRP clearing my cache and dalvik cache led to kind of factory reset =[ but I got my signal back =D

I restored an backup from before the flightmode.

For me the rest works really neat.

Now without Xposed I do have some issues.

  • I want to restore my wifi settings, which were before in /data/misc/wifi/wpa_supplicant.config but I cannot find the file.
  • Is it possible just with root to deactivate some apps like “Files”,“Browser” etc.?
  • Which file manager with root do you use? I use “simple explorer” but cannot access my SD-Card but the root file system.
  • While I’m asking which free (F-droid) app du you use to open .xlsx/.pdf/.docx/.txt files?

Thanks a lot


Just want to report that my mac address changed to 00:0a:f5:67:db:4c. It was before the update different. But the new address is displayed in settings and on my router the same. So it seems it actually changed and is displayed correct.

Different mac address here as well (backuped the original) after flashing LineageOS. But also not the same as @charlie’s. Same vendor code, but the rest seems randomly generated (maybe this is a LineageOS privacy feature?).
Also: This build works together with the pico opengapps perfectly.

I did this:

  • Titanium backuped all user apps
  • Flashed official twrp
  • Booted into TWRP
  • MTP transferred all the pictures and user data to my computer (DCIM, Titanium Backup and more)
  • Made a full backup at the same time
  • MTP transferred the backup to my computer
  • Wiped from TWRP
  • Flashed @jnsp’s modem zip
  • Flashed the LineageOS build
  • Flashed OpenGapps ARM 7.1
  • Reboot!

I guess, no. There was a bug in Fairphone OS 17.04.8 that showed an incorrect MAC address, but that has been fixed in 17.05.2. MAC addresses are unique for each network device (as long as anyone does not fake them).

1 Like

Was FP Open 17.04 also affected? This was the OS I was running before LineageOS.

This bug was related to the Checkup app, but not to the Fairphone OS 17.04.8 itself.

To me it looks like this LineageOS build is reading the MAC address from the wrong location. Might be related to the use of the Prima WLAN driver.


I did not know that, thanks for clarifying! :slight_smile:

Today I had to use tethering and it didnt work. Tried both WPA and no password. When enabling tethering it just says “Error”. I can see WIFI network but cant connect to it.

Also: The preference double tap to wake shows in the settings but doens’t work. I wonder this is even possible with the hardware?

Dual sim works for me out of the box with the image @chrmhoffmann provided (coming from the latest open OS).


I installed it today and I’m really imressed how well everything works! :slight_smile:
Dual-SIM didn’t work for me until I swapped the SIM-Cards (Slot1 uses LTE now). :wink:

1 Like

Doubletap to unlock is always Hardware-dependent. FP2 Display-Firmware doesn’t support this, as i heard.