English

Updating LineageOS 15.1 for microG via TWRP + feature test

lineageos
Tags: #<Tag:0x00007f9ffcb43798>

#82

Is lineage.org down? I cant download last release.


#83

Seems that way at the moment … at least partly … https://status.lineageos.org/

Doesn’t affect microg.org, though … https://download.lineage.microg.org/FP2/ works currently.


#84

Update Installed via TWRP 3.2.3-0 (Releases)

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module) works correctly with Open Camera, stock camera App not checked, didn’t operate the flash correctly for ages.
  • main camera (new module) video recording
  • selfie camera (new module)
  • selfie camera (new module) video recording with stock camera App not checked, worked correctly last time I checked, Open Camera records only black after a random number of seconds.
  • USB connection to PC / MTP
  • alarm
  • MyPhoneExplorer 1.8.11
  • Root access (Settings - Developer Settings - Root Access)
  • USB OTG
  • WiFi hotspot
  • Bluetooth (data connection, music playback … pairings survived the update)
  • FM radio
  • weather (Your local weather with my own OpenWeatherMap API Key, Weather Widget)

For reporting bugs see the bottom of this page.

And here is a Settings reference.


Upgrading from *official* 14.1 to 15.1 (feedback/issues)
#85

Update Installed via TWRP 3.2.3-0 (Releases)

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module) works correctly with Open Camera, stock camera App not checked, didn’t operate the flash correctly for ages.
  • main camera (new module) video recording
  • selfie camera (new module)
  • selfie camera (new module) video recording with stock camera App not checked, worked correctly last time I checked, Open Camera worked this time (checked for some minutes, in the past this only recorded black after a few seconds)
  • USB connection to PC / MTP
  • alarm
  • MyPhoneExplorer 1.8.11
  • Root access (Settings - Developer Settings - Root Access)
  • USB OTG
  • WiFi hotspot
  • Bluetooth (data connection, music playback … pairings survived the update)
  • FM radio
  • weather (Your local weather with my own OpenWeatherMap API Key, Weather Widget)

For reporting bugs see the bottom of this page.

And here is a Settings reference.


#86

Update Installed via TWRP 3.2.3-0 (Releases)

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module) works correctly with Open Camera, stock camera App not checked, didn’t operate the flash correctly for ages.
  • main camera (new module) video recording
  • selfie camera (new module)
  • selfie camera (new module) video recording with stock camera App not checked, worked correctly last time I checked, Open Camera records only black after a random number of seconds again.
  • USB connection to PC / MTP
  • alarm
  • MyPhoneExplorer 1.8.11
  • Root access (Settings - Developer Settings - Root Access)
  • USB OTG
  • WiFi hotspot
  • Bluetooth (data connection, music playback … pairings survived the update)
  • FM radio
  • weather (Your local weather with my own OpenWeatherMap API Key, Weather Widget)

For reporting bugs see the bottom of this page.

And here is a Settings reference.


#87

Update Installed via TWRP 3.2.3-0 (Releases)

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module) works correctly with Open Camera, stock camera App not checked, didn’t operate the flash correctly for ages.
  • main camera (new module) video recording
  • selfie camera (new module)
  • selfie camera (new module) video recording with stock camera App not checked, worked correctly last time I checked, Open Camera records only black after a random number of seconds.
  • USB connection to PC / MTP
  • alarm
  • MyPhoneExplorer 1.8.11
  • Root access (Settings - Developer Settings - Root Access)
  • USB OTG
  • WiFi hotspot
  • Bluetooth (data connection, music playback … pairings survived the update)
  • FM radio
  • weather (Your local weather with my own OpenWeatherMap API Key, Weather Widget)

For reporting bugs see the bottom of this page.

And here is a Settings reference.