English

Updating LineageOS 15.1 for microG via TWRP + feature test

lineageos
Tags: #<Tag:0x00007f9ffa18c8c8>

#62

That mean no more update from LOS+microg fork from now?


#63

I hope not! I’ll wait some weeks


#64

I am using two old Samsung Galaxy 5S phones: This week for the Lineage 15.1 phone I have got seven updates, each day one; for the other one with Lineage 15.1 microG none!


#65

They rolling out builds for LOS microG again :+1:
But they stated, that they will not doing it daily, but weekly like before.


#66

I got it today 15.1 - 19 11 2018.

Thank you those Team who make this project possible (^-^)/


#67

Oh, thankfully!


#68

Update Installed via TWRP 3.2.3-0 (Releases)

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location (Usually my indoor location is found almost immediately without GPS, not this time, will have to see if that’s temporary. GPS worked.)
  • compass
  • screenshot
  • main camera (new module) works correctly with Open Camera, the stock camera App doesn’t operate the flash correctly.
  • main camera (new module) video recording
  • selfie camera (new module)
  • selfie camera (new module) video recording works correctly with the stock camera App, Open Camera records only black after a random number of seconds.
  • USB connection to PC / MTP
  • alarm
  • MyPhoneExplorer 1.8.11
  • Root access (Settings - Developer Settings - Root Access)
  • USB OTG
  • WiFi hotspot
  • Bluetooth (data connection, music playback … pairings survived the update)
  • FM radio
  • weather (Your local weather with my own OpenWeatherMap API Key - Widget updates reliably when App is set to a 30 minute update interval, doesn’t update reliably when App is set to a 1 hour update interval … App and launcher are not battery optimized and have permission to run in the background, Weather Widget)

For reporting bugs see the bottom of this page.


#69

Sometimes, the location mode reset automatically on my LOS FP2. I have to go to Settings > Google > Localization > Mode and select “high precision” again…


#70

Hey,
i was wondering how you deal with your microsd cards?
Do you leave them unencrypted or is there a way to encrypt (or do you don’t use one) ?

My first idea was to use the microsd as internal storage and then encrypt. This failed so far:
I tried with los14.1&15.1 to get the microsd working as internal storage which only led to a wrong Mount setup that would give me only access to the space on the microsd and wouldn’t mount the internal storage correctly…


#71

My personal opinion:

There is enough trouble to be found in this forum with this setup to just avoid it, if possible.

So in my case … privacy-sensitive or work-related stuff goes into the encrypted Internal Storage, other stuff is on the unencrypted SD card.


#72

thanks for the advice - i guess it’s just better not to encrypt the sd and be aware where to put which file :wink:

on a fresh 15.1 install i experience a high battery drain even in standby with no SIM & wifi off/not connected.
can you say the same? would an older modem help? any idea what could be an issue for this behaviour?

stats 15.1 fresh install:
  no SIM&WLAN off:                          ca ~0,5%/h (8% in 17h) - left picture
  no SIM&WLAN on but not connected:         ca 1%/h 


#73

Depends.
Currently I have about 1% battery usage per hour with SIM and WiFi on and connected (with bad mobile network reception at home) and the phone idle otherwise, but freshly installed it was 2%/hour before some automatic optimizing by Android kicked in (my guess) … so for me personally this is actually looking pretty good, and judging from my experience it would not be considered a battery drain on this forum.


#74

are these steps necessary if an old camera is still installed?

  • Booted TWRP
  • Destroyed the LUKS header to really seriously get rid of prior encryption (Advanced - Terminal - dd if=/dev/zero of=/dev/block/mmcblk0p20 bs=4096 count=512 )
  • Formatted data to get a valid Ext4 partition again (Wipe - Format Data)
  • Resized data to not regret later that I left that out (Wipe - Advanced Wipe - data - Repair or Change File System - Resize File System)
  • Wiped everything except Micro SD card (Wipe - Advanced Wipe).
  • Rebooted into TWRP to make sure encryption is gone (no request for the encryption password when starting)
  • Installed lineage-14.1-20180808-microG-FP2.zip
  • Booted LineageOS 14.1
  • Set a PIN and encrypted the phone
  • Rebooted into TWRP to make sure 14.1 encrpytion was in place (request for the encryption password when starting and successful decryption)
  • Turned off the phone and reassembled the new main camera module

#75

These were my steps to get from a 15.1 encryption (which TWRP couldn’t handle) done by 15.1 in the testing phase to a 14.1 encryption, which I then installed 15.1 on (so that TWRP as well as 15.1 could handle it).

If you want to do the same with the old camera, just don’t disassemble/reassemble the camera :wink: .


#76

Update Installed via TWRP 3.2.3-0 (Releases)

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module) works correctly with Open Camera, the stock camera App doesn’t operate the flash correctly.
  • main camera (new module) video recording
  • selfie camera (new module)
  • selfie camera (new module) video recording works correctly with the stock camera App, Open Camera records only black after a random number of seconds.
  • USB connection to PC / MTP
  • alarm
  • MyPhoneExplorer 1.8.11
  • Root access (Settings - Developer Settings - Root Access)
  • USB OTG
  • WiFi hotspot
  • Bluetooth (data connection, music playback … pairings survived the update)
  • FM radio
  • weather (Your local weather with my own OpenWeatherMap API Key, Weather Widget)

For reporting bugs see the bottom of this page.


#77

Update Installed via TWRP 3.2.3-0 (Releases)

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module) works correctly with Open Camera, the stock camera App doesn’t operate the flash correctly.
  • main camera (new module) video recording
  • selfie camera (new module)
  • selfie camera (new module) video recording works correctly with the stock camera App, Open Camera records only black after a random number of seconds.
  • USB connection to PC / MTP
  • alarm
  • MyPhoneExplorer 1.8.11
  • Root access (Settings - Developer Settings - Root Access)
  • USB OTG
  • WiFi hotspot
  • Bluetooth (data connection, music playback … pairings survived the update)
  • FM radio
  • weather (Your local weather with my own OpenWeatherMap API Key, Weather Widget)

For reporting bugs see the bottom of this page.


#78

Will you switch to LineageOS 15.1 encryption, or does the 14.1 still suffice?


#79

I use 14.1 encryption because TWRP as of now (3.2.3-0) can’t decrypt 15.1 encryption.
If TWRP catches up, I might consider 15.1 encryption for a new install somewhen … or 16.0 encryption then :slight_smile: ?

Do you know whether 15.1 encryption does anything better than 14.1 encryption?