English

Update Aug 0129 Ambient light | Adaptive brightness

Carrying on from the discussion on the Adaptive brightness issues noted since the latest update

The issue appears to be

a) the ambient light sensor is not working as it did before and
b) setting the slider at any value is overridden once the ambient sensor reads again.

So this happens

  1. in the evening as the light fades, even before sunset if there is no direct light on the sensor and
  2. early morning before such light and
  3. probably any other situation where sensor reads zero

As soon as the sensor gets a reading above zero the screen brightness goes to a level that is ‘good’ but not the one set by the slider.

It appears as though not just the level of darkness that has been adjusted but the ambient light sensor has also been effected

I’m turning adaptive brightness off for now.

37 Likes

I have the same issue. With low ambient light, the display backlight sometimes gets turned very low (too low to read) now. After some seconds to minutes, it will turn back normal.

7 Likes

Yes I accessed the sensor readings by dialling *#*#66#*#* Service test > Test Single > Ambient Light Sensor and I get zero even though there is adequate light for reading and working, ie. after sunrise.

The slightest angling towards the window and the sensor may only go up to 2 but then the backlight becomes ‘normal’.

The if I angle it away and the sensor drops to zero again the screen light just about disappears.

Keeping the auto brightness off is less demanding than using it.

So for three days the ‘phone’ has learnt nothing.

3 Likes

I have the same issue. The display backlight turns very low, so that you can’t read anything.

5 Likes

I have been experiencing this problem since Android 7 through 8, 9 and now 10.
In my opinion, it is a problem of Android and Google’s approach to know when I want my display brightness and how. The automatic that is responsible for this is a rough setting without taking the sensor into account. With my HTC U11 and the Fairphone 3+, as with other Android smartphones, the behaviour is the same. Unusable. I live very peacefully without the automatic and a swipe down allows me to adjust the brightness. 1 2 adjust done. With automatic it is a permanent readjustment. Not with me. Automatic OFF.

Whatever happens: You must never sink so low as to drink the cocoa you are being pulled through.


Dieses Problem beobachte ich seit Android 7 ĂŒber 8, 9 und nun 10.
Meiner ansicht nach ist es ein Problem von Android und der anmasung von Google zu wissen wann ich meine Displayhelligkeit wie haben möchte. Die Automatik die dafĂŒr verantwortlich ist ist eine grobe Einstellung ohne den Sensor dafĂŒr zu beachten. Bei meinem HTC U11 und dem Fairphone 3+ so wie bei anderen Android Smartphones ist das verhalten gleich. Unbrauchbar. Ich Lebe sehr Friedlich ohne die Automatik und ein Swip nach unten ermöglicht es mir die Helligkeit einzustellen. 1 2 einstellen erledigt. Mit Automatik ist es ein permanentes nachregeln. Nicht mit mir. Automatik OFF.

DafĂŒr hat Erich KĂ€stner ein sehr treeffendes Zitat:
Was immer geschieht: Nie dĂŒrft ihr so tief sinken, von dem Kakao, durch den man euch zieht, auch noch zu trinken.

x

2 Likes

Strange before this update it worked fine on my A10 ??

7 Likes

It may be that I found the solution after scouring the web. I reset the memory which saved the preferred brightness of the backlight.

You go to settings, apps & notifications, show all apps, select “show system apps” in the top right corner. Then select the “Device Configuration” app, then “Memory & Cache” and then “Clear memory content”.

After that, the device will still be dark, but it will remember the manually readjusted settings depending on the ambient brightness.

It works for me now. In any case, it’s not getting so dark anymore.

Es kann sein, dass ich die Lösung gefunden habe, nachdem ich das Netz durchforstet habe. Ich habe den Speicher zurĂŒckgesetzt, in dem die bevorzugte Helligkeit der Hintergrundbeleuchtung gespeichert ist.

Ihr geht auf Einstellungen, Apps & Benachrichtigungen, Alle Apps anzeigen, oben rechts auf “System-Apps anzeigen” auswĂ€hlen. Dann die App “Device Configuration” auswĂ€hlen, danach “Speicher & Cache” und dann “Speicherinhalt löschen”.

Danach wird das GerÀt zwar immer noch dunkel, aber es merkt sich die manuell nachjustierten Einstellungen wieder in AbhÀngigkeit der Umgebungshelligkeit.

Bei mir funktioniert es jetzt wieder. Jedenfalls wird es nicht mehr so dunkel.

12 Likes

Will try your idea but it has worked fine during the day and during the evening as long as the ambient sensor doesn’t go to zero, as then it needs resetting.

Well, it’s your fine. My fine is a different one.
Different light, different environment, different requirement. Just like with many other people.
Like i said, I live very peacefully without the automatic.

3 Likes

That option is ‘ineffective’ maybe as I have de-googled my phone. All option for Storage and cache just show Computing 
 :frowning:

Actually under the Device configuration I see
Not installed for this device :slight_smile:

So I’m not sure that is a cure as I have never had the Device configuration installed and the auto brightness and ambient sensor worked fine before, though I wonder what would happen if I install it ~ another day maybe.

Thanks for your insight.

2 Likes

@Wiehengeist
Diser Tip ist Top. Ich denke das “Speicherinhalt löschen” auch andere Probleme, die so auftauchen, beheben könnte. Danke dafĂŒr!


Go to Settings, Apps & Notifications, Show All Apps, select “Show System Apps” at the top right. Then select the app “Device Configuration”, then “Memory & Cache” and then “Clear Memory”.

This tip is top. I think that “Clear Memory” might also fix other problems that come up. Thanks for this!
x

3 Likes

If this works for some people, then it is fine, of course.

I just wonder why this workaround has this effect, as the “Device Configuration” app usually should do nothing about the ambient light sensor. Instead it is a service that gives feedback to Google about your device:
https://support.google.com/android/answer/9021432?hl=en

Maybe somebody has deeper insights?

2 Likes

Can anybody confirm that Wiehengeist’s “device configuration” trick works for them as well? I’m holding off on installing this update as the issue sounds really annoying.

Also, of course, it would be disappointing for FP to bungle something like this again that should have been caught by QA easily – if this wasn’t exactly the sort of thing I’ve come to expect from them.

Edit: I updated, have to problem as well, and for me Wiehengeist’s solution does not work.

Well just to confirm for the fourth day.

I had the auto brightness set fine yesterday evening, but again this morning the screen has darkened to almost unusable.

So apart from their being no ‘memory’ carried over from yesterday it seems more a function of the fact that the ambient light sensor cannot cope with a certain level of low light and reads zero which then triggers the zero setting on the auto brightness.

If the ambient light sensor reads even 1 it works fine.

So hello @rae maybe someone could officially recognise this without submitting a support request.

4 Likes

This would be helpful. Just got the push notification for the update today, but I am scared to install it.

1 Like

Similar problem - since this latest update only: screen brightness goes automatically to zero. Adjusting the brightness level manually and turning off the automatic ambient programme seems to solve it for a while.

2 Likes

I image the update, with it’s security update is more important that a light sensor. So even prewarned I would have upgraded.

And as pointed out you can disable the auto and manually adjust.
However if the auto brightness is enabled and it goes dark, I mean really dark, then the screen is at zero brightness and it’s hard to see the screen well enough to turn of the sensor. OK once your eyes have adjusted you can see well enough to switch it off and the viewing is fine.

This specific instance will generally only occur at night if you have no artificial light to keep the sensor active. Of course you can always switch on the light assuming there is one :slight_smile:

Yup, same issue here, very dark screen after installing the update. When I turn off adaptive brightness the problem is solved for a while, but comes back soon. Hope this is fixed quickly, because it is quite annoying.

1 Like

You say you still have a problem with adaptive brightness off. Can you check it hasn’t somehow been reactivated as that does happen with me. This may be a separate issue??

OK I may have found a solution.

It’s daytime plenty of light.

  1. I go to Settings > Display >Brightness level Tap so the slider is visible
  2. Hide the ambient sensor so it gets no light > screen goes very dark
  3. Now whilst dark, (i.e. the the ambient light sensor would be recording zero if you could access it) move the slider say to 40%

Bring the phone back to the light and cover the sensor again, hopefully this will now reduce the screen to 40% It’s not easy as the slider is hardly visible. ~ However see post 30

I’ll see what happens this evening and note if anything has changed then.

I don’t need the AI to think for itself, it can’t think, I want it do want I ask.