English

Random disconnecting wifi, again

Last year my fp2 lost wifi connection dozens of times a day. In the end (after doing all things like rebooting and deleting apps etc) Fairphone put a new wifi antenna in the phone. That helped, though I lost bluetooth but somehow that returned after an update.
Now the wifi connection is lost randomly more and more often, and I’m nearly back to dozens of times a day. Sometimes it is totally turned off with the connection button swiped to ’ turn off’ (which I didn’t do myself). Most times it just lost connection. Sometimes I can reconnect by manually tapping on ’ connect’ but more and more often I have to restart the phone. It’s extremely annoying especially since I know the communication with fairphone support is so strenuous. Anyone have a good idea to get my phone to work properly?

1 Like

Hi, did you have a solution for your problem? I have the same problem far worse. My phone keeps disconnecting, now I think it has been a month or so.
I’m on a chat and while txting, I’ll be disconnected every 5mn, sometimes it makes it impossible to have conversations…

hi no it’s just getting worse. It’s the second time too, I had the same issue last year and in the end sent the phone to fairphone repair service and that did help. For a while. And while it helped, I lost bluetooth connection (which came back a few months later, all by itself). Fairphone support will tell me to check for bad apps etc but it’s not any of my apps I think. I actually regret buying a fairphone, which is a shame!

I agree, I admit that I’m tired too, I had a few others issues as well and it’s getting tiresome. My daughter even said she’s going to get an iphone when she can and I think she’s right.
I’m going to open a query then, thanks.

Hi,

it seems as if I have the same issue.

However to me it appears as if WIFI disconnects also depend on the router. With Speedport router I ha no problems so far. WIth FritzBox I have multiple wifi reconnect or no connection at all.

Usually a phone reboot solved this issue for some time.

thanks, that seems plausible as it disconnects much more often at home where I have a fritzbox, then at the office. So I’ll try to get a different router. Thanks again for the tip!

Still it seems like a strange problem to me.

Does anybody has an idea about the reasons for these disconnects? it is really annoying.

I have the same problem with my Speedport W 925V :frowning:

It took me a while to get a connection at all. This was only possible if I switch router wifi security settings from “WPA2 (very high)” to “WPA/WPA2 (high)” as described here: https://bugtracker.fairphone.com/project/fairphone-android-7/issue/276 or Fairphone 2 cannot connect with Wifi with WPA2

Deactivation of 5G Network was helping a bit, but still I’m facing disconnects from the router every 5 Minutes(!)

I added my log output here:
https://bugtracker.fairphone.com/project/fairphone-android-7/issue/139

I have the same issue; never had any problems with wifi disconnecting on my FP2 until I moved into a new apartment where my wifi keeps disconnecting every 5-ish minutes. My wifi still connects normally to other networks (university, parents, grandparents etc.), so it seems to have something to do with the particular router in the apartment? I haven’t checked the router yet as I have not spent much time there yet, but I will send an update once I do
Have any workarounds been found yet for this?

Did someone with wifi problems on FP2 try out an Android 9 upgrade?

Currently, I don’t see anyone reporting a comparable issue on the new Android version:
https://bugtracker.fairphone.com/project/fp2-android9/issues?order_by=-total_voters
(I’m waiting for the encryption to be supported)

I have found that random disconnects can happen if your FP2 is connected at 5 GHz, and your router is configured to automatically select a suitable channel. Apparently the FP2 doesn’t like higher channels like 116 through 128, so if the router lands on one of these, it causes the FP2 to lose connection. It may try to reconnect on 2.4 GHz, which is often congested in urban areas, so this might not improve the situation. My solution was to configure the router to use a fixed channel (56 in my case); see my thread here for further details.

3 Likes

thanks heaps, but to be honest I’ve given up (I’m absolutely not technically inclined) and I’m trying to sell the phone. I have a phone with a bad conscience now but it works.

I can’t say I blame you; I’ve been thinking about it as well (also due to battery life and general slowness of my FP2). Maybe someone else who digs up this thread will be helped by it before it’s too late :slight_smile: