Random disconnecting wifi, again

At the moment I have my Fritzbox 7590 on version 07.21 at Wi-Fi channel settings automatically.

Thanks, I will try this

I had the same problem with my Fairphone 3 connecting with my TP-Link Archer AX50.
I’ve managed to finally solve it by disabling 5 Ghz. The phone now only connect on 2.4 GHz and stays connected. I don’t need the 5 GHz speed on my phone anyway.
The setting was hidden pretty well on Android:
Settings → Network & internet → WiFi → scroll to bottom → WiFi preferences → WiFi frequency → Set it from automatic to 2.4 GHz only.

my wifi problems have been gone away since the Android 9 upgrade of my FP2, I’m really really happy with the new Android version provided by Fairphone :slight_smile:

4 Likes

If you still have this problem, try going to your wifi settings and disabling “wifi scanning”.

What it’s supposed to do is make sure you’re always connected to the wifi source with the strongest connection, what it actually ended up doing for me was constantly disconnecting from one source and failing to connect to the new one.

Ever since I turned wifi scanning off, I haven’t had any issues.

1 Like