FP2 not connecting to new router (Tilgin HG2711)

Another FP2 not being able to connect to wifi after getting a new router. Think I’ve tried all the suggestions I found here but still not working.

This happens with my wife’s FP2 which has the 19.11.2 version. My FP2 which has LineageOS (though it’s also a few years newer than my wife’s so there could be hw revision differences too) could immediately connect to the new wifi. My wife’s FP2 would at first not even try to connect. It would show the nets and allow entering a password, but no indication that it was trying to connect.

After reading some posts here I changed the router from bgn to bg, and created a guest wifi that only requires wpa2/wpa instead of the more secure wpa2. Now the phone tries to connect, gets an ip address, says “no internet” and then immediately disconnects. It gets stuck in a loop like this, where it keeps connecting and disconnecting rapidly. Same thing on both 2.4 and 5.

Check if the router is updated to the latest firmware version.

You can’t manually change/update firmware in this router, it will do that automatically

I don’t think there have been any HW revisions on the FP2 (though I might be mistakeb of course).
To be sure, did you try installing LOS on your wife’s FP2 and see if you still have the problem?

Otherwise perhaps the upcoming upgrade to android 9 for the FP2 will solve the problem. If you want to test, it is actually in beta phase, and you can subscribe to the beta program (but I think the upgrade should be coming soon).

Just to be sure, did you also see this message from thomastc:

or the Wiki referred to?

1 Like

The thread you are referring to is about spontaneous disconnects after successful connects.

I saw it but that one sounded like it was connected and after a while got disconnected, and for them 2.4 also worked… For me it would disconnect instantly, and cycle through connecting/obtaining ip address/disconnect several times per second

But I figured it out and it’s quite embarrassing… I had made a typo when creating the guest network, so the clients had no route to the gateway. I suppose I got confused by the reconnection thing, I’d expect it to stay on the wifi even if can’t reach the internet.

Thanks for the suggestions everybody


Yes, sure, the thread is.
These are the situations described by thomastc in the Wiki referred to though:

  • If the network is 5 GHz only: you still see the network in the Wi-Fi menu, listed as “Saved”, but when you tell it to connect, nothing happens. Or maybe it shows “Scanning…” and “Connecting…” briefly and goes back to “Saved” without any error messages.
  • If the network supports both 2.4 GHz and 5 GHz: it connects on 5 GHz, then randomly loses connection after a while and reconnects on 2.4 GHz. You can see the band and channel in an app like Net Analyzer .

Anyway, good to hear, JohanAR, that you got it working through a guest network!

The bold part of the quote does not fit either, as the network is in the 2.4 GHz bandwith, and connecting was not successful.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.