Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

This effort was based on the unofficial LineageOS ROM with major contributions by @Max_S, @k4y0z, @sooorajjj, and others. After several months of review by LineageOS and iterative cleanup of our work we were admitted into the list of officially supported devices. The currently supported version is LineageOS 17.1.

This topic will collect user feedback, helpful hints, feature wishes and future milestones such as Android 11. To post bug reports, please use the official LineageOS site.

Here a collection of relevant external links:


Congratulations on the success of your work! :clap:

1 Like

Congratulations and thank you for your work!
I’d like to test it but the download page seems to be missing. When will it be available?

From my understanding, last build failed on I think it’s a building agent issue and @dk1978 is working on a patch.

In the meantime, the microG build suceed and it’s available here :

Some peoples tested it and it seems to work fine (see the unofficial ROM topic), I’ll personally give it a try today :slight_smile:


To make it clear, the problem with the build was our bug, but it should be fixed as of today. The next official LineageOS build should be ready by Tuesday if all goes well. We are on a weekly schedule for 16.0.


Congratulations. I’m looking forward for LOS17.1 and support for the FP3+. Then I would switch to LOS.


First of all, thank you to all people concerned!

@dk1978 are bug reports for the microG version also welcome here?

1 Like

Sure, micro-g suggestions are welcome. I use it as well.


Do you have to unlock the bootloader and install recovery in order to install still?

First thing : Congrats to the team ! I am glad to finally have official-ish (microG) version of lineageOS on my fp3 ! Thanks a lot for giving me a good alternative to /e/OS, or worse, android :p.

Second thing : I have trouble with location with the microG version. Do I report the bugs here ? I just want to be sure not to pollute the thread. If yes, I have raised this issue on an app that cannot locate me, wheter I set my location to “High accuracy”, “Battery saving” or “Device only”. I tested 5 apps in total with odd results.
EDIT : I feel dumb for only getting now that mapfel’s previous message’s “but reports” means “bug reports”.



I guess that even if we are already on LOS, we need to fa actory-reset, right?

Not necessarily. I did a dirty install of the microG LOS (over the unofficial microG version) and it worked entirely without data loss (only had to reinstall Magsik).

I followed the instructions under “dirty install” from here:

Don’t know if it helps but I used booted TWRP (without installing) to first install the the migration ZIP and the sideload the ROM. I would strongly recomend creating a backup first though, in case something goes wrong.

1 Like

Should we be on a specific version of vendor/boot or other image?

Fantastic, kudos to everyone involved in bringing LineageOS to FP3! :tada:


I have installed the MicroG version. It was quite complicated to me, due to my inexperience with some steps and because I started by following the Lineage installation instructions which cannot still be followed. I reproduce here the main problems I had so it may be useful for others in a similar situation.

  • Firstly, I was lazy to understand the whole process before starting it, so I didn’t follow the expected order and did unneeded things (so just don’t use my comments to understand the procedure).
  • It is good to mention that almost any problem I faced was someway linked or answered from some thread in this forum, which was nice. However, that led me to confusion too.
  • There are several sources of instructions. I started by following the Lineage instructions but they cannot be currently used due to the current lack of the LineageOS recovery. The best choice would have been to follow the steps in the previous “unofficial LineageOS” thread in this forum using TWRP.
  • It was a unneeded step, but to access the recovery menu was very complicated by following the official Fairphone instructions. I didn’t understand the timing to press/release the buttons from the fastboot mode.
  • In addition, I forgot about unlocking the bootloader before doing a factory reset. From that state, I read that that is expected to be done from the default OS, so I installed the factory ROM (just booting the phone) and tried to follow the procedure, but it always failed: never mind if I was connected to the internet, I set a PIN code or debug mode was enabled; after introducing the unlock code the system failed to unlock it (reported with a temporary message in the bottom of the screen). I didn’t understand the reason. Then I found the alternative process using fastboot by looking in the forum.
  • When doing that I was not able to guess (even if it is clearly stated in the Lineage installation instructions) that to use the fastboot command I needed to have the phone in fastboot mode, so at any time, fastboot didn’t recognize my device while adb could. Finally I guessed the reason, but all my attempts to understand the issue looking on the internet were unsuccessful.
  • The Lineage instructions (LineageOS for MicroG redirects to them) point to “temporally boot a custom recovery” which at that moment did not exist, probably because the Lineage built is not currently compiled (while the MicroG version is) at the time of writing this. Then I read about TWRP and followed it. Previous complications would have been avoided if I would have started from that point.
  • I never used TWRP before, so I didn’t understand its whole point. However, instructions were clear in the header of the previous unofficial LOS thread in the forum, so I was able to follow them around the TWRP interface after booting it.

And that’s all, everything worked after that.

Edit: Making clear that TWRP method is simpler at the moment and I followed unnecessary steps.

Edit 2: Minor corrections/typos.


Great news!

Is it possible to relock the phone after installing LineageOS?

I know that generally is not recommended, but since Fairphone 3 comes with secure boot disabled [1], it probably does not care about verifying the installed ROM, even if locked - see [2].

Why still lock the bootloader then? Well, it does seem to increase security a bit, as a not-too-sophisticated attacker would not be able to load a new ROM without wiping all user data.

[1] Fairphone 3 unbricking

I read yesterday some threads in the forum reporting problems when locking not default ROMs. Probably you can find there some answers.

Hurrah !
Finally an official build is available :smiley: :smiley: :smiley:
Awesome, congratulations to @dk1978 and all the other contributors


Great news !

Does this rom fix some problems with the default system, for example the “too high minimum britghness” described here ? Lowest brightness is too bright

I don’t think the Lineage OS build has a problem with the brightness. I checked the file /sys/devices/platform/soc/1a00000.qcom,mdss_mdp/1a00000.qcom,mdss_mdp:qcom,mdss_fb_primary/leds/lcd-backlight/brightness. Adjusting the settings slider for the brightness changes the values between 0 and 255 which is likely the best that is possible. The linked forum entry reported that the slider there was only able to get the brightness value down to 10.