English

Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

That’s what i expected :slight_smile: Thanks for this precision.

I have no FP for the moment, but the availability of LineageOS (especially future 17.1 release) could lead me to buy a FP3 (i quite never take photos and have no interest in new modules).

I would like to ask: can I backup data (partition) from LOS 17.1 GSI and restore it to this ROM?

Hello and thank you for your great work, I have been lurking for months and was very eager to have this ROM running on my FP3.

I would like to share with you my experience with the LOS+MicroG rom: the installation process went smooth and I have found no issues in particular with that.

That being said (as with the Unofficial ROM with MicroG) I often experience random touches/swipes in the upper part of the screen. I have not had this issue with the stock ROM, it just has appeared after I had flashed LOS. I have heard (don’t remember where though) that the root cause of this issue is in the firmware or something, and that the fix will come from Fairphone themselves. Is this statement correct?

Another issue I am experiencing is with voice messages in whatsapp: when I play one of them, and I put the phone next to my ear (or a finger gets close to the proximity sensor), the audio freezes and can’t be played again. Only a restart of Whatsapp allows to play again the recording. Is this issue independent from LOS?

When I play to Andor’s Trail, when I load a savegame, often the app crashes. If I load the savegame as the first thing I do when I launch the app, it works. But in other circumstances the app crashes almost always. This did not happen with the stock ROM.

Trust tells me that the vendor security patch is out of date. Is this to be expected? Would my vendor sec. patch be updated if I reverted to FP OS, install the OTA updates, and then flash agian LOS?

Eventually: I have flashed Magisk and the updater tells me there is a 662MB update dated 12 November 2020. When I try to install the OTA update, after the restart the phone does not boot. The LOS logo appears, and loads forever. If I restart the phone during this process, the phone boots and apparently no update is installed.
The procedure I have followed is:

  • uninstall Magisk

  • install the LOS’ OTA update

  • re-install Magisk in the inactive slot

Thank you for what you are doing, you are much appreciated.

I doubt that will work, since you would be downgrading. Might be better to wait until we can release our 17.1 version.

3 Likes

I will examine how and why this message appears. I found this interesting discussion about it. One thing is certain: it will not help you to flash stock images, then reflash LOS, because you would simply be overwriting the vendor partition with the LOS stuff again.

I cannot help you with any problems with apps. From my own experience, you will find apps that misbehave, even when using micro-g. What you can do is examine logs with adb logcat while a crash occurs and see if you get hints as to what is going on.

1 Like

Thank you. I guess 17.1 official is not to be expected anytime soon, right?

A curiosity question, concerning a possible future port for FP3+. Is there a dedicated build to make for FP3+, or once the required modifications are done the official LineageOS image will be compatible with both FP3 and FP3+? :smiley:

I think the changes needed for FP3+ concern the vendor partition only, not the kernel. Fairphone does not appear to provide separate builds for FP3/FP3+. Our Lineage OS 17.1 release should handle both, but I will need to get my hands on one of the new camera modules for tests.

3 Likes

Hello,
I tried to prepare my phone for the installation of the lineage image (from stock).
I face two issues:

  1. I installed ADB ´, the adb drivers (Windows) and rebooted with “adb reboot bootloader”. After the restart and waiting for windows to install the device again, I typed in “fastboot devices”. No device showed up.
    What am I doing wrong?
    EDIT: I tried it again and now it shows up. I didn’t change anything, so I guess the device installation too longer than I thought.

  2. in the Wiki on the lineage site, there is a link to the bootloader unlock:
    https://www.fairphone.com/en/bootloader-unlocking-code-for-fairphone-3/
    This did not do much for me (it kep on displaying the message processing). After a longer waiting time, I simple rebooted and nothing had changed.
    In google I found the following instruction:
    https://support.fairphone.com/hc/en-us/articles/360048646311-Manage-the-bootloader-of-your-FP3-FP3-
    It is much longer and actually tells you to factory reset and includes many more steps.
    Which one would be correct?

Many regards

Do you have a rough time frame for a release?

Hem. With LineageOs or other developments, the rule is… “never ask for an estimated time of arrival” :slight_smile:

7 Likes

I strongly agree, I was just interested whether it is going to be a matter of weeks or of months or something like that.

I wouldn’t know, I didn’t write the Fairphone support articles. :slightly_smiling_face:
If the longer instructions work for you, then they are better right? I unlocked my phone in spring, at that time the bootloader did not need an unlocking code.

I will consider updating the Lineage OS Wiki link to point to the longer instructions if we don’t run into other problems.

Did a dirty install of the MicroG version over the old unofficial one (including flash of the migration zip). Seems to have gone alright, but the OTA updater now says I can update to the version I just installed. Build number reads ‘lineage_FP3-userdebug 9 PQ3A.190801.002 eng.root.20201112.055750 dev-keys’, updater mentions 12 november version of 662MB.

Tried to install the OTA version but the notification remains. Is this normal? Or did I install incorrectly?

1 Like

I got the same thing. That might be a side effect of the dirty flashing. Let’s wait and see what happens once the next micro-g build is available.

3 Likes

Interestingly, for me LOS does the trick regarding the brightness. Furthermore, I don’t suffer from the “no sound in calls” bug and random reboots anymore. For me, it’s a full win! Alas, I cannot guarantee that to work for you as well :wink:

2 Likes

I have to warn you: I also experienced some reboots during longer phone calls (>30min). That was in summer when using the unofficial LineageOS build. This might be a problem we cannot solve as normal OS developers - I think the bug may be in inaccessible baseband or modem code.

1 Like

Thanks for the heads up, @dk1978. As I successfully avoided to be involved in calls > 5 mins yet, I will confirm upon encounter.

I was hoping someone might have unlocked their bootloader recently and might be able to tell me which of the two options is the proper procedure.
I am planning on moving to the microg-lineage on the weekend (haven’t installed custom roms for a long time). I will get back to you, if and when I figured out the correct way.

Bootloader unlocking worked for me with this script: Oem unlock "input verify code"

edit: I did it 3 days ago :slight_smile:

2 Likes