English

Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

@dk1978 Thank you very much for your contributions!

do we have a dedicated thread (or something) for systematic testing? i installed the microG build and did not yet find any problems, however I did not search for them :angel:

There are now 2 different versions of the bootloader unlock code, AFAIK it should depend of which OS version you had. See this post : Bootloader Unlocking Code for Fairphone 3 not working :smiley:

2 Likes

I can confirm this, even though they were not reboots but complete crashes. On the official microG LOS this happened to me twice during a teleconference. The screen went black and the only thing to wake it up again was a force reboot into fastboot mode. Strangely enough, this did not happen on other long calls. Still, I fear this problem is not one with the ROM, but with the FP3 in general.

Atm. I’m running the latest FP-OS (build 8901.2A.0054.20200929) and I’m quite happy with the included camera app (version 2.0.002). Which camera may I expect in the official LOS 16.0 for the FP3?

It is a rather basic one. However, you might want to check out this Thread, where a couple of pixel cam ports are shared. These produce in some cases even better results than the FP3 stock cam. I have tried some of them on LOS and can confirm they work.

2 Likes

Thank You and all persons involved so much!!!
Now i can recommend, buy and roll out new devices for my family members and friends.
I love Your work and efforts.

4 Likes

K9-mail from F-droid has a strange displaying behavior. The top and bottom bars start blinking frequently. Apart from that, it is usable. I am using the MicroG version installed with TWRP.

1 Like

If I remember right I need a migration zip to go from unofficial to official? It’s been long ago i needed that, where can i get one for this migration?

I don’t think you need a migration build. Just try a dirty flash.

2 Likes

Thanks. Update is scheduled for Saturday :slight_smile: still on unofficial

Off topic: For the transition from CyanogenMod to LineageOS, a transition zip was required AFAIK. In my career of flashing custom ROMs, it was the only time I ever needed to do that.

AFAIK a migration zip was used for passing from 14.1 unofficial to official and 15.1 unofficial to official on FP2. See here:

Edit: Typo

2 Likes

I’m remembering it this way also, migration from unofficial to official, to account for the new keys. Still, it might be possible to ignore the change of keys… Will see tomorrow

Yup, this zip was however specific for my unofficial build to the official one. Won’t work for this transition. Maybe the maintainer for the unofficial FP3 build could do the same trick as I did back then (probably the zip is still usable and only the values in the script need to be changed).
I can’t test it as I don’t have the device, else I would have helped :slight_smile:

3 Likes

I installed the first build and so far it’s working very well! :+1:

The only problem that I noticed is that I can’t play Ogg audio files (tried the built-in music player and Odyssey). Did anyone else run into this?

I confirmed that the LineageOS built-in music app (Eleven) can’t play ogg vorbis files, although some apps (such as Firefox) were working. The problem appears to be known. I was able to fix it by modifying some of the audio configuration files - it appears the the device was trying to use hardware codecs to play this format which did not work.

Fix will be included in the builds next week.

4 Likes

Hi all, I’m new to FP3 and never “rooted” a device to install another OS like LOS. Is there a good guide you’d recommend for getting started? Thank you :slight_smile:
Last but not least, is it really worth tinkering with LOS, compared to FPOS?

Rooting the device is something different than installing an alternative OS.
How to do it is explained in the official LineageOS page for FP3.
If it’s worth, well, you’ve to decide… You’ll quite move away from Google services and will get a community driven alternative to standard OS… And “tinkering” with it you’ll probably learn a lot about your device…

3 Likes

Awesome, thanks for saving my music collection! :headphones:

1 Like

Dirty install went without problems, it seems!

Did you happen to add (t)exfat already for the external sd card, or is it not there yet?

2 Likes