English

[ROM][UNOFFICIAL] Unofficial LineageOS 18.1 for Fairphone 3/Fairphone 3+

Firstly, my sincere thanks to all FP3 contributors for there hard work on bringing LOS and other custom ROMs to FP3/3+.

It has just been a week since I switched from FP2 to FP3. Was very happy to know that @dk1978 and others have worked so hard to get LOS official on our device. The description in this and this was my real motivation to proceed further.

I started working on LOS 18.1 for FP3/FP3+ by keeping xiaomi’s sdm632 common tree as reference which did not help much. Finally, yesterday I was able to succeed with a working build.

2 screenshots of the build:

A summary on what’s working, what’s tested and what’s not:

Working:

  • Boot
  • WiFi
  • Bluetooth
  • Camera
  • Radio(Network) - tested on single SIM
  • Data - tested on single SIM
  • Encryption(strange but device was encrypted when I had a first boot. Requires more testing)
  • LOS 17.1 to 18.1 upgrade(without any data loss)

Not working:

  • Minor fingerprint sensors issue.

Not tested:

  • None

If users can test and report more then we can edit this list later.

Here’s the download link: AFH link

Updated link as of May 20th: AFH link

@dk1978 I have changes ready for review if you can permit me to upload.
This is the first build and I am very happy that we are able to get so much on the first build it self.
Really looking forward to all your feedback and suggestions.

Thanks,
TeamB58

19 Likes

Thanks to the moderators for altering/modifying the post.

Thanks for the new badge too.

So, anybody tried the build? If yes, request to please post your feedback and suggestions.

3 Likes

So, I tried out your build today, especially around the bulletpoints under “Not tested”.

NFC:
Appears to not be working. from adb logcat i see the same set of messages repeated every second:

5021 5021 W HidlServiceManagement: Waited one second for android.hardware.nfc@1.2::INfc/default
492 492 I hwservicemanager: Since android.hardware.nfc@1.2::INfc/default is not registered, trying to start it as a lazy HAL.
5021 5021 I HidlServiceManagement: getService: Trying again for android.hardware.nfc@1.2::INfc/default…
492 19849 W libc : Unable to set property “ctl.interface_start” to “android.hardware.nfc@1.2::INfc/default”: error code: 0x20
::INfc/default’ from pid: 492 (/system/bin/hwservicemanager): Cannot find ‘/vendor/bin/hw/android.hardware.nfc@1.2-service’: No such file or directory
15684 15715 E ocessService0:: failed to create Unix domain socket: Operation not permitted

Calls:
Made calls to and from a landline, worked; got audio on both ends, on both tries. considering that as working on my end

Media Playback:
Audio: Streamed via Tidal, worked without a hitch.
Local files from SD card worked as well.
Video: Couldn’t fully test; if streamed via a Browser they seem to work tho.

Hope this can be of any help.If you want me to test more stuff, tell me :stuck_out_tongue:
Juplay (also, my first post on this forum :cake:)

5 Likes

Thank you very much.

For sure this result from you will help us when we prepare for official 18.1 release.
@dk1978 , for your reference.

Also, can you confirm if the display issue(screen is too small) is observed from your end too?
And can you confirm if night light and other display features are working or not?

Thanks.

3 Likes

Yup. The Screensize indeed appears to be extremely small.

Nightlight:
Nope, looking into the logcat again, I’m getting this set of error messages spammed in there whenever I enable this setting:

03-06 12:44:19.347 563 587 E SDM : ColorManager::ApplyLinearColorTransform: Apply PCC for SetTransform FAILED
03-06 12:44:19.347 563 587 E SDM : HWCDisplay::HandleColorModeTransform: Failed to set Color Transform Matrix
03-06 12:44:19.347 563 587 E SDM : HWCDisplay::SetColorTransform: failed for hint = 1
03-06 12:44:19.347 563 587 E SDM : HWCDisplayPrimary::SetColorTransform: failed for hint = 1
03-06 12:44:19.348 533 533 W HwcComposer: command 0x2000000 generated error 8

Dark-mode:Works

Automatic Screenrotation: Works

LiveDisplay: Not Working, can’t seem to find a error message specifically related to it in my logs.

Screensaver: Works

Lockscreen settings: All seem to work.

Tap to Sleep: Works

Wake on Plug: Works

Automatic Brightness:Works

4 Likes

Another workaround for The Screen size I found to Work better for me was to Go into Developer Options -> Drawing -> Set smallest width to 427 dp. (FP3/3+'s Display pixel density, which is smaller than The Default setting for The “largest” Option, which Sets it to 608 dp)
Else nothing new found currently.

Hey, I did a quick test and the ROM is working great.

  • I set smallest width to 360 in developer-options to fix the scaling
  • NFC is not working, It is not even giving me an option to enable it.
  • I played back some flac-files, Youtube-videos and some random local videos with random codecs, everything is working perfectly fine
  • I also did a quick call which was working fine as well
2 Likes

Thanks a lot.

I am willing to create v2 with NFC fix(and scaling if I get some pointers) if users are willing to use it as a daily driver.

I’ll wait for more responses.

TeamB58.

1 Like

I would like to test the Rom as a daily driver but there is one problem. The performance of the FP3 is very choppy on the default battery-profile (on every Rom I tested), changing it to the high performance profile always solved this issue. However in this Rom the slider in the battery-settings is missing. Can I do anything about this?

If the Rom turns out to be stable, what would prevent it from being official?

Could you send a screenshot describing this problem so that I can understand better?

For your second question I think @dk1978 will be the right person to answer.

The first Screenshot is from the FP3, you can see the slider is missing.

1 Like

@TeamB58’s work on 18.1 is in the review pipeline for the official LineageOS FP3 build. Since LOS 18.1 will probably not go official until April/May 2021 I am focussing on fixing remaining issues on 17.1 at the moment.

8 Likes

I’ve been using the ROM as a daily driver since I flashed it (about a day before I sent my first message here).

Will it be possible to upgrade from LOS 17 to 18 without wiping?

Aight, thank you for the clarification and the estimation as well :slight_smile:

Things I found that are not yet working are:

  • NFC
  • Altering display colors (Color correction, Invert colors, Nightlight & LiveDisplay)
  • “device performance”-settings
  • fingerprint swipe-gesture
  • the scaling-thing

I’ll keep using it as a daily driver and keep reporting, if I can do more to support development, please let me know.

Look in the OP in the Whats working-list.

3 Likes

Second screen is from?

Joining the team for this.

Yes, it worked for me.

Issue is there in 17.1 as well. We are working on it.

Need more clarity.

NFC is easy. I have fixed it in my local build. For display scaling I still haven’t been able to fix it.

2 Likes

I remember having this option on LOS 17.1 on the FP2 some time ago before it disappeared (never quite understood why), and I think this option also is here on /e/.

I think the device performance option is the one in the screenshot posted, and the fingerprint gestures are gestures on the fingerprint sensor itself to control e.g the brightness. IIRC the Fairphone 3 fingerprint sensor doesn’t support such gestures, not even on FPOS, so quite logical they’re not on LOS (I may be wrong though).

I can’t really say that. Where do you see this the most?

The second screenshot is from a random phone from the Internet, but I know for a fact it was on the FP3 on almost all roms I tested. All have been Android 10 based: LOS, /e/, FPOS, RR (GSI) & AOSP (GSI). And it was working on all of them, the screen becomes REALLY responsive and smooth if you put it to the max and also games stopped having microstutters. The only workaround I found was to change cpu governor to “performance” but it drains the battery and improves the responsiveness of the screen only very slightly, however it removes the microstutters.

Like @Alex.A said, I mean the issue from the screenshot, I just wanted to have a complete list of the issues I discovered for convenience, but I guess I instead caused more confusion :smiley: sorry man.

There is an option, it says if enabled, you can swipe your fingerprint sensor to bring up your notifications. But if enabled it does nothing if you swipe it. But I guess if it is true what @Alex.A is saying, the hardware is not capable, so I guess this option should get removed/hidden instead.

Hell yeah! Thanks for all your efforts! :hearts:

For example if I have a homescreen full of icons and I swipe up the appdrawer, the stuttering is insane. When I type a text, some key-“presses” don’t get registered at all, I guess it is because of something like a low pollingrate of the touchscreen? Scrolling through youtubes feed is also stuttering like crazy. As soon as I set it to high performance, everything I mentioned is not there anymore, the phone feels really really smooth. Out of a sudden I can type text twice as fast, I am better in games, ect. An easy way to test the difference is the game Stack from Ketchapp. It is stuttering and unplayable on the default settings, change the settings and it is just sooooooo smooth.

Well, not for me… I tried both, really no problems.
I tried a screen recording, but I don’t know whether that’s really representative… I could make that available, as a reference

1 Like