Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

I know thats sad to hear, but it isn’t really a 48MP camera. The camera has a so-called quad-bayer sensor that combines 4 pixes into one whicht results in a 12MP output.
Take a look here:

Have you had those issues with normal phone calls or with messaging apps like Signal/WhatsApp?
Similar issues with messaging apps were mentioned here before and @lklaus opened an issue at GitLab


Thanx for the answer!!
I didn’t know about the camera, but it seems logical!
About the restart issue, i had that 3 times the ladt week and only by normal phone call.

Hello all,
I am waiting for @dk1978 to come online.

In the mean time, here’s a treat to all users from my side.


Moderators/Admins, am I allowed to share this unofficial build via a new post?

1 Like

You are free (and very welcome!) to post a link to the unofficial image with a disclaimer that it is an unofficial image, and users are free to decide to click on it or not :wink:





The FP3 image runs very stable. Many thanks to @dk1978 .

The following problems I currently still have in the Bluetooth area:

  • Volume in the car (with bluetooth) partly too loud / too quiet
  • Starting a call in the car (from contacts) not possible. Nothing happens. Pairing is ok.

Are there others with the same problem?
I am currently on 17.1-20210222-NIGHTLY-FP3.

Thanks for feedback.

Am i doing something wrong? I tried to follow the steps on LineageOS wiki for installing, and when i did “temporarily” flash recovery, it immediately rebooted, i have had no time to hold volume up and power to access recovery mode. Now when i do manage to get into recovery, its a dead android with “no command”. Should i repeat the steps and make sure i get into recovery on first try else the original system will wipe it ?

As I yesterday had an important phone call which terminated three times with a spontaneous reboot:
What exactly are the required partitions to flash after extracting them from the stock ROM?
And who to flash? Can we assume that the normal way would be like fastboot flash modem modem.img? I mean: is the partition always called like the image?

Best regards

In one of the threads there was a script which did the flashing. I’m not sure where it was, but later i probably can amend this post with it, if nobody else was faster…

Edit: yes, looks like all the partitions are named similar:

fastboot flash product product.img -S 522239K || exit 1
fastboot flash keymaster keymaster.img -S 522239K || exit 1
fastboot flash cmnlib64 cmnlib64.img -S 522239K || exit 1
fastboot flash cmnlib cmnlib.img -S 522239K || exit 1
fastboot flash lksecapp lksecapp.img -S 522239K || exit 1
fastboot flash mdtp mdtp.img -S 522239K || exit 1
fastboot flash vendor vendor.img -S 522239K || exit 1
fastboot flash system system.img -S 522239K || exit 1
fastboot flash boot boot.img -S 522239K || exit 1
fastboot flash vbmeta vbmeta.img -S 522239K || exit 1
fastboot flash dtbo dtbo.img -S 522239K || exit 1
fastboot flash dsp dsp.img -S 522239K || exit 1
fastboot flash devcfg devcfg.img -S 522239K || exit 1
fastboot flash tz tz.img -S 522239K || exit 1
fastboot flash rpm rpm.img -S 522239K || exit 1
fastboot flash sbl1 sbl1.img -S 522239K || exit 1
fastboot flash modem modem.img -S 522239K || exit 1
fastboot flash aboot aboot.img -S 522239K || exit 1

Thank you very much. And if I understood @dk1978 correctly, the modem and the dsp are the partitions which should/could be updated, right?
Edit: and of course one must get hands on the stock ROM…

Hi! I have installed an unofficial lineageos 16 (gsi build) some months ago (before FP3 got an official image). So my bootloader is already unlocked, I have twrp installed on the recovery partition (at least the active one) and also magisk and microg (flashed separately). I want to install the microg build of lineago OS, preferably without loosing data :slight_smile:

So far, I understand the upgrade process should be:

  • (backup data partition)
  • adb reboot recovery to reboot into twrp, and sideload in this order:
    • migration zip of microg build
    • new microg lineage os rom
    • magisk
    • twrp in boot partition?
  • reboot, check that everything is working
  • redo step 2 to flash everything in inactive slot.

Is this gonna work? Can I flash directly on LO 17, or do I need to first migrate to microg LO 16

Reading this thread, it feels like I’ll loose my data by upgrading to 17. Is it really the case? Can I restore from the backup I made with twrp after the fact?

Do I have the correct flash order? I might not flash twrp at all btw (I find it handy to have it installed, but I might do it later)

Thanks for your answers.

Hi everyone :slight_smile:
I have a question regarding the following commit: FP3: Import blobs from FP3-REL-Q-3.A.0077-20201221.124002 · LineageOS/android_device_fairphone_FP3@bd8ac5c · GitHub

The commit message sais new blobs are imported, but I only see changed strings. Can someone tell me how the importing of blobs work?
Also I am wondering what blobs get updated with LOS and what blobs dont. Also: How can I update the blobs that dont get updated with LOS? This seems important because of the known call freezes etc that fairphone seems to have fixed now.

Thanks for any details :slight_smile:

Please PM me for the details on how blobs work with LineageOS.

Hey all,

I am waiting for all initial issues to be resolved before I get a FP3+. I read the official blog post about various issues including the random reboots during calls, and there are various upates where it’s mentioned that a lot of the issues are fixed (the December update specifically mentions the random reboots).

Are these fixes incorporated into LineageOS 17? If not, how does it work, are they eventually going to be incorporated? Where can I follow developments on this?

Thanks in advance!

1 Like

So… I had another crash yesterday (which might well be caused by magisk and no point to complain here ;-)), but I got another bootloop again.
This seems to be caused by a timeout because of the time the file system check on my 128G SD card takes (see the issue on the LOS issue tracker, I attached the logcat there, basically, it looks like “DeadSystemException” seems to be the culprit in the end). System boots fine without SD card inserted.
So I tried different filesystems on the SD card, f2fs and ext4, but both seem not to be suited for the SD card as my apps that use the external card are not able to store things then (reading works ok). Trying to do a restorecon on the SD cards wants to change contexts but can’t do it (don’t know whether restorecon is supposed to work here on Android). So, back to exfat and will see what happens next.

Anyone has information as to why f2fs and ext4 don’t work on an external SD card on Android? Or is it a LOS thing?

I think this is very important and would be interesting for many users - including those, who consider deciding for a Fairphone.

Does anyone have serious information on this? Maybe with an explanation how the fixes (made by Fairphone officially) come to LineageOS and what is necessary for this?

1 Like

Hi and welcome,
I am the maintainer of LineageOS on Fairphone (that info may be buried under all the posts by now :slight_smile: ).

  • When Fairphone releases a new OTA zip, preferably with a public link, I will incorporate the new proprietary software, essentially the contents of the vendor partition. There may be a lag of a few weeks and I do prefer to test new releases on my own device for a few days first. The blobs from the December update you mention have now been rolled out.
  • The issues of random reboots are really troublesome, and I still do not know the root cause. I suspect that some of the problems are buried in baseband code such as what you will find on the modem_st1 or modem_st2 partitions. These are not included in LineageOS updates and I do not check their state in the update code. Users will have to flash these partitions themselves or migrate from the latest official stock image. That being said, I have not experienced this issue for some time now and I use my own build every day.
  • Fairphone has an official cooperation with /e/, which is essentially a LineageOS derivative. They have more manpower and resources to solve problems, so if you are worried about the reliability of your phone you may want to check out their build instead. I do talk to /e/ people and fixes have gone both ways in the past.
  • Feel free to PM me with any detailed questions, but do use the search feature first since a lot has already been stated in this thread.

Speaking of baseband: I ordered the FP3 in december last year and i guess this model must have some more up to date version, as i never have had issues being disconnected while calling, or any random reboot. For all interested my version says: 953_GEN_PACK-1.313408.1.325768.1. All in all my phone is operating very stable with LOS and i am very lucky with that. Don’t know if i mentioned it already, but now, after using it for 2 months in every day environment, the volume while having a call is not changeable. it seems to be full power regardless what the slider is at, or if you are on speaker, or not.


Hi @dk1978!

I really, really appreciate the work you’re all putting in to make LineageOS available on the FP3! I’ve ordered mine prior to release because of the repairability, attempt at sustainability and the announcement of google-free OS support. The freedom to choose and modify
my phone’s OS was a reason for the Fairphone as much as the modularity and all the additional considerations that went into making this. So I’ve waited for a stable & official LOS release for quite some time and this weekend I finally installed the ROM (including µg & Magisk because I need my stupid banking app… for now) and I succeeded at the first attempt thanks to the great quality of the software & guides released by the FOSS community. I have a (kind-of-more-or-less) de-googled phone and have not encountered any issues as of yet.

The only things I’ve noticed:

  • The status LED finally works! It hasn’t previously, despite all previous updates and the explicit mentioning of this in one of the update changelogs.
  • The phone does not reboot but only shuts down. To turn it on again, I also have to press the power button for >20 seconds. But that’s not really an issue.
  • I’ve received an update via Settings->System->Updater on the 15th of March, which I didn’t know was possible for Lineage, so that’s awesome!

Thank you and all the other Devs very much! It’s a great opportunity to learn a little bit about the complexities of Android and what it takes to create a (more) free mobile operating system. Using a custom ROM was a great way for me to realize how heavily the whole android mobile experience depends on google’s infrastructure. So… Yay!