English

Official LineageOS 18.1 for Fairphone 3/Fairphone 3+

This effort was started and mostly realized thanks to @TeamB58, see the unofficial 18.1 topic with past contributions by @Max_S, @k4y0z, @sooorajjj, and others. We were faster this time and even beat the stock Fairphone and /e/ releases of Android 11. :smiley:

This topic will collect user feedback, helpful hints, feature wishes and future milestones such as Android 12. To post bug reports, please use the official LineageOS site .

Here a collection of relevant external links:

40 Likes

Many thanks to all community members.

Yeah, looking forward to many more moments in this journey with Fairphone 3/3+. We’re actually sorry for such a long delay in getting LineageOS 18.1 official.

We’ll try to work on future tasks on time.

Thanks.

11 Likes

Thank you for all the hard work you put into this!

4 Likes

The pleasure of a well-organized and well-maintained distribution (to all of us) with now, as a bonus, a world premiere of Android 12 for the FP3! Kudos to all for getting this done :muscle:

I did not spot a downloadable build (at LineageOS Downloads), I guess this will take some time? Or would the first build be available tomorrow (as with 17.1)?

See here:

     

2 Likes

Thank you for your work. Now my Google Nexus Tablet from 2013 is not the device with the newest Android anymore.

Looking forward to this! I’ll be joining the FP gang after my last phone (Poco F1 LOS 18) was snatched from me, so nice to know I can pick up relatively from where I left off

4 Likes

Welcome to the Fairphone forum, hope you some fun with a new phone and the users herein :slight_smile:

1 Like

Looks like the first 18.1 build is already there: LineageOS Downloads

Edit: sorry, it’s no longer there

I haven’t been able to patch the rom using the nanodroid patcher that worked perfectly on the previous version even though services.jar are already deodexed.
I remember reading something about the choice to not include signature spoofing directly into the main rom, is it an official guideline for lineage developers?

Yes, it is. No signature spoofing on official LineageOS roms. The entire story can be found here. But this has always been The Way, and your problem is probably somewhere else.

1 Like

Thanks for your work on this! I just updated using the LineageOS recovery and adb, applying OpenGApps nano. Got a warning about failed signature verification but chose to ignore and install anyway. Everything seems to have worked fine but after booting, I noticed that Bluetooth can not be enabled. It just indicates that it is loading for a little while and then goes back to deactivated. Does anyone else share this experience or even have a suggested solution?

Thanks for the great work.

I’ve installed LineageOS 18.1 on my FP3+ today and it works pretty well.

The only problem i am encountering is that i can’t turn on bluetooth.

When i restart the device my phone tells me bluetooth keeps stopping.
And when i try to turn it on the switch goes back to off after some while.
Any ideas what the problem might be or does somebody else have this problem?

1 Like

the website states:

* 10.0 / SDK 29 (Q)
* Patcher works if your ROM's services.jar already contains classes.dex
  * [> Deodex Instructions](https://github.com/Nanolx/NanoDroid/blob/master/doc/DeodexServices.md)

* 11.0 / SDK 30 (R)
* Patcher does not work from TWRP
* Patcher works from Magisk if your ROM's services.jar already contains classes.dex
  * [> Deodex Instructions](https://github.com/Nanolx/NanoDroid/blob/master/doc/DeodexServices.md)

so there are no big differences between the two versions of android, but it doesn’t work on the los 18.1 and I’m quite surprised.
I’ll make some tests and see what happens.

Just confirmed that. Very surprising, will have to check if there was a regression in the last few days.

4 Likes

Wow that’s really a show stopper. Just upgraded. Sideload did work good. But now know bluetooth, so no corona contact tracing.

Is it possible to go back to 17.1? Without wiping data? Did bluetooth work while 18.1 was in beta?

Another question related to the LOS camera app for the fp3. With fp2 you can scan qr codes with (did work with 17.1 and works with 18.1) With fp3 an LOS 17.1 and 18.1 you can only switch between camera and video-mode. What’s the clue on that?

And don’t get me wrong. Thank you very much for your work to give the community an alternative rom without google - espacially lineage os is my favorite - running on bq Aquaris X, Moto G7, Samsung Tab6 lite, fp2 and fp3 within my family. This is so great.

It did - something must have broken very recently, and maybe not even on the device configuration (our) side.

1 Like

Do you need some information to get bluetooth fixed. logcat e.g. or any other logfiles?

Btw NFC is working.

Very helpful of you, but no - since I can see the problem on my own device, I have all the info I could want. I will try to get it fixed in time for the release next week.

3 Likes

No worries.
I am trying a fix and have given a clean build. Will be back with an update in 2 hours from now.

Really unexpected. Sorry for this issue.

Thanks,
TeamB58.

6 Likes