[ROM][UNOFFICIAL] Unofficial LineageOS 18.1 for Fairphone 3/Fairphone 3+

Thanks for checking this out. That’s weird, since I experienced it on all Roms I tested and I can’t imagine how this could be a hardware issue, since after changing this setting, everything is fine. But maybe it is??

I’m pretty sure it isn’t representative sadly.

I remember there has been stuttering on /e/ and LOS, but this was in early versions and is fixed for some time now…

1 Like

This development and potential official LOS 18.1 ROM sounds so sweet! Is it a collaboration with /e/?

I currently use the official ROM with Android 10. My counterparts are hearing an echo when they talk to me in any video- or voice calling apps. Does anyone know if that issue is resolved in this unofficial LOS 18.1 ROM?

1 Like

I shall update this build with April Security updates because it looks like the build will still take time to go official as I have not heard back from maintainer yet.

I can fix only NFC but I have not yet found any solution to the display size issue.



Hey there @TeamB58 ,
are there any updates on this topic, I am curious :sweat_smile:
Thanks for your awesome work so far :slight_smile:


I have not yet heard back from @dk1978 on what the plan on official update would be. If it’s going to be delayed then I shall plan for another update.

and sorry to keep you waiting. I think we should go for the 18.1 release once the display issue is resolved.


Hey @dk1978 . I am unable to update to the new version.

Again ended up with the vendor project issue. Using 17.1 branch instead of 18.1 but still not working.

Sorry - could you give me some details? What version are you trying to update to?

An example:

I guess we need to extract the blobs with this change: https://review.lineageos.org/c/LineageOS/android_device_fairphone_FP3/+/305303/1 so that it works on 18.1.

Trying to update to latest 18.1 state. Also if possible please update/merge 17.1 changes to 18.1 as well in the proprietary project.

OK. As I see it, we have the commit and the updated extract scripts for the device tree you just linked to, but don’t have suitable *.bp and *.mk files in the vendor 18.1 branch yet which would be the output of the extract scripts. I will get started on fixing that now.

I have worked through all remaining 17.1 issues that I had some hope of fixing. I will test and integrate the FP3 0101 release blobs over the weekend and then rebase the 18.1 work on top of 17.1 as you suggest. Starting next week we do 18.1 and freeze 17.1.


I will rebase and submit the final changes for device project today.

Edit: Upload in progress. Stay tuned. :grinning:


Source updated.

Device HEAD: https://review.lineageos.org/c/LineageOS/android_device_fairphone_FP3/+/310535

Kernel HEAD: https://review.lineageos.org/c/LineageOS/android_kernel_fairphone_sdm632/+/310538

Download: lineage-18.1-20210520-UNOFFICIAL-FP3.zip | by TeamB58 for FP3

What/Where is the changelog for this release, if there is any?
Can I lock the bootloader on it?

Nothing much. Just updated to latest May Security Bulletin of lineage-18.1.

If it works in 17.1 then it will in 18.1 as well. @dk1978 any idea on this question?

Locking the bootloader works on 17.1, so I should also work on 18.1 :slight_smile:

After I realized this is a long weekend :slight_smile: I installed it… I tried mindthegapps, as i need gapps, and opengapps is only a test version, but it did not install, it complained about a low resources device and not enough space. So i went with opengapps test, which seem to work fairly well. Have to root the device again, this somehow did not want to work, but that’s not that urgent. I can’t overcome the minuscule display, though. It does not get the right size after rebooting. Maybe i misunderstood this. Switched to larger text and changed minimum width in developer options. For the rest, it seems everything is working fine

Edit: seems GPS does not listen to baidou and Galileo. Only us and glonass

Thanks a lot for trying out the update.

I cannot edit the OP so moderators, it will be helpful if you can update the new link(available in post #33) and also a short hint to set “smallest width to 360 in developer options” to workaround this display issue.

Thanks for the info, and especially for this build!
Can you think of any reason i can’t flash Magisk? Patching the boot.img as file as well as renaming the apk to zip and installing it in twrp leads to an unbootable system. On LOS17 it was working

Edit: might very well be Magisk related. I joined an issue over there

I made the OP a wiki post, you can know edit it yourself.