LineageOS 14.1 with OTA updates for FP2

This one is merged now @snevas would you please trigger a new build.

Building :slight_smile: please test the after it has finished. See
progress here:

1 Like

Thanks for the testbuild but sadly it didn’t work for me. SIM2 SMS bug is still present on my phone.
@_Chris @oli.sax would you give a try on the testbuild?

You can see the SVN changes to the device tree and the build information here. If you look at the build start date you can trace it back to a release.

I am trying to follow these steps (from a FP2 open OS 17.04)
Flashing OTA fix went (finally) ok
But when I come to flash the and the, my phone always answers “zip signature verification failed” (doesn’t change a thing if I do it queuing the 2 files or step by step).
Does someone have an idea what I could try?

20170609 isn’t a OTA build. Download the latest here:

20170803 is the latest build. This one will flash after the migration zip.

Also disable the verification step checkbox before you flash.

I thought you didnt need the migration zip, as the instructions in the 1st post don’t mention flashing it if coming from FPOS. I didn’t use it when I came from Open Android 5.1 and I can get OTA updates with Lineage.
I’d say that if you follow the instructions in the 1st post under “if coming from any other build” then it should be a ok :slight_smile:

As I have a Mac, I had trouble getting fastboot to work, so instead I was able to use the TWRP App, which I downloaded from the play store to the phone, to flash the TWRP OTA Fix to recovery. This skipped the fastboot trouble. I can still successfully install Lineage OTA updates through the updater. What do you think about me adding a line or two with installation instructions in the beginning of this thread for those who can’t get fastboot going? It might help Lineage to reach a wider audience :slight_smile:

1 Like

It’s a wiki post, so you can edit it yourself. But try to keep the instructions as simple as possible :slight_smile:

1 Like

Thanks! But I am still trying…
I updated open OS to the very last one 17.07.
(actually I had a look at lineage because it was impossible to get the file from here 2 days ago, but it worked today… :slight_smile: )
Everything was still okay (apps, contacts, sms,… :slight_smile: )
I flashed modem-17.07.6 (myabe it was not useful now I had the latest open OS?)
Then lineage-migration-signed (the latest one 08-03)
What should I choose now in the team wine recovery project page?

Edit : Actually, I finally manage to get Lineage OTA updates through the updater so I made a step (or at least I hope so…). But after the reboot, I have this same screen and I don’t kow what to do

If coming from open OS, follow this part from the 1st post (no migration zip needed):

Be aware that you’ll need to factory reset and you’ll lose all data that you don’t backup.

Ok, thanks, I will start from scratch :slight_smile:

Edit: sounds like it doesn’t work… I am “stuck” in open OS 17.07 whatever I try… :frowning:
Maybe is it because I get an “error 7” message (while flashing lineage-14.1-20170803…zip)?
I keep trying :slight_smile:

Edit2: I did exactly what is written here

And I still get this get this error7 message :-/

Edit3: No, it worked finally… in 2 steps

  1. factory reset
  2. flashing lineage

@sky I just installed the of 05/08/2017 and I also confirm that the SIM2 for SMS setup does’nt survive a reboot :frowning:

Pushed a update with the new security patches. Nothing else changed. Timestamp is 20170808.

Be aware of the following bugs:


As I still can’t OTA successfully (“Die Überprüfung ist fehlgeschlagen, beschädigter oder …”), I got me a logcat:

08-08 20:13:10.945 10081 18291 D DownloadManager: [269] Finished with status SUCCESS
08-08 20:13:14.691 7880 7890 I art : Background sticky concurrent mark sweep GC freed 139423(6MB) AllocSpace objects, 5(168KB) LOS objects, 28% free, 19MB/26MB, paused 1.564ms total 203.863ms
08-08 20:13:24.540 10081 10093 V DownloadManager: Deleting /data/data/ via provider delete
08-08 20:13:30.775 18216 20682 E DownloadComplete: Verification failed
08-08 20:13:30.775 18216 20682 E DownloadComplete: signature digest verification failed
08-08 20:13:30.775 18216 20682 E DownloadComplete: at android.os.RecoverySystem.verifyPackage(
08-08 20:13:30.775 18216 20682 E DownloadComplete: at com.cyanogenmod.updater.service.DownloadCompleteIntentService.onHandleIntent(
08-08 20:13:30.775 18216 20682 E DownloadComplete: at$ServiceHandler.handleMessage(
08-08 20:13:30.775 18216 20682 E DownloadComplete: at android.os.Handler.dispatchMessage(
08-08 20:13:30.775 18216 20682 E DownloadComplete: at android.os.Looper.loop(
08-08 20:13:30.775 18216 20682 E DownloadComplete: at

(How do I format this best?)

Is it possible that the LineageOS/android_frameworks_opt_telephony tree isn’t used in our LAOS builds?

It’s included. If you search within the buildservers console log you’ll see:
00:01:19.506 Fetching project LineageOS/android_frameworks_opt_telephony

But I’ve heard there have been some other changes yesterday that could fix it. Could you test this one after is finishes?

I’ve seen that, but no more hints to the content of that tree and also no hints to in my logcat after booting the phone.

I’ll try the new build as soon as possible.

No, the new testbuild didn’t fix it.