Lineage-16.0 (Android Pie) Nightly

Yeah, for me the problem is aging :wink:


I just noticed that while charging (regardless of via computer or wall socket), the display won’t completely black out. It will dim down after like 53-54 seconds, but won’t turn all black.
Once I disconnect the charging cable, the display will black out after a minute, just as set in the settings.

Other (chosen) settings: Flight mode activated, automatic display brightness

Has anyone else experienced this? Is it normal?

Tried twice. Slightly different behaviour each time…

First try: display went fully black after less than a minute.
Second try: display dimmed down after about a minute. Went fully black about 5s later.

No flight mode, automatic display brightness on.

1 Like

Currently my pattern persists. What I have tried in the meantime without a different outcome:

  • lifting flight mode
  • deactivating “Wake on plug”
  • deactivating adaptive brightness
  • reboot after each of the above to double make sure each changed setting was really effective (and also of course in order to just give a reboot an unspecific chance)

The pattern is there when charging and it disappears when unplugged.

P.S.: Wild conspiracy guess: Charging level is 95%+. Is keeping the display active a way for the FP2 to let off excess energy? :stuck_out_tongue_winking_eye:

I don’t think I understood the problem, tbh.


Hey, for example…

These two settings will make the alarm sound silent.

… and from this setting the alarm clock is heard.

1 Like

Thanks for the advice. I can confirm that bug.

My phone did not charge last night. The icon “battery charging” is on, but the battery keeps going down slowly :-/
The day before I charged it with the same wire, but in greece. It works well. Tonight, in France, it was not charging anymore. Any idea?

Edit : after rebooting ,it seems to charge again. Strange.

New builds contain an open-source camera hal that has been added to the FP2 lineage source. Please check if your cam still works as before.

Why? This enables us to separate camera from media server - a security feature introduced in N.
Who? This work has been done by other guys, too, on other msm8974 lineage devies. Namely responsible for that work that I “copied” is Michael Bestas, sultanxda, and others. Authorship on the commits are as usual retained. Chain can be found here:



First tests reveal no problems or differences for me

I use Lineage with Gapps paket nano. It is the same problem other people mentioned here. After booting there is no SIM unlock. But when I turn the screen off and on there it is.

Will LOS 16.0 also get the Lockdown feature?

It’s not there yet - wait for next build :slight_smile:

AptX - actually I had to remove it from FP2. Original fairphone does not have it, so I am not allowed to ship it.


13 posts were split to a new topic: aptX codec removed from official LOS 16.0

I had wlan disconntions. I don’t know if it really helps. But it seemed that they are gone after I removed the spaces in the name.
Old name : “This Is My Wlan”
New Name: “ThisIsMyWlan”

Confirmed for LineageOS 16.0 for microG.

While the most left volume setting correctly mutes the alarm, as the icon next to it indicates, the setting one step to the right gives a sound with LineageOS 15.1 for microG, but not with LineageOS 16.0 for microG.

1 Like

Keyboard issues and home/task buttons don’t work:

Every now and then (several times a day), the keyboard does not show up anymore when the cursor is set in a text field. At the same time, the home and task switcher buttons don’t work anymore (pressing them triggers the optical highlighting of the button, but nothing happens). Back button works though.

I need to reboot the phone or switch the keyboard in system settings from Gboard to AOSP, to get everything going again.
(I first thought it has to do with Gboard, but it also happens with the default AOSP keyboard as well.)

Any ideas on how this could be fixed :thinking: ?

Using OpenCamera currently, it’s starting with resolution and ISO information. ISO reads ISO100 after I flashed todays LoS (2019-05-20). This leads to much darker pictures than before the new HAL. Using the stock camera app is not showing this problem (ISO on auto).

Where can I configure ISO setting in OpenCamera ;)? A dumb question I guess…

Using the stock camera app still has an out of sync flash by the way :-/.


With the “-/+” icon above the flash settings icon.


Wow, that was easy ;). So the new camera HAL is working like a charm here.