GPS fix takes very long after update (with e.g. and GPSTest)

Hi there,
after the last ROM update I noticed a very slow GPS fix. Before updating, the fix took only some seconds, now it takes up to 5 minutes. I checked with different apps, same behaviour.
Anyone seeing the same?
Any fix for this?


I see the same behaviour with my FP4. Regardless of the app I use.


Yes, I do have the same problem since the update. I will open a support ticket later and you should do the same.


It’s frustrating to see that Fairphone still hasn’t setup a good QA pipeline :frowning: I did see something a while ago that they are going to setup a beta community, so at least there’s that.


Well, I’ve just learned this the hard way. I set up a route in my navigation app, got on my way an the app suddenly lost track of where I was. I had to switch to Google Maps, which - probably thanks to some black magic - worked fine. But any other app just cannot get GPS data in time. Even GPSTest shows that it takes an enormous amount of time to get a fix. Very frustrating.

1 Like

Have you already opened the ticket?

It’s not a bad idea if everyone contacts support. It sends a message and priority to get things fixed. But also to improve their QA. We didn’t buy a beta release or prototype phone which is still in development. We should be able to count on our phone and not be afraid to update because it might break usability.


You’re right, I’ve just sent a support request.

Yes, no answer so far.

Did anyone try to revoke / grant “Always permittet” for Location for any App?

In my case Google (not Google Maps!) and Garmin Connect have “Always permittet” on, Maps and Strava only when running. It works reliable for every App.

Well, that’s not really a solution. I actually like using Google’s location history (aka Google Timeline) and by disabling the access to location, I would lose it. This is similar to the microphone issue. When you disable access to microphone, it fixes call quality for some people. But then again, I actually like using Google Assistant and it saved me when my navigation failed to get location data. I could just switch to Google Maps using my voice.

Btw, I got a reply from support. They wanted screenshots from GNSS Viewer, first at the start, then after 20 minutes. I’m not really sure if it helps them, because the app eventually gets a fix. It’s just too slow for a navigation app to keep up when it’s used in a car moving 100 km/h.


It’s almost like they can’t replicate the issue, but many people reported the same issue. Strange.


What is even more strange is that I also can’t replicate it anymore. I now always get a fast fix. But I also haven’t restarted my phone for about a week, maybe the problem would return after boot.


You can easily test this by restarting your phone :wink:

But I don’t want the issue to return :joy:

In that case you might break the record of the longest uptime :wink:

What is the record? Is there a thread for competing? I’m at 520 hours :sweat_smile:

1 Like

I’m also “struggling” replicating the long fix issue. It definitely happened to me once after getting out of subway - the phone was looking for a fix for 5 minutes or so. But since then, I can’t replicate, not even with a freshly restarted phone. The fix is almost instant. But no system update came since I had the issue.


This is really strange. Had the same behavior after the january update - took about 10 minutes to get a fix. GPS status incdicated a GPS week number rollover problem.

Two weeks later it suddendly worked - fast fix.

Yesterday I installed the february update, and … no fix.

Looks like AGPS data is totally ignored, starts with only showing one to three GPS satellites, after some minutes GLONASS and GALILEO and the rest show up…

Rebooted the phone several times, but this does not fix the issue. :frowning:

1 Like

I’ve installed the Feb update yesterday, rebooted twice, and now I just went to a window and got a fix in a few seconds. The support has told me to install GNSS Viewer app and take screenshots when the issue appears. If anyone tests for this, please, take the screenshots.

  1. Download and install GNSS Viewer from the Play Store.
  2. Place your phone next to a window, on a balcony, or in any place where you have a clear view of the sky, with no obstacles.
  3. Make sure “Location” is enabled on your Fairphone 4.
  4. Start the GNSS Viewer app and take screenshot(s) of what you see on the screen.
  5. Wait 10 min. and take screenshot(s) again of what you see on the screen.
  6. Send us all the screenshot(s).