[ROM][UNOFFICIAL] Unofficial LineageOS 19.0 for Fairphone 3/Fairphone 3+

Sorry all for the mess.

The issue is, in Android R stock they have migrated most of the content from product partition to system_ext partition.

This affects 18.1 to 19.0 upgrade. As a quick workaround I am adding the permissions to product partition as well.

Clean build going on. Download link should be available in a maximum of 3 hours.

Apologies for the mess again.


Nice. I have a fairphone 4.

This worked me. I downloaded TeamB58s file and sideloaded it to my fp3 with adb. Instructions here.. Took a while and gave me a warning that this was a downgrade from the 18.1 MicroG Lineage build I was on. Rebooted and I’m on 12. Although with no MicroG. I guess I’ll have to wait for a build with signature spoofing.

Thank you so much.

Let me know if you run into any issues. I’ll try to address them before we go official.

I’m seeing two issues.

  1. I can’t get a location fix
  2. Auto Dark theme is not coming on when set to sunset/sunrise

I’m not using any Gapps I’ll try getting microG working, I assume I don’t need signature spoofing if I’m not using the fakestore

You are not alone :slightly_smiling_face: : GPS fix takes very long after update (with e.g. Mapy.cz and GPSTest) (that topic is about FPOS, but the problem might still have the same root cause)
Edit: Should have looked more closely, you are talking about FP3 here, sorry, my bad :man_facepalming:

If I remember correctly, that features needs a location to get the proper times for sunset / sunrise, so likely related to your first issue.

1 Like

Noted. I’ll look into it.


1 Like

Also found that I cant get Wifi tethering to work.

Had some weird issues where after a reboot my installed launcher (Lawnchair alphas) refused to boot and I had to switched to Trebuchet to open anything. Other times apps will appear to get stuck on the splashscreen.

Could be unrelated, but I can’t download photos from Telegram.

As a note, I did a factory reset to see if that would fix anything. It didn’t.

Supplying these details for information not complaining. Everything else has been fine

A little update on my experience of continuing to use this version of Lineage 19.
Location is still not working for me
Wi-Fi tethering seems to be intermittent, sometimes it works, others not.

Thank you very much for your support. It looks like both the issues(tethering and location) are now working in the new test build.
Tethering - kept it ON for close to 30 minutes and it works
Location - tested with GPS test app from F-droid and I get proper details even inside my house.

Generating a clean build now. Will upload and update the post very soon.

Edit: New download link: Mediafire


Unable to edit the first post. Can someone change it please?

Thanks for your hard work \ ^^ //
Gonna try it soon :smile:

I tried it for some minutes, works super well, I love it! A thing I noticed right away, that would be super nice to have: The new notification light that turns on when the camera is accessed is located in the top right corner of the display. Would it be possible to use the hardware LED (the notification LED) for such purposes?

Thanks for your feedback.

This is not a hardware LED. It’s a new feature in Android 12 which can be disabled by disabling “Camera access” QS tile.

1 Like

Thanks for the new build. Location and tethering works for me too. So nice to see the Monet theming working across the OS.
Still have a few small issues.
The phone will not complete update if I use Lawnchair as my launcher. It also acts weird after a reboot if Trebuchet is not set as default. This could be a Lawnchair issue, as it’s still in Alpha.
Images are not downloading for my with Telegram. Can anyone confirm this?

Mhh i’m now on 19, but i had to whipe my data.
Recovery told me that my data got corrupted.

For me its not that bad, cause i had a backup. Just wanted to point it out ^^

1 Like

Hm, I think we are talking past each other. Let me try to make it more clear what I was trying to say:
I am very happy with the camera access feature as it is. It reminds me of how webcams work on computers where there is a light right next to the camera that is on as long as the camera is used. However I thought that it might not be necessary to reserve space in the notification bar for the camera access notification by making the feature even more computer-like: I thought of a feature where instead of a dot in the top right corner of the screen the notification LED would turn on if the camera is accessed.

also NFC doesn’t seem to work on my Phone.
At least Yubico Authenticator tells me (after installing ykDroid) ‘This device doesn’t seem to Support NFC’

think i found the error… had problems with flashing the lastest build yesterday, so i took the link from the staring post… so yeah… i’m still on the version 20220228. I tried to update it to the latest build via adb sideload. recoverey tells my everthing went smooth, but after the reboot i’m somehow still on the old version. at booting no error is displayed :thinking:

1 Like

That’s strange… I tried multiple times and it works!!

Works fine here.

1 Like