GPS/location does not work (Android)


I got the new FP4. Unfortunately the location service does not work.
“Use location”/“Standort verwenden” is turned on. I gave the rights to use the location to some apps. I restricted all google location services like Bluetooth/WLAN search and sharing the location with google (Except emergency location service).

When I e.g. open OsmAnd, it only says “Position noch nicht bekannt. A-GPS-Daten heruntergeladen: 2021-MM-TT” (not sure how the official english translation is, something like “Location not found. A-GPS-Data downloaded: 2021-MM-DD”).

Is there anything I can do for troubleshooting?
Since it downloads A-GPS Data, I’d assume, that the GPS Module is not broken, is that correct?

1 Like

A-GPS data is just used to speed up the time it takes your phone to get a GPS fix.
You can use a app like GPSTest ( F-Droid | Google Play ) to check if your GPS is actually seeing any satellites.


Hi hirnsushi,

Thank you so much for that hint.
I installed that app. It sais:
#Sats: 0/6/23
But there is no lat/long given. Even after a few minutes on the window sill.

My old Phone (Nikia 5.1) lying at the same spot sais:
#Sats: 8/13/38 and it shows lat and long an all the other stuff.
Does this mean, that the GIS module of the FP4 is worse than the one from my old phone?

:thinking: Hmm, those numbers seem a bit low to me.

  • The first # indicates the number of satellites used in the GPS fix. Since you don’t have a fix there’s 0
  • The second # indicates the number of satellites with sufficient signal strength. 6 might be too low
  • The third # indicates the number of satellites your phone “sees” in total

My numbers are 13/16/36 at the moment, but I’m on the top floor with only some roof between me and the sky.
I wouldn’t say worse per se, my Nexus 4 right next to me doesn’t get a fix, so from my point of view it’s better :smirk:

1 Like

No satellite fix after a few minutes at the window really sounds like you might have a problem with your gps. I have a fix with 15 satellites after a few seconds sitting around 1,5 meters from the windows.

The big question here is, did you manage to get a fix at all, even just outside? :thinking:
If you didn’t, definitely a problem, otherwise I’d still file this under normal operation.
It’s not like GPS is designed to work indoors. Interference from steel structures in the walls and ceiling, energy saving windows, all that and more can and will mess up your signal.

If you really need reliable location information indoors, I’d suggest either turning Bluetooth / Wifi search back on or (if you don’t trust that) installing microG and a cell / wifi location provider.


Thanks so much for your answers.

I got a fix after using GPS Test to load new Time Data and new PSDS Data, yesterday.
It still takes some time, but I will test it outside later.


Had a similar problem: deactivated all Google-related GPS thingies and couldn’t get a fix with OSMand and SatStat. Around 18 satellites were shown but no connection to even a single one.
I installed UnifiedNlp from F-Droid: UnifiedNlp (GAPPS) | F-Droid - Free and Open Source Android App Repository and after a reboot, I got a fix almost immediately and over 38 satellites were shown (connection to around 17)

1 Like

are you rooted and using Xposed? because that package requires a very specific setup (and seems pretty outdated anyway), and I doubt it can fix location problems on its own.

1 Like

Haha, you’re right! Uninstalled the UnifiedNlp App and restarted - quick check for a GPS fix with SatStat and it barely takes two seconds to get a fix!
I didn’t change anything else and before installing the app, I never got a fix - even trying for minutes at different locations over a period of days. :man_shrugging:

All in all, I already liked the GPS module of the FP2 and the FP4 seems to be even better in this regard. Nice!

do you have Google Location Accuracy enabled in the location settings? because that will affect how fast the phone will establish your location (with some privacy tradeoff, though)

Was always off and still is.

Worked for me - thank you!!! But I had to activate Google Location Accuracy one time to make it work. Now GPS works without it.

1 Like

It worked for me as well. But what still is making some truble is, that GPSneeds ages to start. With my old phone it took a Max of 5min. But here I need to aktivate GPS a way ahead. Couldn’t figure yethowlong exactly.

This is not true anymore. I now also have problems getting a quick GPS fix. Sometimes it helps to activate Google Location Accuracy for a second, but not always. I wonder if this might have something to do with the most recent software update?

My GPS problem returned as well. I rarely used the GPS during the last weeks but when I tried activating it yesterday, I couldn’t get a fix. Tried PSDS injection through GPSTest and AGPS download through SatStat to no avail. It took the FP4 over an hour! to get a fix.

1 Like

More talk of this here, seems linked to a recent OS update:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.