FP3+: Issues with Android 13 update

“you all know it”: No, I don’t (FP3). Neither does my sister (FP3+). Go figure.

1 Like

I did a factory reset with backup up before and restore after. FP3 works very well and fast now.


I had the same problem on my 3. My 3+ did not have the problem.
Try to remove the phone from your router and the router from the phone. Then reestablish the WIFI connection.
Worked for me.

I have a small update about the missing dial tone for outgoing calls mentioned here. Until recently, we believed that this would be resolved with a software update in early October. This was also communicated by our support agents.

Unfortunately, the issue has reappeared in our most recent tests. Our Software team will go back to the drawing board and do their best to fix it by the next update. In the meantime, the workaround (disabling VoLTE/4G calling) continues to work well.

Thanks for your support and active participation in this topic.


I experience 3 issues after Android 13 update:

Roaming: I live on the border with Slovenia, and roaming just stopped working. No data network, phone network connection working. Data is only reconnected if I go back to Italy, though I need to restart the phone.
I didn’t care that much until I traveled to Belgium: a week offline, except for the occasional wi-fi! A nighmare.
Yesterday I tried moving my SIM to another phone, and went to Slovenia, and it worked! So I know the problem is my loved Fairphone3, or a combination of that with my operator.

Fingerprint: some apps seem unable to read my fingerprint. This is particularly problematic for my home banking. Last time I was abroad I was totally unable to access home-banking not only because of the internet access (see above), but because a 2-steps recognition system demands fingerpint OR a code sent via text message. But I did NOT receive text messages from Italy abroad, because of my operator.

Blank screen: sometimes the screen becomes totally dark, the phone seems not to work anymore. I have to force restart and then I am placed back where I was (same windows open a.s.o.) as if I hadn’t rebooted. Might be a screen issue, it does not happen regularly, and I had receive some Graphic UI notices months ago that I never solved.

I am considering what to do next, moving out of fairphone is one of the options

Unfortunately this is a known problem with the A13 update, due to a change in Android security rules. Please see posts above in this thread, and please read here

and see here for a wiki-list of apps that are affected or that aren’t (maybe you will be able to contribute):

For your roaming problems I would recommend getting in touch with both Fairphone official support (click > contactsupport for more info) and also contact your mobile network operator, even if the SIM works for roaming in a different phone. This is complex territory and both “sides” need to know about the problem.

For the blank screen, some users have found that this stops happening when they disable automatic screen rotation (go to Settings > Display > Auto rotate screen).
See this and following posts:


I have updated my phone today and the SIM issue is solved (but SD one is still there).
I did not have yet test my other issues but it seems that some of them are covered by the update.

1 Like

Fixed with 6.A.022.1 !

1 Like

hello, I have a fairphone 3 and since the Android 13 update I have problems with the hotspot by USB (it worked very well before and now it no longer works or very rarely) and via wifi only if I restart my phone each time. … Someone would have any idea ?

1 Like

Thanks for the news @shaakunthala , I was still with the “no WPA” mode on, just to speed up the manual reconnection but now I have tried WPA2 and I confirm, devices reconnect to the Fairphone hotspot without typing the password again. Now I hope the will fix a similar issue with the bluetooth connection, everytime I get in my car I have to reboot the phone in order to connect it to the hand free system.

1 Like

Did some tests, the Wifi hotspot connection with modern devices (5Ghz) is now ok, but old devices (2,4 GHZ) still can’t reconnect, they consider the phone as a new device every time… let’s hope for the next update.

Could it be because of the “Randomize MAC” setting which is by default “On” in newer Android versions?


Yes, I also think this is the problem. I can disable the random MAC access for every WIFI connection, (gear icon on the connection) but I don’t understand how to disable it for the hotspot…

My Fairphone 3 has become almost unusable since installing Android 13. Some big issues I have experienced;

I can’t take screenshots anymore. Whenever I take a screenshot, I get an error notification that simply reads ‘Couldn’t save screenshot Can’t save screenshot’. I have an SD card with about 100GB of storage available, plus my Camera app works fine, as do video recordings. But not screenshots. I hate how little information that the error notification gives. Tapping on it does nothing, there’s no error code or log information to tell me why I can’t take screenshots, just that I can’t.

My SIM card does not activate after a reboot. If I reboot now since updating to Android 13, I must call someone, wait for the call to fail due to the phone not recognizing the sim card. About 30 seconds to 2 minutes later, then I get prompted to enter my sim PIN. Only then does my 4G, SMS etc. work. On a similar note, the phone doesn’t seem to keep track of time while it is switched off, so if I reboot, I will have incorrect date and time until I do my little ritual with the failed call, or get Wi-Fi. I don’t remember this being a thing before the update.

‘Failed’ Reboots. I don’t know how else to describe this phenomenon, but I have been getting an issue, where if I reboot the phone once, the first time, it will just boot into a Black screen. I can access notifications and go to settings from there, but no other apps will work. I can only get black screen. If I go Settings > Apps > and launch a random app, it just goes to black screen again. I have to re-reboot to get actually be able to use the damn phone, only after the second reboot do I get all the expected behaviors and functionality.

Random apps crashing on launch. Sometimes apps will just not launch or immediately crash. Apps like KDEcoonect and Zorin connect, whether they are installed via Google Play or F-Droid, they will not launch no matter what. There have been other cases of apps not working, but these are the most recent ones I’ve seen.

Some apps not working with fingerprint sensor. This one is just confusing to me. Some apps have no issues whatsoever with using the fingerprint sensor, such as Bitwarden. I use my fingerprint as a faster login to access my passwords etc. But my banking app N26 will not work with my fingerprint, when I try to enable biometric login in the N26 app, it just says ‘error occurred’. N26 said there’s no reason from what they can see that it would be the app, especially since this function worked fine before switching to Android 13.

Toggling Bluetooth On or Off brings the phone to an absolute crawl for several minutes. This one is particularly frustrating, for some reason, toggling Bluetooth on or off makes the phone almost freeze for at least two minutes. I always forget about this when I am about to listen to music on my headphones or in my car. I go to settings, go to enable Bluetooth, then have my phone basically freeze for a few minutes. No indication of how long it will take or if it will unfreeze so I can actually go to my music app and play some music or whatever.

With all that said, is it just easier to revert to a previous version of Android? Can someone point me in the right direction on how this can be done. I rely on my phone for so much, and I love my Fairphone 3, I love what Fairphone themselves are trying to do. But there are just too many bugs and too much frustration that comes from using my phone now.

What is the last update on your phone ? Did you try in safe mode to see if there is not a problem with an app ? And are you ready to try a factory reset in case nothing else works ?

1 Like

Is your SD card configured as internal or portable memory?
Sounds like internal, what could cause some of the mentioned problems. See sdcardguide

(Regarding the problem with the fingerprint sensor see above. As a workaround you might consider to install lineageOS.)


Just FYI, MC_sickle334: I’ve moved your post and the replies about the SD card here because the other thread is solely about the fingerprint issue in A13 on the FP3(+).

1 Like

The settings app says I am up to date

Android Version: 13
Android Security Update: August 5, 2023

So a quick update after seeing you mention SD card issues. I managed to reformat my Samsung SD card as external, and it has solved my Screenshot issue.

Had the error notification gave a bit more info about what was causing the problem, it might not have been such an annoyance. But in any case, it does seem that using an SD card as internal storage on Fairphone 3 can cause screenshots to not work.

It has also helped with app performance. KDEconnect no longer crashes on launch.

Edited to add also, reformatting SD card has also helped with those ‘failed’ reboots I mentioned above. I had no idea that the memery card would impact performance this much.


See sdcardguide .
It’s a more general Android version thing than a particular Fairphone thing, but yes, Fairphones are affected, too, and badly.

I don’t know why this is even still offered to unsuspecting users as a formatting possibility. It made a limited kind of sense in the beginning of smartphoning when built-in storage was a real bottleneck, but it was a bad idea technically back then already to chain together sturdy built-in storage and a flimsy SD card in a flimsy card slot. And recent Android bugs obviously don’t help with this either.