FP Open OS: Clock resets after reboot


I’m using the Fairphone2 Open OS.
I turn off my phone each evening, and power it on again each morning (The fairphone 1 used to handle this automatically but that’s another subject…).

I noticed that each morning the date and time are wrong for almost 1 minute, and set in 1970, as if there was no hardware clock backup while the phone is off. This reminds me of personal computers from the ’70–’80 era, that had no battery, and booted in 1970-01-01 each time…

Is such a backward behaviour normal is this day and age?


my clock still resets after every reboot - now, after the update (Method 1). Before it worked fine.
Also clicking on a link in Facebook always brings a “NETWORK_ERROR” of some sort.

1 Like

[quote=“Friek, post:55, topic:17208, full:true”]
my clock still resets after every reboot[/quote]
Confirm this behaviour. After reboot if no network connection and/or airplain mode is enabled, date is not set corectly. After disabling airplain mode, clock is set correctly - reproduceable!


Even after switching the airplane mode off, the clock did not reset. Had to set it manually.

I think this may have to do with my firewall. Which service should I activate? Any suggestions?
And which other services should I activate? Media server? GPS?

On my FP1 I have an entry called ‘(NTP) - Internet time servers’ (hopefully still relevant as it is the same firewall).

1 Like

I moved this to #software:bug-reports and put it in the #bugslist::tag as this seems to be a reproducible issue with FP Open OS. (It has been reported in self-compiled versions and in the beta tests before.)

I believe everybody running FP Open OS is affected, but if you have set date & time automatically, have a SIM inserted and a good connection you won’t even notice the issue. However if I remove my SIM or am in an area without reception my FP2 resets to January 1st 1970 every time and that means that many apps won’t work until you manually set it back. E.g. Firefox tells me it won’t load forum.fairphone.com as the security certificate is only valid in the future. (don’t remember the exact words).

After I opend that up on my firewall, my clock set after booting - but it takes 5-10 seconds.

Incorrect date and time cause SSL certificates to be invalid. This affects not only browsing (on HTTPS sites, which is HTTP over SSL), but any SSL communication. So apps are affected as well.

About the actualization of the clock, the OS tries to retrieve the date and hour from the cellular network after switching on (thus you have to insert at least one SIM and disable airplane mode). I’m not sure if the OS tries to retrieve date and hour from a NTP server if you have WiFi enabled, I don’t think so.

This said, phones/machines have a hardware clock, or a Real Time Clock (RTC) system.

Any update on when the issue that the clock is reset every boot will be fixed? I located the problem, that Android fails to set the hardware clock (as the hardware clock is running from 01.01.1970) since you last removed the battery.
For other: If you run the command “hwclock” you get the hardware clock time, which is set to the system/software clock every boot. If you run “hwclock -w” (which should set the hardware clock from the system clock), you get an error message.


At the moment the FP SW team is working on general bugs of FP 2 OS. A release candidate is being tested right now in the beta section of the forum and if everything goes well it will be released soon. I guess afterwards they will put the same fixes into FP Open OS and maybe then they’ll start working on the Open-OS-specific bugs.

1 Like

At first, like @paulakreuzer said, I thought that this issue wouldn’t really affect me as long as I “have a SIM card inserted and a good connection”.

Unfortunately, it is not so !

As I said in another bug report, I shutdown my phone at night. It (is supposed to) auto-boot at 8:00 AM, but with the FP1, I still used the phone sometimes as an alarm-clock, with the alarm set to eg. 6:30 AM.

I did just this yesterday: I set the alarm to 6:30 AM for this morning. And the alarm did not wake me up! As far as the system was concerned, it was 2:00 PM in 1970…

When I powered up the phone, it first just showed that an alarm was programmed for sometime 46 years in the future, and then it synchronized the time and told me that I missed an alarm. I did indeed :frowning:

That sucks, but alarm won’t work if you turned off the phone anyway, unless you enable quickboot mode - which is known to be buggy and cause infinite boot-loops…

I don’t know the technical details involved. But try with a Fairphone 1, without any technical tweaking. It just works.
I expected no less of the “better” Fairphone 2.

1 Like

I did not know about this setting. However, I tried to enable it in the developer settings, but then the phone just won’t shut down. When I try to power it off, nothing happens. at. all. :-/

I also have the problem and want it to be fixed as early as possible. Some functions like logging (e.g. in xprivacy) is suboptimal with wrong clock values.
Does anybody know what is the reason of the error message running “hwclock -w” ?
I can eliminate Android SELinux because if I set it from “enforcing” to “permissive” there is no change in error behaviour.

1 Like

This is getting even more annoying now thar after the update to16.06 the phone keeps randomly rebooting. I use no data so even with a SIM the clock does not synchronize after reboots without wifi. I have several reboots per day, so my phone is almost always in the 70’s. Now my text messages are sorted in a weird order since messages received in the 70’s obviously are older than recent messages received from the future (or later in the 70’s before the previous reboot). My conversations are now completely messed up and I have to scroll up to find new texts un the middle of other ones. And messages are reset to the top after each reboot.


I confirm this behaviour. Please fix this issue, it is really a fundamental bug.


I have few random reboots (2 or 3 in three months’ time) but my clock resets too on shutting down/rebooting/updating, which is indeed very annoying.


During holidays in another country, I had to restart my phone at some point. And since I had neither WiFi nor mobile data, I ended up using the phone “in 1970” for half a day! So I got a bunch of 40-year-old photographs :frowning: … that is, until the evening, when I got WiFi again.

This issue has to be sorted out.

1 Like