Fairphone Open OS 16.05

Same situation here (encrypted user data, error messages in TWRP) - but the upgrade went just fine. So there must be another reason…

Just to confirm - Bluetooth Audio fixed. Enjoying Spotify in my beaten old Toyota… :slight_smile:


I followed your suggestion, also from @maba007.
Installed Open OS 16.05 and reboot.
The phone started as normal. I checked, yes I have installed update 16.05
O no, :rage: Again the screen says Loading and the whole crap starts again. I am in the loop again of Android optimising, loading etc.
So again I had to clear Dalvik Cache and Cache partition, reboot.
Now the phone starts normal, but all my icons and widgets are gone.
Oké, installing OpenGapps pico zip, TWRP can’t find OpenGapps pico, it’s in the storage instead of the sd-card.
Restarting the phone, trying to move OpenGapps pico zip to the sd-card. no permission.
Sd-card copy to computer, sd-card format in the phone, now I can move OpenGapps pico zip to the sd-card.
Restarting the phone, installing OpenGapps pico.
Restarting the phone, Installing Titanium Backup again.
enable Root, restore the whole lot.
And finally I can use my phone again.
What an exercise. But in the end I succeeded. :relieved: :joy:


Yes, my commands check out the newly tagged version.

Sadly not, but you can run the repo init in your current tree, no need to redownload. Hopfully Fairphone will fix the branches, so a repo sync should be enough.

1 Like

I have the same problem. Thank you for spelling out what you did. I will now try to follow your steps and get out of the boot-loop myself.

Could someone check if the clock still resets after reboots?

It’s not mentioned in the release notes, but I have a feeling it could be related to the previously missing

I’d test it myself, but my touchscreen currently doesn’t work after an unfortunate incident with the toilet… :droplet: :toilet:

It seems like it doesn’t do that anymore. Furthermore, my GPS works now and also the screen doesn’t flicker anymore. I’m very happy with this update! :slight_smile:

Edit: Sorry to hear about your incident! :frowning: I hope your phone recovers soon!

Edit2: Hey @paulakreuzer, after others reporting that the clock still resets on their phone I booted my phone on airplane mode and yes, it still does reset. Without airplane it just gets the info so quick that I couldn’t notice.

1 Like

For me the clock reset still happens. It looks like the time until the click is set is shorter now. Doesn’t happen all the time.
But, yes, great release, I’m also very happy with it!


Confirm that behaviour. Clock reset after reboot is still there.

1 Like

Does anybody have checksums for the prebuilt images?
It seems the download page has not beeen updated yet: http://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-downloads.html

73702b53e239302005ad55ff05539a48 fp2-sibon-16.05.0-image-userdebug.zip
ad533205938163686aaed40a75073fcd fp2-sibon-16.05.0-ota-userdebug.zip
c4ec8ead547ecc7e81bf9a78dc80b78823eeda7f942f1a703869a30593a0cc13 fp2-sibon-16.05.0-image-userdebug.zip
4481c6cbb7cd5bc6fbcd667231dd5ab6560cee1587dbc6dacb8b3da3c8c321fd fp2-sibon-16.05.0-ota-userdebug.zip

if you need more checksums, please message me, I just have these downloaded right now.

I have updated and have no GAPPS but gps it is not working for me. Did you do anything?

Hi @paulakreuzer
With Open OS 16.05, the clock still resets on poweroff or reboot.
Besides, I thought I’d try quickboot again after the upgrade, but I cannot find this setting anywhere anymore :-/
Also, I don’t know where this Setup Wizard is.

Yeah thanks, I’ve been told. :frowning:

Same as with 1.3.6: The quickboot bug is not fixed yet so they decided to remove quickboot alltogether for now. I guess it will be available again when the bug is fixed.

I guess it only appears if you install 16.05 without having Open OS installed before.

THX for the Bluetooth update, works fine!
Still no GPS. My FP doesn’t find my location at all :frowning:

I made some changes to the gps.conf. Now my gps is good.
More information at gps doesn’t work on fp open os with opengapps
If you haven’t installed opengapps, then try µg unified nlp with installation guide from F-Droid.


Isn’t the unified NLP included in Open OS 16.05?

Thanks, that matches my downloads.

SHA256 checksums (sorry forgot to post them before):
c4ec8ead547ecc7e81bf9a78dc80b78823eeda7f942f1a703869a30593a0cc13 fp2-sibon-16.05.0-image-userdebug.zip
4481c6cbb7cd5bc6fbcd667231dd5ab6560cee1587dbc6dacb8b3da3c8c321fd fp2-sibon-16.05.0-ota-userdebug.zip
71659f6b7ef0179b12b10535f3b3506491722cf637d7937acd0dc6fd6cb6ec90 fp2-sibon-16.05.0-ota_from_gms-userdebug.zip

I can’t find Unified Location provider on my phone. Perhaps it is because I have installed Opengapps pico.