FP Open OS 16.07 is now available

Monthly security updates are more important than a whole and problematic version bump. The FP2 is as well a new phone, let it breath some air! :slight_smile:

@freibadschwimmer quoted some working community project, but we are, in this forum, working on a CyanogenMod port (I’ll link it later, I’m on the go). Should you are in the mood to help or have some developer knowledge, please help us to bring it sooner, :wink:

1 Like

Which data did you lose updating? I did not have to restore any backup

I didn’t check all the things I lost. The first thing I noticed is that the Xposed modules options were not activated even after flashing the framework, a lot of my home screen widgets and app shortcuts were missing. So I did a global restore from Titanium and got almost everything back.

Strange. I didn’t lose anything, even though I spent quite some time in bootloop and corresponding restarts

1 Like

Dalvik-Cache is on /data partition: /data/dalvik-cache

1 Like

M_Dammer posted here Release of 16.07? that there exists a code aurora patch for the unsolved RTC bug (wrong date/time after reboot without connection: https://forum.fairphone.com/t/fp-open-os-clock-resets-after-reboot/17635).
Is there any possibility to get this patch for a workaround and if not how could we/I help the development to find the solution faster?

Update: Maybe this suggestion could be a solution for the next version: https://forum.fairphone.com/t/fp-open-os-clock-resets-after-reboot/17635/35

Please force fixing this bug.


I switched to Fairphone Open from a stock Fairphone (updated 1.5.1) : it took 5 minutes and worked fine ! :dizzy:
Thanks! :slight_smile:


Update worked fine for me as well :slight_smile:

1 Like

It was the firewall (AFWall). I turned it off, Updater found something. Funny, because I allowed the Updater to access the internet.

I had the same issue with my firewall… Hmm what’s wrong?

I am interested in testing the FP Open OS but have the same problem as some other people seems to have too. I can not switch using the Updater App. All that’s visible is the 1.5.1 FP OS. Anyone have a solution?

Added: Can I do it using a software like Odin or would that void the warranty?

I don’t know what Odin is, but here you’ll find some instructions on how to install the Open OS:

1 Like

Thank you. Now using FP Open OS :slight_smile:


Odin is a software to flash images to Samsung devices, because Samsung replace the normal fastboot interface with a proprietary one on their devices.

So the helper software should use the fastboot interface available in the FP2.

Updating from 16.06 to 16.07 was no problem. Thanks.

1 Like

I also started Open OS wit 16.07. First impression unfortunately is the missing while buggy setting of display/sleep. This bug doesn’t seem to be new. Display/Sleep can influence power consumption and otherwise annoys me when taking myself time for reading without having display automatically shut down after half a minute

Is there any screenshots or video showing FairphoneOpenOS ?

Also, I’m somewhat sad to not seeing any community driven ROM projects as it’s the case for other phones.

There are, actually. Feel free to contribute!

1 Like

It looks the same as the regular FP OS.

Difference is mainly, it is rooted and without Google mobile services. But it has the same (Fairphone) Launcher and is also close to stock Android, so it looks and feels the same.


If you mean this thread: [SOLVED] Display sleep timeout is limited to 30 seconds
I have no problem on 16.07