Fairphone 2 Open OS is available

Not sure if there is a solution.

I hardly ever use location, and if, then only in situations where I need no play store (i.e. somewhere outdoors).
Though, whenever turning on GPS, play store crashes.

I don’t know if there’s a workaround or fix.

1 Like

I moved this topic to the #software category because I think it fits here better and the other @moderators didn’t have any doubts about it.

1 Like

i now would like to deinstall the open Gapps i have installed. how do i do this?

Very cool! Cheers to you, Fairphone software team!

If you didn’t change the system in any other way (any other flashed ZIP, nor any root-requesting app changing things on /system) you can unzip the system image from the official ZIP and fastboot flash system system.img. This preserve your data because userdata is not touched at all.

If you did modify the system, then that wouldn’t be easy. Most Google Apps are invisible to the user, meaning they do not show on the launcher, and trying to manually find and remove them with some root-enabled app is quite arduous. I followed once this blogpost, but I think the package format in OpenGApps isn’t the same, so you have to engineer something. Try to search the Web for another method or re-flash system.img and apply your changes again if that’s possible.

5 posts were merged into an existing topic: Date and time lost when powering off Fairphone 2 Open OS

Hi there,

I’m using the final FPOSOS and I’ve experienced some mayor and some minor bugs.

[1. Most importantly: mobile data is NOT working at all (provider: Drillisch Germany (O2)).] Solved!
2. The screen glitching as described below appears much stronger than before. My FP is sometimes almost unusable.

These issues still appear:

I hope all descruptions where clear enough.

Thanks. I did it somehow. I still do not know how, played a lot with the telephone, eventually wiped out everything and after a few nervous minutes, I did it…:slight_smile:

Hi guys,
I have some problems, I did what you said, but my screen is black with “Fairphone” in white for 10 minutes. I m not sure that’s good…
Help me please !! ^^’

Have you checked if your APN settings are correct?

Additionally, for me getting mobile to work on beta, I had to enter the APN data as a new entry… Updating the existing entry did not help

@Irina_Spitznagel posted a step-by-step solution here (auf Deutsch :flag_de:). Since you are using a German provider, I assume there is no need to translate her post.
Hope that helps!

Now that I have the Open OS installed, I have a few questions ( probably stupid questions). :astonished:
I have activated the developer option by tapping on the build number 10 times. Under developer options, I have activated root access for apps and add. Is that it? or do I still have to download an app like Superuser through the F-droid store ( which I simply love)? How do I download Titanium Backup when all downloads I find are only through the google play store possible? Thanks again for your help…

@freibadschwimmer @T0bi sorry for making you meshuga!!! I contacted my provider and he told me the same as @Irina_Spitznagel. It just worked. The preset internet wasn’t complete, under “APN” wasn’t written anything, just “Name” was filled in. So thank you both!

PS: The other bugs still appear…

About TitaniumBackup: I downloaded it via raccoon. It is a programme which pretends being a device and in that way it is able to download any .apk from the PlayStore. You need an
existing Google account.

About SuperUser: Same question here… (until now it worked without it but I want to make sure that no unwanted application has root access…)

Since this morning, the “Updater” regularly offers me a “new” version, which I think I already have :wink:
I installed the 16.04 ZIP from code.fairphone.com last week and now get this:

Anyway, installing this fails: It reboots to TWRP, shows this error messages about being unable to mount /data and then reboots back to the normal system:

This is probably happening because my phone is encrypted as it was mentioned here before. So, two questions:

  • What is this update which appeared today :question:
  • Can we update FPOSOS with encrypted storage at some point in the near future? Or will I have to wipe the phone every month? :frowning:

It might be that fp will have to update recovery to something like 3.0.3 or later, if I understood the discussion on G+ correct…

Ohh I was just trying to install the FPOSOS but I am in the same situation with an encrypted phone.

Did you solve the issue?


No, activating root in developer options is enough. Now you just have to give apps root permission when they prompt you. You can download Superuser to have more options managing root access, but that currently doesn’t work with FP OSOS. (The app says root is out of date and changing options within the app have no effect).

It can be downloaded on the official site (direct link). You just need to allow unknown sources in settings > security, but i guess you already did that since you use f-droid.

Yup, same here. Typical little Fairphone bug with OS versions that are not fully polished yet.

It’s not a new version.

1 Like

Ugly methods, but this worked to get the “real” 16.04: I downloaded fp2-sibon-16.04.0-image-userdebug.zip, unzipped it and then only flashed the boot, system and recovery parts of it, because cache, userdata and the -w switch in the instructions sound like they would wipe stuff. As @paulakreuzer wrote this update is apparently only about the version number and not worth this hassle, but it’s good to know that in principle we people with encrypted phones can update the system using fastboot instead of twrp but still not have to wipe userdata. Now the updater is happy and the build number changed from rc1.7 to the real 16.04:

On a side note, I am still unable to change the wallpaper and while rebooting does not reset the clock any more it still moves all apps under “Idle” :frowning2: