Fairphone 2 Open OS is available

Hello everybody,

I am using FPOSOS for about one week now (first beta now the officially released 16.04). I really love to be without google.

But never the less currently the limitiations should not be underestimated.

I think the development team should think about integrating µNLP or at least make it possible to use the non-patched µNLP.

In additon I am missing an alternative for fused. But that might be a task for microG developers.

Finally I would like to thank all Fairphone OS OS developers and all the great developers of microG, XPosed, … !

from where can i get xposed-v83-sdk22-arm.zip ?


or more directly from here: http://dl-xda.xposed.info/framework/sdk22/arm/xposed-v83-sdk22-arm.zip

1 Like

Thanks @freibadschwimmer, @m4lvin

@freibadschwimmer Location schould be turned off all the time? If yes, is there any solution?

Not sure if there is a solution.

I hardly ever use location, and if, then only in situations where I need no play store (i.e. somewhere outdoors).
Though, whenever turning on GPS, play store crashes.

I don’t know if there’s a workaround or fix.

1 Like

I moved this topic to the #software category because I think it fits here better and the other @moderators didn’t have any doubts about it.

1 Like

i now would like to deinstall the open Gapps i have installed. how do i do this?

Very cool! Cheers to you, Fairphone software team!

If you didn’t change the system in any other way (any other flashed ZIP, nor any root-requesting app changing things on /system) you can unzip the system image from the official ZIP and fastboot flash system system.img. This preserve your data because userdata is not touched at all.

If you did modify the system, then that wouldn’t be easy. Most Google Apps are invisible to the user, meaning they do not show on the launcher, and trying to manually find and remove them with some root-enabled app is quite arduous. I followed once this blogpost, but I think the package format in OpenGApps isn’t the same, so you have to engineer something. Try to search the Web for another method or re-flash system.img and apply your changes again if that’s possible.

5 posts were merged into an existing topic: Date and time lost when powering off Fairphone 2 Open OS

Hi there,

I’m using the final FPOSOS and I’ve experienced some mayor and some minor bugs.

[1. Most importantly: mobile data is NOT working at all (provider: Drillisch Germany (O2)).] Solved!
2. The screen glitching as described below appears much stronger than before. My FP is sometimes almost unusable.

These issues still appear:

I hope all descruptions where clear enough.

Thanks. I did it somehow. I still do not know how, played a lot with the telephone, eventually wiped out everything and after a few nervous minutes, I did it…:slight_smile:

Hi guys,
I have some problems, I did what you said, but my screen is black with “Fairphone” in white for 10 minutes. I m not sure that’s good…
Help me please !! ^^’

Have you checked if your APN settings are correct?

Additionally, for me getting mobile to work on beta, I had to enter the APN data as a new entry… Updating the existing entry did not help

@Irina_Spitznagel posted a step-by-step solution here (auf Deutsch :flag_de:). Since you are using a German provider, I assume there is no need to translate her post.
Hope that helps!

Now that I have the Open OS installed, I have a few questions ( probably stupid questions). :astonished:
I have activated the developer option by tapping on the build number 10 times. Under developer options, I have activated root access for apps and add. Is that it? or do I still have to download an app like Superuser through the F-droid store ( which I simply love)? How do I download Titanium Backup when all downloads I find are only through the google play store possible? Thanks again for your help…

@freibadschwimmer @T0bi sorry for making you meshuga!!! I contacted my provider and he told me the same as @Irina_Spitznagel. It just worked. The preset internet wasn’t complete, under “APN” wasn’t written anything, just “Name” was filled in. So thank you both!

PS: The other bugs still appear…

About TitaniumBackup: I downloaded it via raccoon. It is a programme which pretends being a device and in that way it is able to download any .apk from the PlayStore. You need an
existing Google account.

About SuperUser: Same question here… (until now it worked without it but I want to make sure that no unwanted application has root access…)