Fairphone 2 Open OS is available

Since this morning, the “Updater” regularly offers me a “new” version, which I think I already have :wink:
I installed the 16.04 ZIP from code.fairphone.com last week and now get this:

Anyway, installing this fails: It reboots to TWRP, shows this error messages about being unable to mount /data and then reboots back to the normal system:

This is probably happening because my phone is encrypted as it was mentioned here before. So, two questions:

  • What is this update which appeared today :question:
  • Can we update FPOSOS with encrypted storage at some point in the near future? Or will I have to wipe the phone every month? :frowning:

It might be that fp will have to update recovery to something like 3.0.3 or later, if I understood the discussion on G+ correct…

Ohh I was just trying to install the FPOSOS but I am in the same situation with an encrypted phone.

Did you solve the issue?


No, activating root in developer options is enough. Now you just have to give apps root permission when they prompt you. You can download Superuser to have more options managing root access, but that currently doesn’t work with FP OSOS. (The app says root is out of date and changing options within the app have no effect).

It can be downloaded on the official site (direct link). You just need to allow unknown sources in settings > security, but i guess you already did that since you use f-droid.

Yup, same here. Typical little Fairphone bug with OS versions that are not fully polished yet.

It’s not a new version.

1 Like

Ugly methods, but this worked to get the “real” 16.04: I downloaded fp2-sibon-16.04.0-image-userdebug.zip, unzipped it and then only flashed the boot, system and recovery parts of it, because cache, userdata and the -w switch in the instructions sound like they would wipe stuff. As @paulakreuzer wrote this update is apparently only about the version number and not worth this hassle, but it’s good to know that in principle we people with encrypted phones can update the system using fastboot instead of twrp but still not have to wipe userdata. Now the updater is happy and the build number changed from rc1.7 to the real 16.04:

On a side note, I am still unable to change the wallpaper and while rebooting does not reset the clock any more it still moves all apps under “Idle” :frowning2:

Hello. I tried using the "Method 1: Using the OTA package"
I downloaded the latest version onto my phone. Then went to Amaze file manager. Tapping the file to start the installation procedure only opened the zip and then the folder.
Fairphone Updater did not process the file or ask me to restart my phone to complete the installation. Any ideas?

Did you perhaps at any point get the option to open the file with Fairphone updater or Amaze and you chose Amaze?

Ah yes. Now it seems if, within Amaze, I long hold/right click the zipped folder, I can now choose Updater from among the applications to open it with. Brilliant. I’ll continue along that path! Thanks.


Hi all,
I updated from the FPOSOS beta and I had to do the same trick I used to flash the beta, in order to flash it (I had to flash from TWRP the fp2-sibon-16.04.0-ota_from_gms-userdebug ZIP, not the flashable image one).
Also I still suffer of unexpected reboots (I updated yesterday morning and 1 hour ago I had a reboot while unlocking the screen…) and the weird screen scrolling. Didn’t notice yet if there are also ghost touches.
P.S. also updating from the beta erased all user data!
Bye! :slight_smile:

Hi again,
I am not able to choose the external sd card as storage location for backups in Titanium Backup…I allowed writing permission through amaze and I can add folders on the sd card through amaze. However through the settings in Titanium Backup, when I navigate to the sd card as back up location, I can not choose it…Somehwere above, it says this folder is not writable or something (schreibgeschützt). What am I doing wrong? Thanks again.

Look here SD Card no writing permission in FP2

In order to use the SD card to store the backups (if you don’t want to mess with the system file to enable writing on it) you can use the following folder path: /storage/sdcard1/Android/data.
This is the only location where (in their standard behavior) apps are allowed to write on external storage, starting from Android 4.4.4.
Inside this folder there should be a folder named like the full package name, for TB is “com.keramidas.TitaniumBackup” but beware: if you uninstall TB (the same happens for every other app) all the files in this folder will be also removed by the uninstaller so be careful when you use this folder to store apps data on SDCard.
Bye! :slight_smile:

1 Like

I’ve never managed to get Racoon to work. Shame, I liked the concept. If you have any tips please let me know…

Well, I had no problems but I can describe how I did it.
So: I downloaded the .exe and executed it. It was not a proper programme to install but rather a code which you have to run each time. When it opens you have to log in with a Google account and afterwards you can use the search for finding the apps you need. You can click on the app names to get more info. Click on download to download the app. At the flag “transfers” you can see your downloads. Just open the folder link and copy the .apk to your phone and install it.
At which point it didn’t work?


What are peoples thoughts on this so far? I will probably make the switch if it is stable enough. I am sick of Google and don’t use many apps. In terms of stability what is the verdict so far? I have seen a few issues here. Are those widespread? Also, childish as this sounds, is the lock screen the same? Damn, I love those widgets.

FPOSOS works for me as stable as the stock OS, so it runs absolutely fine and stable!


I can confirm that.
Have an uptime of 191 hrs.
Great Job!:ok_hand:

The lock screen info “you fairphone for” still does not get the correct information. Looks like a SELinux issue:

Inode 2 is the persist directory, and FairphoneClockData complains with EACCESS…

1 Like

Thanks. I gave up on it some time ago but I remember running the program, entering a Google ID and password, select the ‘create new’ option, and then it says ‘Login, please wait’ - for ever…

Hmm, I never experienced that bug… Maybe you should try making an account at Google’s website…