English

/e/ OS Q (Android 10) for FP3/FP3+

The official Android 10 beta page is here: https://doc.e.foundation/q-beta-fp3

11 Likes

After a lot of trouble with unlocking the FP3 (still haven’t managed to unlock the FP3+ I have here), installing the beta worked on the first attempt all as instructed (btw, what’s that with the odd “-S 522239K” command line endings? Anyway, I omitted those and it seems to have worked without those).

The very first update /e/OS 0.12-2020110582855 that the /e/ updater offered me took quite a long time to install (around 30 minutes).

Last but not least, I don’t know if this was possible before already, but I like the option to completely drop the battery symbol from the notification bar – just battery percentage is exactly what I prefer :slight_smile:

3 Likes

I assume the “-S 5…K” is to avoid an error that several people had when flashing the image. For those never affected by the error it of course also works without the “-S …”

5 Likes

Perhaps there’s something here …

… or perhaps this works …

3 Likes

Thanks, tried both by now (I only ever get a code through z3ntu’s site, never through Fairphone’s official – the latter always insists I had entered a typo), but keep getting “No such phone” message when I enter the verify code. I’m starting to think it has to do with this specific FP3+ borrowed from Fairphone.

1 Like

Does it include the latest microG or does it work like advertised by adding Exposure Notification? Or is it still without a way to use EN?

But supposedly the 8901 variant of the unlock command doesn’t need this whole code business.

That (“fastboot oem 8901_unlock”) produces “FAILED (remote: unknown command)”.

1 Like

The Q beta of today comes with microG 0.2.10.19420-77. And I don’t see any reference to Exposure Notification in the microG settings.
I think version 0.2.12.x is needed for Exposure Notification. But with the myriad duplicate topics in the /e/ forum I didn’t find the post I was looking for. My guess is that microG gets updated on the test channel before it reaches the dev channel (which the Q beta is based on).

1 Like

What FPOS version is the FP3+ running where the unlock is failing? At least Q-3.A.0054-20200929 seems to require different codes than the Android 9 versions. I haven’t checked the previous two Android 10 versions yet.
The codes from the official unlock page are different to the codes from my old script now.
Is the phone connected to the internet while unlocking?

That’s installed (A.0054).

My unsuccessful attempts (to retrieve a verify code from https://www.fairphone.com/en/bootloader-unlocking-code-for-fairphone-3/ (using my computer, but I remember I once or twice also tried it via the FP3+ itself) keep giving me this error (both when there is a Wi-Fi connection on the phone and if there is none).

The IMEI and/or serial number is incorrect. Please check for typos.

I tried unlocking (using the code from your old scripts because the official unlock page never gave me one, see above) both with the FP3+ offline and online, it would not work. Always “no such phone”.

P.S.: I really suspect there is something wrong with this particular device’s (FP3+) IMEI. I was able to get a verify code from the official unlocking page yesterday with an FP3, and that code was accepted.

1 Like

Running into the similar ‘No such phone’ error / alert here as well for the Fairphone3+.

1 Like

The string 8901_unlock disappeared from aboot between Android 9 2.A.0120 and 2.A.0134, it is also not in aboot from Q-3.A.0054 so this wont work for Android 10.

It would probably make sense to report the problem with the unlock website to the fairphone support.
I only tried the webpage with the imei+serial from my FP3 and it also works fine (but gives different values for each request, even with the same input).

If you are open for adventures, you could try to follow either of the two methods described here (maybe fastboot first and then the hidden edl version):

And I have one more option: If you can get your wifi router (DNS server) to redirect factory.fairphone.com to fp3.lrnz.org (or 148.251.41.172) instead, try unlocking with an arbitrary (non-empty) unlock code while it is connected to that wifi. Opening https://factory.fairphone.com in the browser on the phone should then give a certificate error (e.g. ERR_CERT_COMMON_NAME_INVALID).
Disclaimer: This will probably send your IMEI + Serial to my personal webserver but I promise not to log those requests.

4 Likes

Thanks @_tmp. Did create a suport ticket with Fairphone Customer Support yesterday. If I don’t hear back from them over the next 48 hours shall go the DNS route.

Another thing I noticed was that checking for OS updates results in “Updates are temporarily unavailable. Please try again later.” Wondering if both are related with backend / server issues.

Trust @rae can help.

1 Like

Hi all! I needed a new phone some time ago. But, as I really love FP and privacy, I waited until /e/OS was available. Then I ordered one to FP, but I made the “mistake” of choosing an FP3+ and of not buying it via /e/.

I’ve been following all the updates on the situation of the /e/ release fot the FP3+ (investing lots of time in it), and I understand that it’s a matter of hours having a non-beta version: https://community.e.foundation/t/plussed-fairphone-3/21318/17

However, I can’t wait anymore (I need a phone now and I can’t postpone it more) and I’m going to start using the device with regular Android, although I find it repulsive. I understand Lineage isn’t an option either as of now. And I’m not aware of any other FOSS that might be compatible.

Plus, I’m extreeemeley scared of turning an expensive phone into a brick, so now that I’m going to be used by Google for a while, I think I’ll wait for a moment in which an easy way of installing /e/OS is available.

I think I read somewhere that there’s work in progress regarding an auto-installer for the FP3, so I want to thank the people involved because not everyone concerned about privacy is super tech-savvy. <3

2 Likes

Hi @rohan,

Please share your ticket number and I’ll check with our support team.

Best,
Rae

4 Likes

The Zendesk support ticket # is 397991. Thanks @rae!

1 Like

Hi @Ingo
When you go to this link is write: /e/ now supports officially FP3/FP3+ with Android Q! Kindly refer to the official documentation to install it.

But when you go to this documentation there is a warning that say: Caution: Please note this build is for the original FP3 under Android 9 (Pie) only. The FP3+ and its new camera modules are not supported on /e/OS yet. If you have upgraded your FP3 to the new Android 10 stock OS please do not flash this build.

So we are agree that Andoir Q is Android 10 ? If yes which one is the good option.

Thnaks.

Me too, I don’t understand how contracting they are !
Just another disappointment with the Fairphone 3+

Hi,
I asked this question in the /e/ community forum and received the following information from one of the support moderators “The warning is being removed. Should not show up by Monday when the team would come in and push the change to the documentation server.”
So you can disregard the message with “The FP3+ and its new camera modules are not supported on /e/OS yet.” I guess they are pretty busy trying to rollout the new update.

6 Likes