Difficulty in installing /e/ custom ROM after unlocking bootloader?

Change from stock to /e/ Android 9 went without problems under Linux Mint. Bootloader is unlocked.
Upgrade with same computer to /e/ Android 10 resulted already with the first command in following error:
~$ fastboot -w
wiping userdata…
Invalid erase-block-size 512: must be a power of 2 and at least 4096.
Invalid logical-block-size 512: must be a power of 2 and at least 4096.
mke2fs 1.45.5 (07-Jan-2020)
/tmp/TemporaryFile-Cr5SDk: Nicht implementierte Ext2-Bibliotheksfunktion beim Erstellen des Superblocks
/usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
mke2fs failed: 1
error: Cannot generate image for userdata
Does anyone has an idea?

I moved your question here as the fastboot problem is the same as in an earlier post Difficulty in installing /e/ custom ROM after unlocking bootloader? - #7 by phonefrog

Invalid logical-block-size 512: must be a power of 2 and at least 4096.

This means the platform tools are too old. It’s a frequent problem.


Well, under Linux it does not work at all. Even with updated Linux and latest ADB. Will download tomorrow latest ADB for Win and try again. Will report!

Did you install adb from your distribution or directly from Google? Distribution packages may not get updated beyond a certain version (e.g. on Ubuntu 16.04 that was the case).

Did install directly from Google as I know that ADB in the Linux Repo is not always up to date.
What is funny for me: From stock to /e/ under Android 9 there where no problems at all even with old ADB from Mint repo.

That looks like distribution packages have been used instead of the Google ones (unless you manually installed the latter in /usr/lib)

And are you sure about the stock to /e/ Android 9? Your post from may has the exact same error.


May be confusing but I changed in May from Stock to /e/ with problems. You are right. Than I changed again back to stock. Some weeks ago for testing again to /e/ 9 and this went with Standard repository ADB Linux very well. Was the quickest install ever. Now I tried to go from /e/ 9 to 10 and had the same problem as in May. First try was with Standard Repo ADB and then with new Google download ADB. I also deleted the old ADB prior to installing new one.
Many thanks!
Anyway, I was busy the whole day but this afternoon I will try Win ADB (New download)

I am now completely frustrated. After many hours and with win 10 installed /e/ and locked bootloader again but after several reboot-attempts e did not start. I am now a prisoner in recovery mode and this with locked bootloader. So it seems I cannot install any OS or TWRP. Hope that I did not brick my phone!
Could it help to go back to stock ROM due to the locked bootloader and then if stock is installed unlock bootloader again and install any custom ROM?

Installing the stock Fairphone OS requires unlocking the bootloader, too.
Can you unlock it in the current state?

For a while fastboot oem 8901_unlock could do it without the code procedure, but it seems this was removed …

1 Like

Yes, thanks. After restart pressing down and power it now stats DEVICE STATE-unlocked.
But now: adb devices says: list of devices attached instead of No. of device.

Maybe you forgot to post something, but with Volume-Down and Power you end up in fastboot mode and adb is the wrong tool for fastboot mode.


From fastboot mode I got following message after first command:

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot -w
wiping userdata…
CreateProcess failed: Das System kann die angegebene Datei nicht finden. (2)
error: Cannot generate image for userdata

should I try to continue with next commands:
fastboot flash system_a system.img -S 522239K
or better try to flash any recovery like lineage recovery or TWRP.
If lineage works I would stay there.

That sounds as if the “Minimal ADB and Fastboot” installation does not contain the mke2fs binary.
IIRC nowadays the suggestion is to just install the latest official “platform-tools” package from Google.

1 Like

The latest tools from Google are also the way to go on Windows.


Thanks for your help.
After 2 days hard work /e/ Android 10 is running!!!

I have to admit that the big problems are not caused by /e/ software directly but by 3 reasons:

  1. Tried to flash with Linux. Currently there seems to be a bug within adb/fastboot. Use Windows until further notice. Hope it will run in future under Linux.

  2. Did not use the latest platform-tools. Even under Win Minimal ADB and Fastboot is very old and not suitable. Always download latest platform-tools (do not use Minimal ADB and Fastboot) as adviced by Ingo and AnotherElk.

  3. I made a very severe mistake and continued installation after receiving the info:
    " fastboot -w
    wiping userdata…
    CreateProcess failed: Das System kann die angegebene Datei nicht finden. (2)
    error: Cannot generate image for userdata"

All further commands work (that is the problem!!!) and also lock bootloader but then the system does not start.
This resulted in a completely unusable phone with locked bootloader and I had the impression that it is bricked. With your help I unlocked bootloader again.

After 2 days “try and error” I found a solution by chance:
a) installed the new
This is a very effective and lightweight recovery. With this recovery is was possible to delete and format.
Then back to /e/ it was no problem under win 10 with latest platform-tools to execute commands :
fastboot -w and all other commands.
Hint: You should always copy and paste commands to avoid any typing errors.

I now belong to the happiest people of the world as my FP3 is working again :grinning:


I didn’t have problem to flash /e/ Q with linux (opensuse Leap 15.2) and in the /e/ forum I’m pretty sure there were others who were able to successfully flash it with linux.
True, if someone has access to both OS and it doesn’t work on one, it might be an idea to use the other.
But I wouldn’t advice against linux in general. Otherwise people could refrain from trying to flash /e/ when they simply have no windows machine around.

1 Like

Glad you got it to work.
The install instructions say …

2. Make sure your computer has working adb and fastboot. Setup instructions can be found here.
Please ensure you follow the instructions for adb and Fastboot setup exactly as given in the previous step to avoid unexpected issues during device setup.

/e/ added the additional warning for a reason (which you encountered yourself) … https://community.e.foundation/t/add-a-warning-to-e-install-instructions-to-avoid-fastboot-w-failing/15627.
If the instructions are really being followed in this case, 3. doesn’t happen, and 1. and 2. don’t become a problem.


Fully agree. I have been using Linux for 20 years now and I am very happy with it. Maybe there was something wrong with my drivers.
Continue using Linux!!!


Happy End!
Fairphone runs with /e/ extremely well!!
Thanks for the help!
My promise for the future: Will read all instructions carefully! :wink: