English

Difficulty in installing /e/ custom ROM after unlocking bootloader?

Hi guys. I really am a novice when it comes to this - as the topic highlights, I’ve managed to unlock the bootloader using the guide. I directed everything from Android Suite from my laptop.
Now I’ve downloaded the /e/ package onto an SD, and this is where I’m finding difficulty installing… the ‘how to’ doesn’t specify enough for me to have confidence in final installation. I’ve tried opening the zip files and use the command with no success - before I brick the phone - could someone kindly offer any guidance?

Thanks!

Welcome to the community forum.

Else …

The installation is done with the phone connected to your computer via USB.
You download to your computer.
You run the commands on your computer.

Which steps are unclear or give you trouble in particular?

1 Like

I’ve downloaded the files to my computer and i’m stuck on how to execute the commands. When I’ve tried it doesn’t seem to recognize the file path - now the phone is back on (wiped and unlocked) I’ve had to activate developer access again and usb debugging to connect back up… any specific details from here would be much appreciated! Cheers!

In your terminal window, you must first go to the directory where your fastboot files are (it usually starts in the user directory). Then you can type your command.
The files you want to install must also be in that directory.
Is that the case?

1 Like

Just in case using the command line is a problem, this should help to get going …

Else …

Did the adb and fastboot setup instructions the /e/ installation guide links to in “Requirements” work for you without errors?

I’m not that experienced myself so I’ll only describe the steps I’ve taken myself with no prior knowledge and only the /e/ guide to support me when I installed it on my Fairphone myself 2 days ago.
I’m assuming you’re stuck on the same part that stumped me: you have to browse to the folder where you downloaded the adb and fastboot files, you mentioned you put it onto an SD card if I understand correctly?

When pointing the command prompt at a different you start with “cd destination folder”, but if it’s located on a different drive, you need “cd /D destination folder”.

Then you can test if putting “adb devices” in the command terminal while your phone is plugged in (with USB debugging turned on) prompts a response and after that test if inputting “fastboot devices” in the command terminal (while the phone is in fastboot mode) does the same.

It’s important to know these work just fine like @AnotherElk mentioned.

From your explanation it seems you rather struggle with the part beyond “unzip”, which wasn’t very clear for me either (“Do I unzip using the terminal?”).
After I knew adb services and fastboot worked correctly, I unzipped the /e/ file manually (using Winrar) into the same folder where adb and fastboot were located.
I then opened the command terminal, input “cd /D destination folder”, put the phone in fastboot mode and followed the /e/ install guide from there on.

The short version: from the looks of it I think you got stuck on the "unzip " like I did. I unzipped the files manually to the folder where I had placed the adb services and fastboot files.

2 Likes

Also have a problem after unlocking bootloader. Got this info in the terminal after command “fastboot -w”:

~$ fastboot -w
wiping userdata…
Invalid erase-block-size 512: must be a power of 2 and at least 4096.
Invalid logical-block-size 512: must be a power of 2 and at least 4096.
mke2fs 1.44.1 (24-Mar-2018)
/tmp/TemporaryFile-khssws: Nicht implementierte Ext2-Bibliotheksfunktion beim Erstellen des Superblocks
/usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
mke2fs failed: 1
error: Cannot generate image for userdata

Is there anyone with an idea?

Update the Android Platform Tools?
Hmmm … mine says “18-Aug-2018” … not much better, but worked.

2 Likes

Thanks. Just trying to use my old Windows computer with adb and fastboot. It looks much better and seems to work. Will report.

Installation worked now under Windows 10. I also believe that the Platform Tools of Linux installed from the repository were outdated.
In the beginning Windows fastboot did not find the installation files but I remembered that they must be included into the same file were adb is situated.
One of you gave this info in the past in this or in the /e/-forum. Think it was Ingo.
Many thanks.

That means:
After unzipping you have to open IMG-e-0.9-p-2020042851613-dev-FP3 and to copy the 10 individual .img-files into the file of adb. This file was on my computer under windows (c:) Programme (x86)- Minimal ADB and Fastboot.
Now I hope to enjoy my new /e/!!!

3 Likes

Everything I tested up to now works well. Even LTE works out of the box. For FP2 and FP3 stock ROM is was necessary to correct APN.
But one question:
Last step on installation /e/ was:
" fastboot flashing lock
The last command will ask you to confirm on the device to lock the bootloader. Select LOCK THE BOOTLOADER with Volume + and valid with Power."

Did this but on reboot found in the Developer options that OEM lock is allowed.
If I swipe this in the Developer Option to “not allowed”
What will happen? Would this brick the phone and I could not go back at a later stage to stock ROM?

These are two things

  • the state of the bootloader: can be “locked” or “unlocked”
  • the developer option to allow the bootloader to be unlocked: can be allowed or not allowed

So after fastboot flashing lock you have locked your bootloader but anyone booting the FP3 in fastboot can unlock again.
If you don’t want anyone to unlock the bootloader, you should disable it in the developer options.
Later, when you feel the need to unlock the bootloader again, you can come back to the developer options and set it to allowed.

3 Likes

Change from stock to /e/ Android 9 went without problems under Linux Mint. Bootloader is unlocked.
Upgrade with same computer to /e/ Android 10 resulted already with the first command in following error:
quote
~$ fastboot -w
wiping userdata…
Invalid erase-block-size 512: must be a power of 2 and at least 4096.
Invalid logical-block-size 512: must be a power of 2 and at least 4096.
mke2fs 1.45.5 (07-Jan-2020)
/tmp/TemporaryFile-Cr5SDk: Nicht implementierte Ext2-Bibliotheksfunktion beim Erstellen des Superblocks
/usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
mke2fs failed: 1
error: Cannot generate image for userdata
unquote
Does anyone has an idea?

I moved your question here as the fastboot problem is the same as in an earlier post Difficulty in installing /e/ custom ROM after unlocking bootloader?

Invalid logical-block-size 512: must be a power of 2 and at least 4096.

This means the platform tools are too old. It’s a frequent problem.

2 Likes
2 Likes

Well, under Linux it does not work at all. Even with updated Linux and latest ADB. Will download tomorrow latest ADB for Win and try again. Will report!

Did you install adb from your distribution or directly from Google? Distribution packages may not get updated beyond a certain version (e.g. on Ubuntu 16.04 that was the case).

Did install directly from Google as I know that ADB in the Linux Repo is not always up to date.
What is funny for me: From stock to /e/ under Android 9 there where no problems at all even with old ADB from Mint repo.

That looks like distribution packages have been used instead of the Google ones (unless you manually installed the latter in /usr/lib)

And are you sure about the stock to /e/ Android 9? Your post from may has the exact same error.

3 Likes

May be confusing but I changed in May from Stock to /e/ with problems. You are right. Than I changed again back to stock. Some weeks ago for testing again to /e/ 9 and this went with Standard repository ADB Linux very well. Was the quickest install ever. Now I tried to go from /e/ 9 to 10 and had the same problem as in May. First try was with Standard Repo ADB and then with new Google download ADB. I also deleted the old ADB prior to installing new one.
Many thanks!
Anyway, I was busy the whole day but this afternoon I will try Win ADB (New download)