Device not booting after flashing factory image and locking bootloader


I might have been a tad stupid and most likely bricked my phone, which kinda sucks. I have already contacted support and I assume I’ll have to send it in to get it fixed.

I don’t think anyone but fairphone can help me now, but I’d still like to know where I messed up or whether there might be something wrong with my phone.

Back when I first got my FP4 one of the first things I did was unlocking the bootloader and flashing a patched kernel (most likely to slot b, I don’t think I ever actively touched slot a), but unfortunately the device did not boot with the patched kernel, so I flashed the stock kernel instead, but the device still did not boot. I switched to slot a (without flashing anything) and it still failed to boot.

Later I found out that even if I couldn’t boot from an installed kernel I could just download the kernel to the device (using fastboot boot boot.img) and perform a tethered boot. That means I always needed my PC if I ever wanted to reboot my phone but since there was no reason to reboot I didn’t really mind. I knew that the factory imaged was coming eventually and would fix all my issues. Funnily enough I always needed to be in slot b for this to work, I couldn’t perform a tethered boot from slot a; I was under the assumption that I must have broken something without noticing.

Fast forward to last Friday. My phone did not receive the December updates until it notified me in early February, but installing the updates always failed. It started a countdown saying that it would auto install the updates in X days, which would have been last Saturday, so when the factory images were released on Friday I thought it was perfect timing for me to fix my phone.

I unlocked the critical partitions, flashed the factory image and was able to boot my FP4 without using by PC, nice. I played around for a bit to verify that everything worked and decided to be a good Android user and re-lock my bootloader.

I go into fastboot mode, do fastboot flashing lock, reboot and BAAAAM, phone not booting. I cannot switch slots, since the bootloader is locked and the failed boot countdown does not reduce since it apparently does not even try to boot into anything but fastboot, so it will also never switch slots by itself…

And the get_unlock_ability flag might be persistent across reboots and factory data resets, but not across factory image flashes :frowning:

Any ideas on how to (maybe) fix this mess without sending the device in?
Could there be something wrong with my device?

I’m stupid, I know.
I’m probably still spoiled from my trusty Nexus 5, this thing was unbrickable…

Since I can now edit my posts:

UPDATE 04.03.2022 (from Fairphone support):
I have to send in my device, it’ll probably cost around 30€ for Fairphone to fix it.

UPDATE 15.03.22 (from the repair center):
I just got a quote for a “repair”. They want to replace my phone. Since this statement is from the repair company and not directly from fairphone I do not know if this is final, considering, it should be possible to fix the device and, even if not, a core replacement should still be cheaper. I’m waiting for a response from official fairphone support

Small UPDATE 15.03.22:
Somewhere in the mail I got from the repair center was some contact information, I’ve asked them to elaborate as to why they think my device is unfixable, why EDL won’t work and why replacing the core module won’t work.

Small UPDATE 23.03.22:
Still no word from the repair center, but fairphone got back to me. They’ve been in touch with the repair center and it looks like I’ll get a new quotation (I hope they do not propose buying a new phone again). It should have arrived by now but, as you may have guessed, it did not.

Huge UPDATE 23.03.22:
I still did not receive a quotation from the repair center, but fairphone support just forwarded it to me. What should I say, they now want 29,90€ to fix it :slight_smile:


Sorry, I don’t have advice but at least can tell you it very much sounds like this experience:


For a more in-depth discussion you might want look here as well:

I’m afraid it’s not looking great regarding ways to repair it yourself… :pensive:


I’m aware that I probably won’t be fixing this myself, but I’d still really like to know where I messed up xD


I’am waiting for support answer too with the same situation: bricked device with bootloop in fastboot mode.
Can I ask you to give me in touch when the support answer to you ?

Sure, I’ll update the post once I have any news


Apparently I can’t edit a post, so I cannot update my question, so we go:

I have to send it in and it’ll be ~30€ for them to fix it


Editing is up another user level.



Thank you for the update. It’s great that they can fix it.

I 'am still waiting for an answer from them.

I just got an update apparently they have to replace my phone…

@hirnsushi sorry for tagging you, but you seem pretty knowledgeable. Shouldn’t it be possible to flash a factory image in EDL even with a locked bootloader?

If I’m not mistaken one should even be able to fix it themselves if the appropriate files were leaked?

1 Like

Can you give us details about that update?
Did they say something about the costs of replacement?
Where do you have to send it?


The only update I got from the repair center was - and I quote - ON - DOES NOT SWITCH ON. I mean I kinda knew this

Replacement cost is the cost of a new phone, I had to send my phone to some place in France.
If you want to know anything in particular let me know.

I’ll be in touch with customer support to see if I can get some more information myself

EDIT: To make it clear, the replacement they suggest is a new phone

1 Like

It only seems that way :smirk: I’m just a regular user myself…

But yes, this should be fixable in EDL with the appropriate tools (mainly a signed programmer) or in the communities case with a leaked firehose file.

I mean, I can imagine a scenario where some fuses would have been burnt, that make that route impossible, but I don’t see a reason why that should have happened in your case :thinking:

Wow, that is unacceptable :roll_eyes:

If I read your first post correctly, it still boots into fastboot, so that response seems very uninformed :man_facepalming: I mean, what are they even doing there? :roll_eyes:

Well, at least we are on the same page, so there might be some truth to it, thanks for your quick reply :slight_smile:

1 Like

I have no idea… I’ll try to get more information from support and update here as I learn more.

It still boots into fastboot, yes

1 Like

That is nevertheless the total insanity and fooling on top!!!

You send your defective phone somewhere to France and have to pay the shipping costs.
You get another or new device back.
Also again shipping.
Cost does that you so the cost of a new FP + shipping

You can also buy a new one. Costs the same. But you have the old as a spare parts store.

Since you would be totally stupid if you would get involved in this deal.

As I said, that’s the biggest joke.

I did not have to pay shipping for the device to France, I now have the following three options:

  1. 649€ for a new phone, does not mention anything regarding shipping prices
  2. 18,36€ for them to ship my phone back
  3. 0€ for them to get rid of the phone I sent in

OK, but it remains the same.
I would still never choose the 649 option. Then the old phone is gone.
Then rather the 18.36 and buy a new FP regularly, if you want a new one.
Then you have, as I said, at least a spare parts store.

But the question still remains: Why can’t they reset it to default and lock the bootloader?
To charge an hourly rate of 50-60 Euros for that is still OK. But why produce electrical scrap?

And if they can’t do it on the software side, then just replace the core module. It’s still cheaper and more environmentally friendly than a completely new FP4.
Should be a matter of the heart, especially for FP, right?

Sorry, but I really get pimples with such practices.


That’s pretty close to where I stand right now

Please correct me if I’m wrong, but from what I understand, you:

This should be covered by the warranty, right? I honestly don’t understand why they want to charge you money for this. And especially the full price.