Finally the FP4 ROM file is available

Very tempting indeed, but my time as a full time Software Dev is just twenty years ago.
I guess that until I found all obstacles to fall over by building it myself - the official LOS might already be available. :blush:
I’ll try to read and understand your first suggestion. :sunglasses:

1 Like

Well, with iodéOS you have all these options.
As I said before - you have the option not to install any apps you don’t want by simply deselecting them - even microG - during the setup of iodéOS or later :grinning:

But of course it’s fine if you prefer to wait for the "original " LineageOS :slight_smile:


Here Iodé OS vs /e/OS - Tech News - /e/ community you can read some impressions.


They discuss that iodé does not make their sources open. In detail it’s only the iode App which is closed source.
This app is iodé’s unique selling point. That’s a fair point.
The reason behind it can be read here

But, they forget the /e/ for itself is not better. They have refused to name the sources behind their app store for years. Refuse to name the makers of This is no less a high risk to take

In the end, everyone must decide for themselves


Cleanapk info

1 Like

Hi everyone,
I just saw that the FP Team release the factory image for the FP4. So, i tried to revert from IodeOS this afternoon and i face some difficulties :

  • unlocking bootloader check (device unlock and no secure boot)
  • flashing FP4 factory image check (see the right message at the end of the process)
  • bootloader lock again check
    But now, after erasing action because of the locking of the bootload, my FP4 does not boot into the OS.
    It bootloops into the bootloader and i am not able to unlock it again to try to flash again with your factory image or juste boot into recovery !! I am stuck into the bootloader.

Do you have an idea ? Thanks for your help !!

Welcome to the community forum.

As this is a community forum, not the company, it’s not “our” factory image :wink: .
That being said, if the phone is in fastboot mode (aka bootloader) and connected to your computer …

What does fastboot getvar current-slot say?
If “INVALID”, just set a slot with fastboot --set-active=a or fastboot --set-active=b and try to boot again with fastboot reboot.

Even if it doesn’t boot successfully, setting a valid slot should enable booting into recovery again to e.g. try whether a factory reset might help proceedings.


Thank for your answer :slight_smile:

fastboot getvar current-slot say that current-slot is b !

But, if i try to set the current slot to a for example, fastboot raise an error : 'Slot change is not allowed in lock state'

If i try to fastboot flash unlock, fastboot say 'Flashing unlock is not allowed'.
If i try to go to recovery with physical buttons or inside bootloader, i always go back into booloader.


Hmmm … it was worth a try.
Might be a question for Fairphone support … … unless somebody else here knows what to do.

1 Like

Yes, I open an issue and wait for an answer!

I will publish the answer of support Team in this topic just in case someone face the same issue regarding the revert back process with the factory image !


That sounds a lot like:

I hope that’s not the case and you can get this resolved without having to send your phone to Fairphone :crossed_fingers:


Indeed, it is the same situation expect i try to flash Fairphone factory image and not /e/OS :sweat_smile:

Try everything from your link and nothing work ! I am still stuck with a locked bootloader :pensive:

If I understand it good you have to unlock the bootloader from an other OS before flashing back the original? If you don’t do that it’s bricked?

1 Like

If I understand it right you shouldn’t relock the bootloader after flashing back the original (at least not before being sure it boots well). Else you might run into a bricked device.


I am exactly facing this situation ! I relock the bootloader before the first start of the OS and now i am stuck waiting for the support team answer !

So it is a really good option to start the OS once before relocking the bootloader to ensure that everything work perfectly !


I’m happy others are warned now but I’m very sorry for you that you’ve been the one having had to discover this. I really hope you’ll find some way out!

1 Like

Huh, did you flash the partitions by hand? :thinking:
If you used one of the included scripts, the phone should have rebooted automatically.

It’s better to let it unlocked then install the original ROM , boot and then if everything goes well relock if needed. I guess that’s the best option. I have it unlocked and rooted. Since the original ROM is near stock android another ROM is not necessary for me. In the first place I was interested in rooting and that works without problem.

Nop, I use the script given by the FP Team.
It did not reboot automatically.

It’s better to let it unlocked then install the original ROM , boot and then if everything goes well relock if needed. I guess that’s the best option.

I am agree with you @H_Verweij, i guess i could be noticed in the support article to avoid this kind of problems

Interesting, the script should take care of the reboot automatically (worked for me).
My guess is that it actually did reboot, but to the wrong slot, so it immediately went back to fastboot. That happens all the time and might be hard to notice.

I agree, this has to be mentioned in the docs!