FP4 Root Access is possible, maybe a bit risky

For your reference - Last week, after last Magisk update, my FP4 started to malfunction: Magisk application disappeared after the installation and no more wifi, nor sound. I wanted to go back and manually flash stock FP4 ROM but, after a series of manipulations and re-locked the bootloader, I received the message "Your device is corrupt. It can’t be trusted and will not boot” and I only have access to the Fastboot mode.
I have just contacted support to have them reset the phone to factory defaults…

Was this the message you where seeing? :thinking:
https://source.android.com/security/verifiedboot/boot-flow#no-valid-os-found

What is the state of your bootloader at the moment, am I understanding you correctly that you locked it after installing the stock image?

Thank you @hirnsushi. I think my mistake was to disable the permission to unlock the bootloader in the developer settings : my phone was locked and unlocked at the same time. So I was unable to flash the FP OS stock rom, as it was impossible to flash the critical partitions. I then tried to block the bootloader via fastboot, because I can’t no more enable the permission to unlock bootloader, who was greyed in the developpers settings. At reboot I got once the message “Your device is corrupt. It can’t be trusted and will not boot”

and since then I only have access to the fastboot.
What I didn’t understand is why the upgrade to Magisk v24.3 failed. The application disappeared every time I tried to install it, then no wifi, no sound, the device heated up. I tried to flash the stock rom and bricked my device.
Now I’m waiting for FP support.

I would be really interested in how this happened, so others might avoid that pitfall. This shouldn’t be possible at all :thinking:
On both unlocked FP4s I have access to, the option isn’t even toggleable…

grafik

If I’m understanding you correctly, you updated the Magisk app to 24.3 and tried to update your Magisk installation to 24.3 after that? At what point did the app start crashing, immediately when opened or after the Direct Install process already started?
Did that process mess with sound / wifi or were there reboots in between?

So far I haven’t been able to reproduce that Magisk behaviour on my side :thinking:

I don’t completely understand you there, did you lock the bootloader from fastboot, trying to unlock it again afterwards?
Are you absolutely sure your bootloader is locked? What is the output of fastboot getvar unlocked?

2 Likes

When I saw that my bank application was not working I tried to remove the permission to unlock the bootloader, which was not greyed out in the developer settings. This did not solve the problem, but to reactivate the permission to unlock the bootloader I was asked for the special code again and I was afraid that I would have to erase all my data again, so I left it like that. Later I noticed the option had become greyed out.

First I updated the Magisk app when I saw update notification. Then I directly install Magisk and reboot as usual. After that I saw that the Magisk application had disappeared and that each time I tried to reinstall it, it disappeared again when I wanted to run it. Then I gradually discovered the other malfunctions: wifi, heating, sound.

Yes. First I tried to reinstall Magisk according to your other post, but it failed and things started to get seriously messed up. So I decided to flash the original FP4 rom, but got “Critical partition flashing is not allowed” message in Fastboot.

“unlocked: no”
IMG_0002

All this looks like to this other post Finally the FP4 ROM file is available - #14 by EmmanuelH

Thanks again for your help !

1 Like

Thank you for the clarifications :+1:

Very strange Magisk behaviour indeed. Did you by any chance enable Hide the Magisk app in the Magisk settings before? :thinking: That wouldn’t explain the wifi, thermal and sound issues though…
Without logs we probably won’t be able to figure this out, not that it would help your situation anyway, sorry :see_no_evil: (I’m just curious).

That’s unfortunate, then there’s probably nothing we can do here, I hope your experience with support is better than others :crossed_fingers:

:scream: oh, what a nightmare !

I don’t know about heating, but the wifi and sound issues are probably related to an outdated boot.img. I don’t have time to read through the entire thread right now, but if that happened after an update I’d assume something went wrong and you are currently on a half updated system.

Download the newest image from here and use fastboot boot boot.img to try it without flashing the image

Thank you, but " FAILED (remote: ‘Fastboot boot command is not available in locked device’)"

This command will unfortunately not help you with a locked bootloader :confused:

I intended it more as answering a lingering question for those of use fortunate enough to have a mostly working system (not that I have one…)

You might be on to something here :metal: something similar has happened before

And indeed, booting any image other than current will not only break wifi (that one I knew already), but also sound and likely more. Thermal issues might just stem from some process going haywire and constantly trying to start, never ran from a fastboot booted image long enough to notice anything like it.

Why a Magisk update would somehow lead to a downgraded kernel / boot partititon will remain a mystery for now. The only way I can imagine at this point is if a mismatched (i.e. older) boot.img is flashed to the device, updating through the app shouldn’t cause this.

@cortomalese did you flash a boot.img at some point during that process? :thinking:

Those aren’t my instructions btw, I always recommend to only fastboot boot a patched image and install (and ideally uninstall) Magisk through the app if possible. That way the version of the boot.img doesn’t really matter and Magisk creates a backup that can easily be restored later.

2 Likes

It’s always better to never re lock the bootloader again.

5 Likes

Nope, I just fastboot boot with a patched image of the latest boot.img as you wrote in this post. But I remember once doing adb fastboot instead of adb recovery and it was in fastbootd mode that I continued, but I don’t remember what day or what stage of the procedure.

1 Like

It is possible to end up with different boot images in slot_a and slot_b, thus working wifi and sound while booting with one and issues while booting the other.

But without flashing an outdated image manually that’s probably not trivial to achieve.

Please, the right tutorial for FP4 is here:

1 Like

That has been rectified.

For anyone trying out CalyxOS, here’s a Calyx boot.img patched with Magisk v24.3.

No problems with root / Magisk so far.

2 Likes

Well, the new Update has landed. If Im not misstaken, the steps to update are: reflash original boot.img, update, start old patched boot image, patch newly installed boot image, right? Problem is that I forgot to backup the .103 image. Or does any old image work? .99 is downloadable as part of the offline install zip?!

  1. In Magisk press :wastebasket: Uninstall Magisk“Restore Images”
  2. Install OTA-update and let it perform a full reboot
  3. Use any Magisk patched boot.img you have lying around and fastboot boot from it
  4. Choose “Direct Install” in Magisk as usual, reboot and have fun

It doesn’t matter which boot.img you use, you just won’t get usable wifi (and some other problems) with the older ones, but since we only need to install Magisk that doesn’t really matter.
I uploaded a Magisk patched boot.img from the newest release (A.107) if you need it.

ah! didnt know you can just restore the images. updating now. thank you (:

1 Like