FP4 - very privacy-friendly custom ROM iodéOS

After about 15 tries I could send the avb. So I progress. I doublecheck if I’m on slot a and did a fastboot flashing lock and … device locked and corrupt! :woozy_face:

No chance wether 20220407, nor 20220405.

When I see the “Erasing” logo, what does the device erase?

User data, not more.

:confounded: this is so frustrating… I wonder if it will work out if we try iode3.0 … but not sure if we can go back then? When I tried adb sideload 20220405 I got the feedback that this image is older than the current image and, thus, it won’t be installed !? (even though I of course did the factory reset before) Guess I will still try on the weekend if there is no other update until then. :crossed_fingers:

@FairphoneHulk I followed your instructions on the iode forum from 5th April. But I used 20220407. I ended up in a bootloop aswell.

In my recovery I saw that I was in b. So I set it to a (fastboot --set-active=a) and iode started like a charme. But it was still with open bootloader. Locking the bootloader results in a corrupted device message.

By unlocking in fastboot, flashing the recovery and the key (is that needed?) I can boot iode without problem again (with reset data of course). I still don’t want to start setting up my phone now because I feel like I want a closed bootloader even though I didn’t have it on my FP2 for years now…

you, @wurzelsucher and maybe @Hubble also used version 220407. I used 220405 and did the update to 220407 via OTA.
Don’t know if it is the issue. For me and some others worked my instruction without problems. Don’t know what happens on your side…sorry

1 Like

I now believe that no one has any perspective at all. In which situations and with which constellations it works or does not work.
There are so many different options:

  1. Which OS do you come from, which version?
  2. Where do you want to go, with which version?

I’m now at a point where I can’t say anything more and, above all, can’t recommend anything anymore.

Just my advice, just like @hirnsushi already said: Until there is no and above all tested solution, I would leave the bootloader unlocked.

Lots of discussion, lots of confusion. I myself have no more perspective.

here in this Thread
and here and here

1 Like

I tried 220407, 220405, slot a and b. It doesn’t work for me.
I thought for a short time to test the /e/OS version, but life is short and I don’t want to waist my time with test- and debugging. I bought to use, not hack the phone. I’ll finish my configuration and if the rest work’s, I’ll keep the bootloader unlocked. All my phones before had an unlocked bootloader.
Thanks a lot for your help my green friend :wink:

1 Like

I finished my configuration. Perfekt, 114 apps an only one is not working! :+1:
German DKB banking app told me I should download the latest version for Playstore. But it is the latest version.
I love the rom and the hardware. For somebody who want’s to keep away from app tracking is iodèOS definitely the best choice. But I would recommend to order the phone direct from iode.tech to avoid installation trouble, like I had. Sadly my order was placed before I saw that. Anyway, for me it look`s very good, except for the loader. If I win in lottery I’ll buy another one.
Have fun guy’s and a nice weekend :v::slightly_smiling_face:

2 Likes

Yes, for me it was also 220407 - coming from FPOS (updated).
Today I also tried: flashing FPOS again (There was an issue with flashing the frp partition, but in the end I could boot FPOS) - just to flash 220405 again (as far as I understood this was exactely the setting that worked for you @FairphoneHulk wasn’t it?).
Still… same old problem. I will surrender for now as well and will just use 220407 with an unlocked bootloader…

1 Like

@FairphoneHulk I appreciate your efforts very much. I can totally understand that at some point your support comes to an end. For the next months, I will stay with an open bootloader. And for those who might be interested I will give an overview what I tried else:

I tried changing back to the original FPOS with the instructions from the support page. I came from a very new but updated FP4 before installing iode for the first time. For installing FPOS I unlocked critical now aswell. Everything worked well but this time the get_unlock_ability turned to 0 and in the OS the OEM unlock button turned grey.
After that I tried calyx (because why not…). I installed it successfully. But the OEM unlock button stayed grey. Interestingly after flashing and before the first boot into the system I tried get_unlock_ability in fastboot and it returned 1. After the booting and going back into fastboot it was 0 again.

So in the end I installed iode again because of the developing state of calyx and stay with everything unlocked. The OS works very well and except the wide angle camera and the missing option to show the network usage in the status bar I don’t have any complaint about it.

2 Likes

I use iodéOS on a FP3 and have the option to enable Network traffic monitor under SettingsSystemStatus bar

It’s not available (yet) in 3.0 for FP4.
And as I remember not in 2.4, too.

If I right, it depends on LOS codebase, if it is available or not.

iodé is deliberately very close to LOS. When developing and customizing the ROM, they limit themselves to their own apps and cleaning up Google. Therefore, such features either come into the ROM via the LOS code base or not.

1 Like

Maybe it’s not available for a device with the notch in the top middle (like FP4 as this is where it would be displayed)? Just guessing…

2 Likes

It is available in Calyx, so it’s probably already in the LOS sources for Android 12.
They moved it right next to the clock, looks awful in my opinion:

I’ve never used it, so :man_shrugging:

4 Likes

I have iodéOS 2.4.
Strange, I’ve had this feature with every LOS build I can remember. I thought this was a standard AOSP feature…

hmh yes, that could be a reason why they left out this function…

Your right man.
The problem is definetily the notch
On the right side is no space left for that
On the left side it will take the whole space for notifications

If it would be available, I would never use it. So I don’t miss it.

And yes, it looks realy awful…

On my wifes OPO 6T I use LOS4microG. LOS19 (A12) available since two days now.
6T has also a notch, and traffic monitor does not exist, too.

It is the same minimalistic 19.1 LOS as for iodé. Many missing things actually, but what I don’t find disturbing, because everything important is there

New Beta released today (20220509)

  • Visible changes are new screen off fingerprint switch and location indicator muted for NLP providers.

I updated to the new Beta today (was on the latest 2.4 before) and had bluetooth crashing everytime I tried to enable it.

I managed to make the bluetooth work by:

  • Turning on “Disable Bluetooth Hardware Offload”
  • Clearing the cache and data of the Bluetooth system app
  • Unpairing and pairing all of my bluetooth devices.

:partying_face:

2 Likes

Only if you update
Not on clean installs