English

Camera Error: Can’t connect to the camera

camera
unsolved
Tags: #<Tag:0x00007f9ff67db3b8> #<Tag:0x00007f9ff67db278>

#1

Dear all,

there are at least the following 9 conversations on this topic already, some from 2016 but several also from the past year and recent months:









In all of them, the rear camera can’t connect whereas the front camera works fine.

Like others, I had the same issue 1 month already after receiving the phone in January 2018. Like everyone is told by the support, I was asked to disassemble the phone. As this “solved” the camera error for a couple of days (again, as in the case of others), the whole process of finally ordering and receiving a replacement module was delayed (the camera finally stopped working on May 3, I got a replacement module on June 3). The support was responsive and very kind. I’m just astonished that everyone seems to hope that “disassembling and reassembling” would solve anything and that this is marked as a “solution” in a few conversations in this forum. The many pages in the forum do not provide information beyond what is written in the user guide: “disassembling and reassembling”, “contacting the support”. The one exception is the entertaining remark that “pressing with the thumb on the camera module” temporarily fixes the error for some users. So I discourage readers to go through all of the conversations in the hope of finding an “actual solution”. I spent too much time with already.

Now, after four months during which my replacement module worked fine, the same error comes up again. To me, this strongly suggests that the camera module is simply not reliable. The present conversation aims at counting the number of instances where this occurs to get Fairphone into looking into this issue more closely, solve it thoroughly and prevent the lengthy, repetitive support discussions that all of this causes.

For now: I’ll again go through the disassembling/reassembling and the “taking photographs of the camera” step again, go back to my old support request and hope that I’ll get a replacement camera that will be good for longer than 4 months.


Module caméra not connecting (back camera)
Main camera not working v2
#2

I have the exact same problem : rear camera stopped working with the (approaching) error message “cannot connect to camera”


#3

I have the same problem. New FP2.
I don’t really want to take out the camera and blow on it, as that seems like a poor and temporary fix.


#4

If there is dirt there then cleaning it is the only fix.


#5

+1

Got the same issue with a slight difference: I don’t get a black screen, I get a picture with many thin vertical coloured lines.

Awesome work nailing down the whole camera issue from all the different threads.

It needs a ‘poll’ so people can click up the count, instead of needing to post a message.


#6

You are describing exactly what is happening to the camera of my girlfriend. Many thin, coloured vertical lines and she get’s a message “mediaserver has crashed” after a few seconds.


#7

My FP2 is also affected - from time to time I only get purple lines all over the screen and sometimes an error message when activating the camera. After some attempts it works, so up to now I did not do anything about it, but sometimes it is really annoying.


#8

Taking the phone apart and cleaning the contacts with alcohol as suggested fixed it for me - although I don’t know how long it’ll stay fixed - might need taking apart again at some stage.


#9

Same problem with my FP2, half a year old. I opened the phone, contacts have been clean, no dirt. I’ll contact the support, let’s see if they can help…


#10

Same here, first it just happened occasionally but now I get purple lines and the message that the camera cannot connect every time I try to use the rear camera (while the front is OK). Since I’m un unpractical person I have not dared to dissassembly the module and after having read this thread I understand that it might not solve the problem anyway. Thankful for suggestions on what to do.


#11

Hi all,
Same problem for me! It sometimes work if I press it really hard (I assume it is a contact problem). I cleaned it as much as I could (I yet have to get the tiny screwdriver to do this properly).
My phone is only a few months old. Everything else is fine.


#12

Same problem here. Disassembling/cleaning/reassembling got it working again. Is somewhat tedious to do every 3 or 4 months, though.


#13

Same error message only a few weeks after purchase. Front camera working but not back camera.


#14

I have the same problem. If I take out and replace the camera (with or without blowing on it :0)) it works again for a couple of days. Then it gets colorful lines and can’t cannot.


:fr: Problème avec la caméra principale (FP2 neuf)
#15

I have the same problem. Many thin coloured vertical lines and the message “Camera error”.


#16

Same error here. It’s a connection problem between camera and core module. Disassembling/cleaning/reassembling got it working again.


#17

I also have same problem, phone is a few months old. Problem is intermittent.


#18

I now use Open Camera from the F-Droid store. Works better then the standard camera app with the new camera module.


#19

My FP2 is only a week old (was a Christmas present). I’ve had the same issue: back camera not working, built-in Android Camera app shuts down after trying and failing to connect to the camera. Front camera is fine, but I had to install the Open Camera app (thanks datenteiler) to be able to use it, because the built-in app won’t let you switch between cameras unless both of them are working.
First time it happened (after about 5 days of use), I restarted the phone and that helped. A few more days, and the back camera was dead. Took module out, cleaned contacts, back in - nothing. It was only when I was contacting Support, I had to take the module out again to take a photo (which is what they’re asking you to do). Swapped two of the screws over (didn’t like how the top one sat in the casing), put it back together again. Voila - works now. Let’s see how long that lasts.


#20

Hi, I’ve had my Fairphone 2 for years and installed the new rear camera module in December 2017. It worked fine with the default camera app and with OpenCamera until very recently. I installed the latest system upgrade as the Fairphone Updater app suggested (now on Fairphone OS 18.09.2). The phone then stopped ‘seeing’ the rear camera, and the camera apps just show the selfie camera. The flash/torch also stopped working at the same time. I’ve tried taking the camera module out and cleaning the contacts, but it didnt make any difference, I didn’t think it would because it seems to have been caused by the OS upgrade. Can anyone advise what to do? Is it possible to roll back the OS upgrade?