English

Bugreport: unencrypted wifi impossible to connect in airplane mode - only encrypted wifis seem possible

Brand new out of the box Fairphone3 FP3, applied latest December 2019 update, even before putting any google/accounts to it. So far so good.

Then, just discovered a very frustrating malfeature. Since I actually only use public wifi places, buggy feature of FP3 is that when in airplane mode, and turning wifi back on, it only seems to list wpa2 (wpa?/wep?) - so encrypted only wifi networks thus no unencrypted wifis, even when sitting right next to the access point.

when briefly deactivating airplane mode, then quickly connecting into the public unencrypted wifi, and re-activating airplane mode, briefly killing public wifi as well, but quickly turning back on via the wifi icon, it very briefly shows back the unencrypted public wifi name and seems to maybe somewhat connect to it, just to lose this unencrypted public wifi connection again within seconds and then never making anything of public wifis again ever after.

wanted to force some wifi call tests and so on and then discovered this weird and buggy behaviour :frowning:

anyone?

I don’t have a solution, just a question: what is your motivation behind those settings? “Airplane mode” and “Wifi on” sound like a contradiction to me. Can’t you just switch all unwanted things off and just Wifi on?
But I have to admit I don’t know if airplane mode does more than simply switching all data off. My naive thinking is that it is a shortcut to disabling Wifi, SIM and Bluetooth at the same time without disabling them all manually.

2 Likes

I wanted to enforce/test wifi calling, so decided to disable phone/modem functionality, thats why airplane turning off everything.

But thats not the point, the point is, FP2 never had problems to connect to any type of wifi inside airplane mode. In fact when you are on an airplane, how you gonna connect to a public wifi there with FP3 when having this bug?

Just to compare it to some other Android9 hardware:
A Samsung Galaxy based Android9 phone, works perfectly fine in so called offline-mode (airplane mode) with wifi turned back on and then connecting to this same public wifi here at this place I am currently staying at.

FP3 does not. Such a fail :((((

1 Like

Have you checked different wifi networks?
Do you have an open public network in reach that shows the described behaviour? Please try a wifi scan and report back

  • 2.4GHz or 5GHz
  • channel

Background:
FP3 WLAN/Wifi Problems

By putting airplane mode off when you are allowed to (ie. keep airplane mode on during take off and landing).

No radios should work with airplane mode on. If radios work with airplane mode on, that is a bug.

Would be glad if you wouldnt try to derail this thread, to begin with.

Sitting in the very same position within a wifi range, merely switching airplane mode disables unencrypted wifi networks functionality. thats what this thread is about.

A different android9 based phone is perfectly fine using the very same nonencrypted wifi from the same position. so is the FP3 as well when being in normal non-airplane-mode.

Only inside airplane mode, and activating wifi there, renders unencrypted wifi access impossible.

Your point being airplane mode and if one is allowed to use wifi then, in my case doesnt mean i am sitting i an air-plane at all. airplane mode is simply called offline-mode on other android9 phones as an example for different wording. also there are plenty of other non-flight use-cases to advocate for such a mode.

and it wouldnt be built into android9 os to begin with if this was some illegal or highly problematic or nonstandard thing to do. You can simply have airplane mode activated and wifi mode activated at the same time. This is what this thread is about.

Thanks for refraining from any further derailance ;p

Airplane mode is essentially a software kill switch. If it were a hardware kill switch, your workaround does not work either. What you are using appears to be a bug, and your complaint is a bug within the bug. The workaround you are using shouldn’t work in the first place.

The problem you described is not the core issue, as the expected behavior in airplane mode is that all radios are off. That you prefer to have some radios on is OK, but then you disable the radios you don’t need, and enable the ones you do need. You can add the LTE toggle in the pull down menu, to name an example.

The bugreport should be that WLAN is possible while airplane mode is on; it should not be possible at all. Whether one calls it airplane mode or offline mode does not matter, that is just semantics. Why would people expect to be able to use WLAN when their device is supposed to be offline?

That’s my opinion (IMO based on facts). You’re entitled to yours, and I am entitled to mine.

thats not correct. basically all modern phones (at least Android based) allow usage of Wifi in airplane mode.

Turning Airplane mode on first kills all wireless communication (SIM/Modems, Wifi, Bluetooth, NFC, …) but it is possible to selectively turn Wifi back on. (While reactivating SIM cards is not possible without exiting Airplane mode)

The reason is because some Airlines started to allow Wifi on board, (in some countries) while Cellphone, which has higher Tx Power remained forbidden. That mandated to have Smartphones being capable of turning Wifi on while having the high power modems safely and consistently off. This feature exists in all Android 6 and up phones AFAIK.

And it is not a bug.

Being unable to connect to unencrypted Wifis (whether in Airplane mode or not) however IS a bug.

8 Likes

Enabling airplane mode is a one-time kill-switch of all radios, but then you’re allowed to enable Wi-Fi or Bluetooth individually. I actually have my phone in airplane mode most of the time when I’m at work or I don’t want to be disturbed (way too many marketing bs calls), but still have access to online music, messages, etc,

As for the issue at hand, I’ve seen something similar happening on some Ubuntu machines but I never figured out why does it happen or how to fix it. In my previous machine if I knew the SSID I could just select “connect to hidden wi-fi network” and that would work just fine, even prompt me for the password if I never connected there before.

@abittner Have you tried to select “Add Network” from the Wi-Fi menu screen, and enter the SSID/password manually?

For the record: the FP2 also allows turning wifi back on after you switch to airplane mode, and has no issues connecting to an open network in that case.

2 Likes

TL;DR: I’ll agree to disagree.

I assume a software killswitch works in effect the same as a hardware killswitch (with the difference that you can trust the hardware killswitch better than the software killswitch as it is a galvanic isolation). Apparently it does not, then that is a bug in Android. It probably won’t get fixed though (“working as intended” :roll_eyes:) , while the reported bug might get fixed.

Thanks for the report, I’ve added it in the list here in the thread: Improving the software of FP3

1 Like

Ok I never understood why people tend to rather derail and belittle or deviate threads and questions and problem situations instead of rather refraining from speaking off topic or belittling, sidetracking and distracting from the actual question and situation to be discussed. Sigh.

In the beginning of my FP2 lifecycle for example, I merely used FP2 as a tablet device, and for its infamously poor battery life and performance and behavior, I deliberately deactived (flight mode) the phones modem/radio, and only selectively activated wifi functionality. Mostly I tend to use public wifi realms, so that worked perfectly fine with FP2. With FP3 this functionality is seriously impaired or rather say completely broken.

Also libraries or places where you dont want to take calls, come to my mind, where I deactivate phone functionality completely, also to save battery etc. WiFi is completely disjunct from this.

And I dont know since when I know android based phones, but if my memory serves me right. I remember as far bas as Android5 based phones where I could switch to flight mode and still be able to happily successfully use WiFi when I needed to. So this is far from a bug or unwanted behaviours, this is ridiculous that people come up with such claims.

WiFi is competely different from the broadband mobile data functionality. If you ask me, always has been. To completely differing technologies and varied pieces of technical beasts.

So thanks for all the helpful and all the other entertaining replies in this thread. This needs to become a real bugreport.

Am I right when saying, that with FP3 release, we dont have any more any professional tech. way or place of bugreporting, bugtracker, etc for reporting such things, except here for public scrutiny on our community forums as a good common space for everybody to view and to discuss?

Thanks.

If this were a bug, it would be the best known and in parallel most ignored, most persistent and most useful one I have ever stumbled upon :wink:

Are there any findings concerning the channels of the problematic networks?

Look, I really don’t care that you continuously try to attempt to look like some kind of victim of some kind, as if you’ve experienced some great harm, then call it entertainment, and then attempt to downplay the relevance of a public discussion. If you cannot accept that people have a different viewpoint than yours, why bother on a discussion forum?

If you read bug reports on GitHub or Bugzilla, they also contain discussion. Might be marked as such. As long as everyone stays civil discussion is healthy in bug reports, as it allows to reach a solution.

Even though I don’t give a flying fuck about this bug because I believe the underlying problem is the bug which should be fixed, I still added it to the bug list. That’s the best list we got, for now.

For me this is unwanted behavior. That the behavior has been this way for long, is an appeal to tradition. The Librem 5 with its hardware killswitches does this right, and it only makes the use case for hardware killswitches more valid. On top of that, Google got caught in the past that deactivating WLAN actually did not deactivate it, but still made background scans. Which is an example where a hardware killswitch would’ve been suffice.

DND or just keeping your phone on silent or vibrate only also serves this purpose. I nearly always have my smartphone on vibrate. My colleagues (to my annoyance) don’t, but to each their own.

Yes, to (sic) completely differing (sic) technologies yet both affected when you put airplane mode on.

1 Like

Well, considering the definition of bug is rather broad [1], that’s rather subjective. Some bugs live on for years.

I just tested, iOS 12.4.4 does it too. :woman_shrugging:

I guess the correct way to get rid of it, is to allow more fine grained software kill switches. Or hardware kill switches.

[EDIT]From: Edward Snowden: How Your Cell Phone Spies on You

“Airplane mode does not turn off WiFi anymore” – Edward Snowden (emphasis mine)[/EDIT]

[1] A software bug is an error, flaw or fault in a computer program or system that causes it to produce an incorrect or unexpected result, or to behave in unintended ways. Wikipedia.

I agree with you only partly but …

… why does this “bug” not work as expected just on the FP3? :wink::smiley:

At the risk of dragging the slightly of topic discussion whether WIFI should be possible in flight mode, I’d like to get the following fact to everyone’s attention.

If you have a SIM in the phone, flight mode is the only way to disable the modem.

This is due to a “feature” in Android 9, that it won’t let you disable all SIM cards. In a dual sim phone, you can disable either of them under Settings -> Network&Internet -> SIM cards. But if you try to disable BOTH, you get an error message.

Error, cannot disable all SIMs.

As such, the only way to shut the GSM/LTE RF system down completely happens to be to enter flight mode. (Aside from drastic measures such as removing the SIM cards physically)

If you want to use WIFI with Cellphone RF turned off, as such you MUST do so in flight mode.

5 Likes

I have to say, this actually works for me. I didn’t try it with a real network, I set up a “personal hotspot” with another phone on 2.4 GHz as an “open” network - but that phone didn’t actually have any internet, so it could only test whether connecting to the “accesspoint” works and if an IP address gets assigned.

This was the case. I could connect to this wifi network both in and out of Flight Mode.

As such I cannot reproduce the bug.

I am Using FP3 Build 8901.2.A.0105.20191217

2 Likes

I did not try to set up unencrypted ssid by entering it manually, obviously this would fail at all places where I only visit and never observed or took notes about which open public wifis would be there in the first place.

This bugreport is about the only difference in airplane mode that functionality to normally use and see the unencrypted wifis, thats all. Dunno why people left and right came up with completely unrelated and not even workaround worthy ideas ;p

Cheers.

Well, as mentioned before, I was able to both “see” and “connect” to an open (unencrypted) network in Airplane mode with FP3, so whatever steps are required to reproduce this bug, Airplane mode isn’t all. Either not all phones are affected, or additional side conditions need to be present such as specific Wifi modes or channels used. (802.11b, g, n, a, c x … localization/area restricted channels such as 12 & 13 etc)
there are other threads that suggest FP3 has issues with some combinations, especially in the 5GHz band, sometimes in combo with weak signals…

…

as such its possible that this is only a small part of a larger wifi issue which you triggered by chance.

5 Likes