English

Bug: Android 10 FP3 - Unknown Caller

I’ve reported this to FP already, but I have found a bug with Android 10.

Whenever 4g LTE or WifiCalling are used, any calls that come through this method do not display phone numbers - they show up as Unkown Caller. However, if 4g LTE is disabled and not connected to wifi, caller details display. The same is true with wifi calling. If wifi calling is enabled when connected to wifi, the call comes through as unknown caller. This happens on both SIMs and I have reset my phone to factory default and the issue persists.

I have two sims, both run on the o2 network. One is an o2 sim, the other is on giffgaff. Both are UK networks.

Anyone else getting this problem?

[Edit: I’ve added the current workaround as the solution until FP fix this. Anyone new with this issue should report to FP too]

17 Likes

I have tested with disabling wifi and disabling lte and those advanced call enhancements via lte and downgrading to 3g only, to 2g only even, and all incoming calls worked fine and properly displayed the caller id/recognition thereof.

sorry cant repro over here with android10 upgrade applied to a FP3 phone.

1 Like

Hi Chris, thanks it is exactly how you discribed. We have 2 pcs FP3 updatet to Android 10 and did not see the callers anymore. After disabling 4G it works again. All my Pinned Contacts are also gone. Groups with pinned Contacts also gone. I was using Windows Phones for more than 10 years without any problem. I like the Fairphone Idea, but this android ist build for people who like troubles …
greetings

1 Like

I have same experience since installing Android 10: Using 4G Lte I get ‘Unknown’ calls from people already in my contacts list.

Regards, Vagn

Selbes Problem. Wenn das Telephon mit wlan verbunden ist oder 4G werden eingehende Anrufer nicht angezeigt. Gibt es da eine Lösung.

The solution for now it’s too disable the wifi calling and 4g LTE options

Phone - settings - calling accounts - select sim - wifi calling

Settings - network and internet - mobile network - advanced - enhanced 4g lte mode

Not the best out solutions but until FP fix this is a workaround

6 Likes

Just wanted to chime in and say that I am also affected by this.
Thanks Chris for the workaround

2 Likes

Thanks.

Can I also suggest that you raise a ticket with Fairphone. It might give them some more data on the impact. I said this was a medium impact on my ticket as I have to use wifi calling a lot and not knowing who is calling me in a work capacity is a bit of a problem for me.

Also I found out that if I called them while on wifi calling, they didn’t get my phone number either!

4 Likes

Hello! I have the same problem. Thanks for the workaround! But I hope that there will be an update solving this issue soon…

1 Like

I am not using WiFi calling, so disabling 4G only is an annoying but sufficient workaround.

Not seeing who called is a real issue. Among most of my contacts, it is good habit to call back even without explicit request on the voice box or via text message - I simply could not do that with this bug.

I wonder whether raising more tickets of the same issue makes them faster (there is no public issue tracker, is it?). I hope, they are reading here. As a new watcher of this thread,

  • I hope people “like” the thread instead of posting to many "me too"s with no new message, and
  • please post updates from FP when they have or forecast a solution in your support ticket. TIA.

Btw,

I have this afternoon updated my support ticket to let FP know that others are definitely having this issue and have passed them the link to this topic so they can see the information here. I don’t know whether they need more data on the cause and how wide a problem it is, but I’ve let them know they can update in here too.

4G LTE is the standard for making voice calls over the 4G network. If this isn’t enabled, what happens when you receive a voice call is that you receive the call on 3G. If you watch what happens on your signal on your phone you’ll see it update to 3G before the call rings through. That’s a problem if you don’t get a good 3G signal but do get a good 4G signal. 4G LTE calls are considered HD owing to better quality audio.

I also saw this, but my 4G data is fine and I’ve already checked the APN settings anyhow :slight_smile:

There’s definitely some big fixing that they need to do. It’s a shame they didn’t release this as a beta like they have done with Android 9 on the FP2

1 Like

It should give them an idea about the scope of the problem, so they can set priorities with the software development partner.

As this is a community forum and not the company, Fairphone staff might read along occasionally and engage, or not. You sure can hope, but counting on it will not work out in general.
@Chris_R notified them about this topic, so it’s safe to assume now they’ll have a look here.

2 Likes

I recently updated my FP3 to Android 10. Afterwards all incoming calls are shown as “Unknown”, the phone doesn’t recognize the callers from my contact list.
When I call a contact it is shown correctly in the call history.
Any idea how to fix this?

I moved your post here to avoid duplicates. Please have a look at the thread and the solutions given.

THANK YOU for fixing this problem for me!

1 Like

Hello. After upgrading my FP 3 to Android 10 my phone numbers are shown as " unknown". Have anyone an Idee how to solve this Problem. Thank you.

You might want to read

and

Best wishes,
Thomas

3 Likes

I moved the two last posts here to avoid duplicate discussions.

1 Like

The Fairphone 3 updated to Android 10 and since then incoming calls are shown as “unknown user”
App restrictions are ok. Google Account has all rights in phone and contact functionality…

Has anybody had this problem or has an idea how to solve?

App cache has been deleted yet. next step? factory reset?

Of which app did you delete the cache?