English

Bug: Android 10 FP3 - Unknown Caller

Gibt schon einen längeren Thread dazu:

1 Like

@martinproell Welcome to the forum!
I moved the three last posts here to avoid duplicates, you can have a look at the solution given in the first post

1 Like

Since this problem seems to affect a lot of people and it looks like many just register on this forum to post here, maybe @rae can look into it and take care, that this bug is registered with Fairphone. :wink:

3 Likes

Hey, just for the record, I also have the same problem.

1 Like

Some here.
One Sim card is doing ok, the other one - all the numbers are from “unknown caller”.
Not ok. I really hope that they will solve that problem fast.

I have had this update on my ticket today. I’m not sure why they have suggested the first part of this as that’s only for displaying your number when you call someone and not the other way around. But they clearly know about it

I was suggest everyone who has the issue reports and raises a ticket directly with Fairphone

Dear Chris,

Thank you for contacting us and for supporting Fairphone. I am sorry for the inconvenience caused.

We have recently become aware of this issue related to unknown calls on some Network Operators after the latest software update.

Normally this is related to the SIM card Caller ID set as hidden.

We suggest you do the following:

  1. Go to the phone app (blue icon)
  2. Click on the three dots icon (top right corner) > Calling accounts
  3. Select the sim card you are using
  4. Click on "GSM call settings > additional settings > Caller ID
  5. Select “Show number”
  6. Test if the issue is solved

If that doesn’t solve the issue, indeed as a temporary workaround we suggest disabling the option “Enhanced 4G LTE Mode”.

Additionally, if not specified already, we kindly ask you to specify network provider(s) and country where experiencing the issue. In this way I will log your details and forward them to our developers.

Thank you in advance for your cooperation and patience. We are truly grateful to our customers for supporting our mission.

I will keep your request on-hold and I will get in touch as soon as we have any news.
If you have any questions in the meantime, please let me know.

5 Likes

Habe dasselbe Problem seit dem letzten Update. Anrufer werden als Anonym gekennzeichnet. Gibt es schon eine Lösung?

2 Likes

I got the same answer. Did not work.

2 Likes

Update from my side - I unfortunately got quite a silly answer today (but also including the nonsensical steps to show caller details), not even acknowledging that it is a software problem with Android 10. I have again tried to be very detailed and specific about it. Hopefully this person will now read my ticket completely.

Entsprechend der englischsprachigen Antwort von Fairphone in dem vorherigen Posting, ist das Problem bekannt und man arbeitet an einer Lösung.
Jeder, der das Problem hat, soll beim Fairphone Support ein Ticket aufmachen und auch noch angeben, welche Netzwerk-Provider und welches Land betroffen sind.

3 Likes

Same problem: Workaround didn’t work for me. Business is hurting because I can’t call people back who might have wanted something from me. This is a serious problem, if it isn’t fixed in a few days I’ll have to get myself an unfair but working phone.

That’s really bad and certainly a no-go.

Just to make sure:
The workaround is this one posted by @Chris_R:


This does not work for you? I thought that to be a sure thing.
You then definitely should open a support-ticket with Fairphone and let them know, that it is not working for you. (Don’t forget to include infos on network provider and country.)

I really hope, that this problem gets solved soon.

:bangbang: Maybe, instead of buying a new phone, you could return to Android 9 for the time being, by installing it manually. :bangbang:
Take a look at this support page:

There they state:


4. Download Fairphone OS (Android 9) onto your computer. Currently, the Android 10 version of Fairphone OS is unavailable.

So it seems, they are really working on it to fix it.

3 Likes

Problem solved after today’s update. Great.

1 Like

I also think it is fixed, but I think it may only be partially fixed.

I think they may have disabled 4G LTE calls altogether (although the toggle is still active). Anyone able to receive calls over 4G LTE? You’ll know if you are as you’ll have a 4G signal when the call comes through - else it will drop to 3G or another available option.

1 Like

I have also this problem and my sim works on a swiss network. I’ve reported the problem to FP and I’m waiting for them to fix this bug

I have made the update today and the problem still remain

2 Likes

It may be that the issue requires settings for different operators, so you’ve done the right thing by letting them know. In the meantime, if you disable wifi calling and 4G LTE that’s the best workaround we have right now.

2 Likes

Habe ebenfalls das gleiche Problem seit dem letzten Update.

1 Like

unfortunately can’t confirm

Bei mir das selbe Problem, habe heute die SIM-Karte getauscht, der erste Anruf hat funktioniert, danach wieder alle als “Unbekannt”.

Gibt’s mittlerweile eine Lösung?